summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/adm8211
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/adm8211')
-rw-r--r--net-wireless/adm8211/Manifest1
-rw-r--r--net-wireless/adm8211/adm8211-20060111.ebuild57
-rw-r--r--net-wireless/adm8211/files/01-fix-up-build-breaks-from-2.6.19.patch44
-rw-r--r--net-wireless/adm8211/files/02-Use-ieee80211_generic_get_stats.patch43
-rw-r--r--net-wireless/adm8211/files/03-fix-work_struct-build-breakage.patch69
-rw-r--r--net-wireless/adm8211/files/04-fix-set-essid-for-WE-21.patch26
-rw-r--r--net-wireless/adm8211/files/05-update-email-address-from-jkmaline-cc.hut.fi-to.patch81
-rw-r--r--net-wireless/adm8211/files/06-adm8211-fix-build-breakage-from-skb-mac.raw.patch53
-rw-r--r--net-wireless/adm8211/files/2.6.20-no-config_h.patch20
-rw-r--r--net-wireless/adm8211/files/2.6.20.patch27
-rw-r--r--net-wireless/adm8211/files/linux-2.6.17.patch10
-rw-r--r--net-wireless/adm8211/files/linux-2.6.19.patch32
-rw-r--r--net-wireless/adm8211/metadata.xml5
13 files changed, 468 insertions, 0 deletions
diff --git a/net-wireless/adm8211/Manifest b/net-wireless/adm8211/Manifest
new file mode 100644
index 000000000000..a9f0e75f8d12
--- /dev/null
+++ b/net-wireless/adm8211/Manifest
@@ -0,0 +1 @@
+DIST adm8211-20060111.tar.bz2 36391 SHA256 09e803d78d2b86ca2261960135d280b48ef8ccb9bf1aef877bc5a011bf32bb76
diff --git a/net-wireless/adm8211/adm8211-20060111.ebuild b/net-wireless/adm8211/adm8211-20060111.ebuild
new file mode 100644
index 000000000000..df9c975a56fa
--- /dev/null
+++ b/net-wireless/adm8211/adm8211-20060111.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="IEEE 802.11 wireless LAN driver for adm8211 based cards"
+HOMEPAGE="http://aluminum.sourmilk.net/adm8211/"
+SRC_URI="http://aluminum.sourmilk.net/adm8211/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND="net-wireless/wireless-tools"
+
+BUILD_TARGETS="all"
+
+MODULE_NAMES="adm8211(net:)"
+
+CONFIG_CHECK="WIRELESS_EXT CRYPTO_ARC4"
+ERROR_WIRELESS_EXT="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions"
+ERROR_CRYPTO_ARC4="${P} requires support for ARC4 cipher algorithm (CONFIG_CRYPTO_ARC4)."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 10; then
+ eerror "${P} requires linux-2.6.9 or later."
+ die "${P} requires linux-2.6.9 or later"
+ fi
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/01-fix-up-build-breaks-from-2.6.19.patch
+ epatch ${FILESDIR}/02-Use-ieee80211_generic_get_stats.patch
+ epatch ${FILESDIR}/03-fix-work_struct-build-breakage.patch
+ epatch ${FILESDIR}/04-fix-set-essid-for-WE-21.patch
+ epatch ${FILESDIR}/05-update-email-address-from-jkmaline-cc.hut.fi-to.patch
+ kernel_is ge 2 6 22 && epatch ${FILESDIR}/06-adm8211-fix-build-breakage-from-skb-mac.raw.patch
+
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc Changelog NOTES TODO
+}
diff --git a/net-wireless/adm8211/files/01-fix-up-build-breaks-from-2.6.19.patch b/net-wireless/adm8211/files/01-fix-up-build-breaks-from-2.6.19.patch
new file mode 100644
index 000000000000..1cf8f0a0ac10
--- /dev/null
+++ b/net-wireless/adm8211/files/01-fix-up-build-breaks-from-2.6.19.patch
@@ -0,0 +1,44 @@
+From 108f260412a71614665e8867a3356231af43f374 Mon Sep 17 00:00:00 2001
+From: John W. Linville <linville@tuxdriver.com>
+Date: Tue, 17 Oct 2006 13:02:27 -0400
+Subject: [PATCH] [PATCH] adm8211: fix-up build breaks from 2.6.19
+
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+ adm8211/adm8211_hw.c | 6 ++----
+ 1 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/adm8211/adm8211_hw.c b/adm8211/adm8211_hw.c
+index a45c74d..f95d798 100644
+--- a/adm8211/adm8211_hw.c
++++ b/adm8211/adm8211_hw.c
+@@ -15,7 +15,6 @@
+ * more details.
+ */
+
+-#include <linux/config.h>
+ #include <linux/version.h>
+ #include <linux/module.h>
+ #include <linux/moduleparam.h>
+@@ -737,8 +736,7 @@ static void adm8211_interrupt_rci(struct net_device *dev)
+ }
+
+
+-static irqreturn_t adm8211_interrupt(int irq, void *dev_id,
+- struct pt_regs *regs)
++static irqreturn_t adm8211_interrupt(int irq, void *dev_id)
+ {
+ #define ADM8211_INT(x) if (unlikely(stsr & ADM8211_STSR_ ## x)) printk(KERN_DEBUG "%s: " #x "\n", dev->name)
+
+@@ -2041,7 +2039,7 @@ static int adm8211_open(struct net_device *dev)
+ adm8211_set_rx_mode(dev);
+
+ retval = request_irq(dev->irq, &adm8211_interrupt,
+- SA_SHIRQ, dev->name, dev);
++ IRQF_SHARED, dev->name, dev);
+ if (retval) {
+ printk(KERN_ERR "%s: failed to register IRQ handler\n",
+ dev->name);
+--
+1.5.2.1
+
diff --git a/net-wireless/adm8211/files/02-Use-ieee80211_generic_get_stats.patch b/net-wireless/adm8211/files/02-Use-ieee80211_generic_get_stats.patch
new file mode 100644
index 000000000000..4adfea7c94e9
--- /dev/null
+++ b/net-wireless/adm8211/files/02-Use-ieee80211_generic_get_stats.patch
@@ -0,0 +1,43 @@
+From 192837172632b72c0da82ade708bb6b1ed649b8f Mon Sep 17 00:00:00 2001
+From: Daniel Drake <dsd@gentoo.org>
+Date: Wed, 22 Nov 2006 03:16:13 +0000
+Subject: [PATCH] [PATCH] adm8211: Use ieee80211_generic_get_stats
+
+adm8211 can also benefit from the generic get_stats implementation in my
+previous mail. I am sending the adm8211 patch separately because adm8211 is
+not in Linus' tree.
+
+Signed-off-by: Daniel Drake <dsd@gentoo.org>
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+ adm8211/adm8211_hw.c | 7 -------
+ 1 files changed, 0 insertions(+), 7 deletions(-)
+
+diff --git a/adm8211/adm8211_hw.c b/adm8211/adm8211_hw.c
+index f95d798..a33d239 100644
+--- a/adm8211/adm8211_hw.c
++++ b/adm8211/adm8211_hw.c
+@@ -363,12 +363,6 @@ static void adm8211_clear_sram(struct net_device *dev)
+ ADM8211_CSR_WRITE(WEPCTL, reg);
+ }
+
+-static struct net_device_stats *adm8211_get_stats(struct net_device *dev)
+-{
+- struct ieee80211_device *ieee = netdev_priv(dev);
+- return &ieee->stats;
+-}
+-
+ static void adm8211_set_rx_mode(struct net_device *dev)
+ {
+ struct adm8211_priv *priv = ieee80211_priv(dev);
+@@ -2531,7 +2525,6 @@ static int __devinit adm8211_probe(struct pci_dev *pdev,
+ dev->features |= NETIF_F_LLTX;
+ dev->open = adm8211_open;
+ dev->stop = adm8211_stop;
+- dev->get_stats = adm8211_get_stats;
+ dev->set_multicast_list = adm8211_set_rx_mode;
+ dev->set_mac_address = adm8211_set_mac_address;
+
+--
+1.5.2.1
+
diff --git a/net-wireless/adm8211/files/03-fix-work_struct-build-breakage.patch b/net-wireless/adm8211/files/03-fix-work_struct-build-breakage.patch
new file mode 100644
index 000000000000..95eb22afd638
--- /dev/null
+++ b/net-wireless/adm8211/files/03-fix-work_struct-build-breakage.patch
@@ -0,0 +1,69 @@
+From e8c4bd51047c6f428474f9f0788375a3433684e7 Mon Sep 17 00:00:00 2001
+From: John W. Linville <linville@tuxdriver.com>
+Date: Mon, 11 Dec 2006 18:32:06 -0500
+Subject: [PATCH] [PATCH] adm8211: fix work_struct build breakage
+
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+ adm8211/ieee80211_sta.c | 12 ++++++------
+ adm8211/ieee80211_sta.h | 2 +-
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/adm8211/ieee80211_sta.c b/adm8211/ieee80211_sta.c
+index 032d067..940f742 100644
+--- a/adm8211/ieee80211_sta.c
++++ b/adm8211/ieee80211_sta.c
+@@ -30,7 +30,7 @@
+ #define IEEE80211_MONITORING_INTERVAL (30 * HZ)
+ #define IEEE80211_LINKCHECK_INTERVAL (3 * HZ)
+
+-static void ieee80211_timer(void *ptr);
++static void ieee80211_timer(struct work_struct *work);
+
+ ParseRes ieee802_11_parse_elems(struct ieee80211_info_element *start, size_t len,
+ struct ieee802_11_elems *elems)
+@@ -818,12 +818,12 @@ void ieee80211_start_scan(struct ieee80211_data *data)
+ ieee80211_set_associated(data, 0);
+ data->scan_channel = 0;
+
+- schedule_work(&data->work);
++ schedule_work(&data->work.work);
+ }
+
+ void ieee80211_init(struct ieee80211_data *data)
+ {
+- INIT_WORK(&data->work, ieee80211_timer, data);
++ INIT_DELAYED_WORK(&data->work, ieee80211_timer);
+
+ data->listen_interval = 10;
+ data->ieee->state = IEEE80211_UNINITIALIZED;
+@@ -1187,10 +1187,10 @@ void ieee80211_rx_mgmt(struct ieee80211_data *data, struct sk_buff *skb,
+ dev_kfree_skb(skb);
+ }
+
+-
+-static void ieee80211_timer(void *ptr)
++static void ieee80211_timer(struct work_struct *work)
+ {
+- struct ieee80211_data *data = (struct ieee80211_data *) ptr;
++ struct ieee80211_data *data =
++ container_of(work, struct ieee80211_data, work.work);
+
+ switch (data->ieee->state) {
+ case IEEE80211_INITIALIZED:
+diff --git a/adm8211/ieee80211_sta.h b/adm8211/ieee80211_sta.h
+index b672936..75dc61b 100644
+--- a/adm8211/ieee80211_sta.h
++++ b/adm8211/ieee80211_sta.h
+@@ -47,7 +47,7 @@ struct ieee80211_data {
+ void (*link_monitor)(struct net_device *dev);
+ int (*set_channel)(struct net_device *dev, unsigned int channel);
+
+- struct work_struct work;
++ struct delayed_work work;
+
+ #define AUTO_ASSOCIATE (1<<0)
+ #define AUTO_RATE (1<<1)
+--
+1.5.2.1
+
diff --git a/net-wireless/adm8211/files/04-fix-set-essid-for-WE-21.patch b/net-wireless/adm8211/files/04-fix-set-essid-for-WE-21.patch
new file mode 100644
index 000000000000..dfe807b88682
--- /dev/null
+++ b/net-wireless/adm8211/files/04-fix-set-essid-for-WE-21.patch
@@ -0,0 +1,26 @@
+From 79259f536ba8fd8c500b4506b1a89b06c5264d06 Mon Sep 17 00:00:00 2001
+From: John W. Linville <linville@tuxdriver.com>
+Date: Tue, 27 Mar 2007 13:03:46 -0400
+Subject: [PATCH] [PATCH] adm8211: fix set essid for WE-21
+
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+ adm8211/adm8211_ioctl.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/adm8211/adm8211_ioctl.c b/adm8211/adm8211_ioctl.c
+index 22850cc..7c0f6b6 100644
+--- a/adm8211/adm8211_ioctl.c
++++ b/adm8211_ioctl.c
+@@ -294,7 +294,7 @@ static int adm8211_ioctl_siwessid(struct net_device *dev,
+ if (dwrq->flags == 0 || dwrq->length < 1)
+ len = 0;
+ else
+- len = min(dwrq->length - 1, IW_ESSID_MAX_SIZE);
++ len = min(dwrq->length, IW_ESSID_MAX_SIZE);
+
+ memcpy(priv->ieee80211.ssid, essid, len);
+ priv->ieee80211.ssid_len = len;
+--
+1.5.2.1
+
diff --git a/net-wireless/adm8211/files/05-update-email-address-from-jkmaline-cc.hut.fi-to.patch b/net-wireless/adm8211/files/05-update-email-address-from-jkmaline-cc.hut.fi-to.patch
new file mode 100644
index 000000000000..be7561c6b78c
--- /dev/null
+++ b/net-wireless/adm8211/files/05-update-email-address-from-jkmaline-cc.hut.fi-to.patch
@@ -0,0 +1,81 @@
+From 3e2d468ee087e4d60c007746b68731e08346d620 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <j@w1.fi>
+Date: Sat, 24 Mar 2007 17:15:30 -0700
+Subject: [PATCH] [PATCH] Update my email address from jkmaline@cc.hut.fi to j@w1.fi
+
+After 13 years of use, it looks like my email address is finally going
+to disappear. While this is likely to drop the amount of incoming spam
+greatly ;-), it may also affect more appropriate messages, so let's
+update my email address in various places. In addition, Host AP mailing
+list is subscribers-only and linux-wireless can also be used for
+discussing issues related to this driver which is now shown in
+MAINTAINERS.
+
+Signed-off-by: Jouni Malinen <j@w1.fi>
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+ drivers/net/wireless/adm8211/adm8211_hw.c | 6 +++---
+ adm8211/adm8211_ioctl.c | 2 +-
+ adm8211/ieee80211_sta.c | 2 +-
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/adm8211/adm8211_hw.c b/adm8211/adm8211_hw.c
+index a33d239..2ec950d 100644
+--- a/adm8211/adm8211_hw.c
++++ b/adm8211/adm8211_hw.c
+@@ -2,7 +2,7 @@
+ /*
+ * Linux device driver for ADMtek ADM8211 (IEEE 802.11b MAC/BBP)
+ *
+- * Copyright (c) 2003, Jouni Malinen <jkmaline@cc.hut.fi>
++ * Copyright (c) 2003, Jouni Malinen <j@w1.fi>
+ * Copyright (c) 2004-2005, Michael Wu <flamingice@sourmilk.net>
+ * Some parts copyright (c) 2003 by David Young <dyoung@pobox.com>
+ * and used with permission.
+@@ -43,7 +43,7 @@
+
+ #define RELEASE_DATE "20060414"
+
+-MODULE_AUTHOR("Jouni Malinen <jkmaline@cc.hut.fi>, Michael Wu <flamingice@sourmilk.net>");
++MODULE_AUTHOR("Jouni Malinen <j@w1.fi>, Michael Wu <flamingice@sourmilk.net>");
+ MODULE_DESCRIPTION("Driver for IEEE 802.11b wireless LAN cards based on ADMtek"
+ " ADM8211");
+ MODULE_SUPPORTED_DEVICE("ADM8211");
+@@ -58,7 +58,7 @@ module_param(rx_ring_size, uint, 0);
+ module_param(debug, int, 0);
+
+ static const char *version = KERN_INFO "adm8211: "
+-"Copyright 2003, Jouni Malinen <jkmaline@cc.hut.fi>; "
++"Copyright 2003, Jouni Malinen <j@w1.fi>; "
+ "Copyright 2004-2005, Michael Wu <flamingice@sourmilk.net>\n";
+
+
+diff --git a/adm8211/adm8211_ioctl.c b/adm8211/adm8211_ioctl.c
+index 7c0f6b6..7009dae 100644
+--- a/adm8211/adm8211_ioctl.c
++++ b/adm8211/adm8211_ioctl.c
+@@ -1,7 +1,7 @@
+ /*
+ * Linux driver for ADMtek ADM8211 (IEEE 802.11b wireless LAN card)
+ *
+- * Copyright (c) 2003, Jouni Malinen <jkmaline@cc.hut.fi>
++ * Copyright (c) 2003, Jouni Malinen <j@w1.fi>
+ * Copyright (c) 2004-2005, Michael Wu <flamingice@sourmilk.net>
+ *
+ * This program is free software; you can redistribute it and/or modify
+diff --git a/adm8211/ieee80211_sta.c b/adm8211/ieee80211_sta.c
+index 940f742..3b57915 100644
+--- a/adm8211/ieee80211_sta.c
++++ b/adm8211/ieee80211_sta.c
+@@ -1,7 +1,7 @@
+ /*
+ * IEEE 802.11 station / management functionality
+ *
+- * Copyright (c) 2003, Jouni Malinen <jkmaline@cc.hut.fi>
++ * Copyright (c) 2003, Jouni Malinen <j@w1.fi>
+ * Copyright (c) 2004-2005, Michael Wu <flamingice@sourmilk.net>
+ *
+ * This program is free software; you can redistribute it and/or modify
+--
+1.5.2.1
+
diff --git a/net-wireless/adm8211/files/06-adm8211-fix-build-breakage-from-skb-mac.raw.patch b/net-wireless/adm8211/files/06-adm8211-fix-build-breakage-from-skb-mac.raw.patch
new file mode 100644
index 000000000000..d3bb15d60cca
--- /dev/null
+++ b/net-wireless/adm8211/files/06-adm8211-fix-build-breakage-from-skb-mac.raw.patch
@@ -0,0 +1,53 @@
+>From 72c942ed694ef6249c0df84c0802e7378884e7c7 Mon Sep 17 00:00:00 2001
+From: John W. Linville <linville@tuxdriver.com>
+Date: Tue, 29 May 2007 14:21:23 -0400
+Subject: [PATCH] [PATCH] adm8211: fix build breakage from skb->mac.raw
+
+Use skb_mac_header and related functions instead.
+
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+ drivers/net/wireless/adm8211/adm8211_hw.c | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/adm8211/adm8211_hw.c b/adm8211/adm8211_hw.c
+index 2ec950d..49d79cb 100644
+--- a/adm8211/adm8211_hw.c
++++ b/adm8211/adm8211_hw.c
+@@ -499,7 +499,7 @@ static void adm8211_rx_skb(struct net_device *dev, struct sk_buff *skb)
+ ieee->stats.rx_packets++;
+
+ skb->pkt_type = PACKET_OTHERHOST;
+- skb->mac.raw = skb->data;
++ skb_reset_mac_header(skb);
+
+ netif_rx(skb);
+ dev->last_rx = jiffies;
+@@ -717,7 +717,7 @@ static void adm8211_interrupt_rci(struct net_device *dev)
+ #endif
+ stat->rssi = rssi;
+ stat->rate = rate;
+- skb->mac.raw = skb->data;
++ skb_reset_mac_header(skb);
+ skb->protocol = __constant_htons(ETH_P_802_2);
+ skb_queue_tail(&priv->rx_queue, skb);
+ tasklet_schedule(&priv->rx_tasklet);
+@@ -2376,7 +2376,8 @@ static int adm8211_hard_start_xmit(struct ieee80211_txb *txb,
+
+ int adm8211_80211_header_parse(struct sk_buff *skb, unsigned char *haddr)
+ {
+- memcpy(haddr, skb->mac.raw + 10 + sizeof(struct avs_caphdr), ETH_ALEN); /* addr2 */
++ memcpy(haddr, skb_mac_header(skb) + 10 + sizeof(struct avs_caphdr),
++ ETH_ALEN); /* addr2 */
+ return ETH_ALEN;
+ }
+
+--
+1.5.2.1
+
+
+
+
+
+
+
diff --git a/net-wireless/adm8211/files/2.6.20-no-config_h.patch b/net-wireless/adm8211/files/2.6.20-no-config_h.patch
new file mode 100644
index 000000000000..d565eccca047
--- /dev/null
+++ b/net-wireless/adm8211/files/2.6.20-no-config_h.patch
@@ -0,0 +1,20 @@
+--- adm8211/wep.c.old 2007-06-13 11:06:07.778330430 +1000
++++ adm8211/wep.c 2007-06-13 11:06:16.442008732 +1000
+@@ -10,7 +10,6 @@
+ * more details.
+ */
+
+-#include <linux/config.h>
+ #include <linux/version.h>
+ #include <linux/module.h>
+ #include <linux/init.h>
+--- adm8211/adm8211_hw.c.old 2007-06-13 11:10:12.949927966 +1000
++++ adm8211/adm8211_hw.c 2007-06-13 11:10:23.838266881 +1000
+@@ -29,7 +29,6 @@
+ */
+
+
+-#include <linux/config.h>
+ #include <linux/version.h>
+ #include <linux/module.h>
+ #include <linux/init.h>
diff --git a/net-wireless/adm8211/files/2.6.20.patch b/net-wireless/adm8211/files/2.6.20.patch
new file mode 100644
index 000000000000..10081fbcecbb
--- /dev/null
+++ b/net-wireless/adm8211/files/2.6.20.patch
@@ -0,0 +1,27 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../adm8211/2.6.20.patch
+# Copyright (C) 2007 The T2 SDE Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+--- adm8211/wep.c.vanilla 2007-03-30 09:36:24.446241003 +0200
++++ adm8211/wep.c 2007-03-30 09:44:01.860307546 +0200
+@@ -22,6 +22,8 @@
+ #include <linux/crc32.h>
+ #include <asm/string.h>
+ #include <asm/scatterlist.h>
++#include <asm/page.h>
++#include <linux/mm.h>
+
+ #ifndef CONFIG_CRYPTO
+ #error CONFIG_CRYPTO required to build
diff --git a/net-wireless/adm8211/files/linux-2.6.17.patch b/net-wireless/adm8211/files/linux-2.6.17.patch
new file mode 100644
index 000000000000..f3a65428363d
--- /dev/null
+++ b/net-wireless/adm8211/files/linux-2.6.17.patch
@@ -0,0 +1,10 @@
+--- adm8211/adm8211_hw.c.vanilla 2006-07-01 17:17:45.000000000 +0000
++++ adm8211/adm8211_hw.c 2006-07-01 17:20:10.000000000 +0000
+@@ -39,6 +39,7 @@
+ #include <linux/etherdevice.h>
+ #include <linux/ioport.h>
+ #include <linux/pci.h>
++#include <linux/dma-mapping.h>
+ #include <linux/if_arp.h>
+ #include <linux/delay.h>
+ #include <linux/crc32.h>
diff --git a/net-wireless/adm8211/files/linux-2.6.19.patch b/net-wireless/adm8211/files/linux-2.6.19.patch
new file mode 100644
index 000000000000..9a3f2e57d0a2
--- /dev/null
+++ b/net-wireless/adm8211/files/linux-2.6.19.patch
@@ -0,0 +1,32 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../adm8211/linux-2.6.19.patch
+# Copyright (C) 2007 The T2 SDE Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+--- adm8211/adm8211_hw.c.orig 2005-03-23 12:12:02.000000000 +0100
++++ adm8211/adm8211_hw.c 2007-01-02 16:54:08.000000000 +0100
+@@ -2468,9 +2468,13 @@
+ dev->set_mac_address = adm8211_set_mac_address;
+ dev->hard_start_xmit = adm8211_hard_start_xmit;
+
++#if WIRELESS_EXT >= 12
++#if WIRELESS_EXT < 20
+ dev->get_wireless_stats = adm8211_get_wireless_stats;
++#endif
+ dev->wireless_handlers =
+ (struct iw_handler_def *) &adm8211_iw_handler_def;
++#endif
+
+ init_timer(&priv->timer);
+ priv->timer.data = (unsigned long) dev;
diff --git a/net-wireless/adm8211/metadata.xml b/net-wireless/adm8211/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/net-wireless/adm8211/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>