summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-12-02 14:31:03 +0100
committerPacho Ramos <pacho@gentoo.org>2021-12-02 14:31:03 +0100
commitc56c92516c1f7faa80cf76c5df2938edf50b538f (patch)
tree9c32dc243bbb9250be7aac129e6701083f8a1220 /net-wireless/bluez
parentdev-scheme/tinyscheme: new upstream release (diff)
downloadgentoo-c56c92516c1f7faa80cf76c5df2938edf50b538f.tar.gz
gentoo-c56c92516c1f7faa80cf76c5df2938edf50b538f.tar.bz2
gentoo-c56c92516c1f7faa80cf76c5df2938edf50b538f.zip
net-wireless/bluez: Important bugfixes
This solves disconnecting due to GattCharacteristic1.MTU and reverts a commit introducing a regression when connecting some mouse models Bug: https://bugs.gentoo.org/827706 Bug: https://bugs.gentoo.org/827911 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-wireless/bluez')
-rw-r--r--net-wireless/bluez/bluez-5.62-r3.ebuild294
-rw-r--r--net-wireless/bluez/files/0001-Revert-attrib-Make-use-of-bt_att_resend.patch188
-rw-r--r--net-wireless/bluez/files/bluez-5.62-fix-disconnecting.patch54
3 files changed, 536 insertions, 0 deletions
diff --git a/net-wireless/bluez/bluez-5.62-r3.ebuild b/net-wireless/bluez/bluez-5.62-r3.ebuild
new file mode 100644
index 000000000000..0068b5bad6aa
--- /dev/null
+++ b/net-wireless/bluez/bluez-5.62-r3.ebuild
@@ -0,0 +1,294 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools linux-info python-single-r1 readme.gentoo-r1 systemd udev multilib-minimal
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://www.bluez.org"
+SRC_URI="https://www.kernel.org/pub/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="btpclient cups doc debug deprecated extra-tools experimental +mesh midi +obex +readline selinux systemd test test-programs +udev"
+
+# Since this release all remaining extra-tools need readline support, but this could
+# change in the future, hence, this REQUIRED_USE constraint could be dropped
+# again in the future.
+REQUIRED_USE="
+ extra-tools? ( deprecated readline )
+ test? ( ${PYTHON_REQUIRED_USE} )
+ test-programs? ( ${PYTHON_REQUIRED_USE} )
+"
+
+TEST_DEPS="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+ test? ( ${TEST_DEPS} )
+"
+DEPEND="
+ >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+ btpclient? ( >=dev-libs/ell-0.39 )
+ cups? ( net-print/cups:= )
+ mesh? (
+ >=dev-libs/ell-0.39
+ >=dev-libs/json-c-0.13:=
+ sys-libs/readline:0=
+ )
+ midi? ( media-libs/alsa-lib )
+ obex? ( dev-libs/libical:= )
+ readline? ( sys-libs/readline:0= )
+ systemd? ( sys-apps/systemd )
+ >=sys-apps/dbus-1.6:=
+ udev? ( >=virtual/udev-172 )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bluetooth )
+ test-programs? ( ${TEST_DEPS} )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # Try both udevadm paths to cover udev/systemd vs. eudev locations (#539844)
+ # http://www.spinics.net/lists/linux-bluetooth/msg58739.html
+ # https://bugs.gentoo.org/539844
+ "${FILESDIR}"/${PN}-udevadm-path-r1.patch
+
+ # Fedora patches
+ # http://www.spinics.net/lists/linux-bluetooth/msg40136.html
+ "${FILESDIR}"/0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
+
+ # This reverts commit ac2c2e10b3adb432a572b618c6f53cabb6b3c80b. It
+ # causes problems with Logitech MX wireless input devices (see
+ # https://github.com/bluez/bluez/issues/220 )
+ "${FILESDIR}"/0001-Revert-attrib-Make-use-of-bt_att_resend.patch
+
+ # gatt-client: Fix disconnecting due to GattCharacteristic1.MTU
+ # (from 'master')
+ "${FILESDIR}"/${P}-fix-disconnecting.patch
+)
+
+pkg_setup() {
+ # From http://www.linuxfromscratch.org/blfs/view/svn/general/bluez.html
+ # to prevent bugs like:
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ CONFIG_CHECK="~NET ~BT ~BT_RFCOMM ~BT_RFCOMM_TTY ~BT_BNEP ~BT_BNEP_MC_FILTER
+ ~BT_BNEP_PROTO_FILTER ~BT_HIDP ~CRYPTO_USER_API_HASH ~CRYPTO_USER_API_SKCIPHER ~RFKILL"
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206815
+ if use mesh || use test; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_USER
+ ~CRYPTO_USER_API ~CRYPTO_USER_API_AEAD ~CRYPTO_AES ~CRYPTO_CCM ~CRYPTO_AEAD ~CRYPTO_CMAC"
+ fi
+ linux-info_pkg_setup
+
+ if use test || use test-programs; then
+ python-single-r1_pkg_setup
+ fi
+
+ if ! use udev; then
+ ewarn
+ ewarn "You are installing ${PN} with USE=-udev. This means various bluetooth"
+ ewarn "devices and adapters from Apple, Dell, Logitech etc. will not work,"
+ ewarn "and hid2hci will not be available."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ default
+
+ # http://www.spinics.net/lists/linux-bluetooth/msg38490.html
+ if ! use systemd; then
+ eapply "${FILESDIR}"/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch
+ fi
+
+ eautoreconf
+
+ if use cups; then
+ # Only not .am to not need to run eautoreconf only because of this
+ sed -i \
+ -e "s:cupsdir = \$(libdir)/cups:cupsdir = $(cups-config --serverbin):" \
+ Makefile.{in,tools} || die
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ # readline is automagic when client is enabled
+ # --enable-client always needs readline, bug #504038
+ # --enable-mesh is handled in the same way
+ ac_cv_header_readline_readline_h=$(multilib_native_usex readline)
+ ac_cv_header_readline_readline_h=$(multilib_native_usex mesh)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # deps not used for the library
+ {DBUS,GLIB}_{CFLAGS,LIBS}=' '
+ )
+ fi
+
+ econf \
+ --localstatedir=/var \
+ --disable-android \
+ --enable-datafiles \
+ --enable-optimization \
+ $(use_enable debug) \
+ --enable-pie \
+ --enable-threads \
+ --enable-library \
+ --enable-tools \
+ --enable-manpages \
+ --enable-monitor \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ $(multilib_native_use_enable btpclient) \
+ $(multilib_native_use_enable btpclient external-ell) \
+ $(multilib_native_use_enable cups) \
+ $(multilib_native_use_enable deprecated) \
+ $(multilib_native_use_enable experimental) \
+ $(multilib_native_use_enable mesh) \
+ $(multilib_native_use_enable mesh external-ell) \
+ $(multilib_native_use_enable midi) \
+ $(multilib_native_use_enable obex) \
+ $(multilib_native_use_enable readline client) \
+ $(multilib_native_use_enable systemd) \
+ $(multilib_native_use_enable test-programs test) \
+ $(multilib_native_use_enable udev) \
+ $(multilib_native_use_enable udev hid2hci) \
+ $(multilib_native_use_enable udev sixaxis)
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -f Makefile -f - libs \
+ <<<'libs: $(lib_LTLIBRARIES)'
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+
+ # Only install extra-tools when relevant USE flag is enabled
+ if use extra-tools; then
+ ewarn "Upstream doesn't support using this tools and their bugs are"
+ ewarn "likely to be ignored forever, also they can break without"
+ ewarn "previous announcement."
+ ewarn "Upstream also states all this tools are not really needed,"
+ ewarn "then, if you still need to rely on them, you must ask them"
+ ewarn "to either install that tool by default or add the needed"
+ ewarn "functionality to the existing 'official' tools."
+ ewarn "Please report this issues to:"
+ ewarn "http://www.bluez.org/development/lists/"
+
+ # Upstream doesn't install this, bug #524640
+ # http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
+ # http://comments.gmane.org/gmane.linux.bluez.kernel/54564
+ dobin tools/btmgmt
+ # gatttool is only built with readline, bug #530776
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1141909
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=720486
+ # https://bugs.archlinux.org/task/37686
+ dobin attrib/gatttool
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1699680
+ dobin tools/avinfo
+ fi
+
+ # Not installed by default after being built, bug #666756
+ use btpclient && dobin tools/btpclient
+
+ # Unittests are not that useful once installed, so make them optional
+ if use test-programs; then
+ # Drop python2 only test tools
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206819
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/simple-player || die
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206821
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/test-hfp || die
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206823
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/test-sap-server || die
+
+ python_fix_shebang "${ED}"/usr/$(get_libdir)/bluez/test
+
+ for i in $(find "${ED}"/usr/$(get_libdir)/bluez/test -maxdepth 1 -type f ! -name "*.*"); do
+ dosym "${i}" /usr/bin/bluez-"${i##*/}"
+ done
+ fi
+ else
+ emake DESTDIR="${D}" \
+ install-pkgincludeHEADERS \
+ install-libLTLIBRARIES \
+ install-pkgconfigDATA
+ fi
+}
+
+multilib_src_install_all() {
+ # We need to ensure obexd can be spawned automatically by systemd
+ # when user-session is enabled:
+ # http://marc.info/?l=linux-bluetooth&m=148096094716386&w=2
+ # https://bugs.gentoo.org/show_bug.cgi?id=577842
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804908
+ # https://bugs.archlinux.org/task/45816
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1318441
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1389347
+ if use systemd; then
+ dosym obex.service /usr/lib/systemd/user/dbus-org.bluez.obex.service
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ keepdir /var/lib/bluetooth
+
+ # Upstream don't want people to play with them
+ # But we keep installing them due to 'historical' reasons
+ insinto /etc/bluetooth
+ local d
+ for d in input network; do
+ doins profiles/${d}/${d}.conf
+ done
+ # Setup auto enable as Fedora does for allowing to use
+ # keyboards/mouse as soon as possible
+ sed -i 's/#\[Policy\]$/\[Policy\]/; s/#AutoEnable=false/AutoEnable=true/' src/main.conf || die
+ doins src/main.conf
+
+ newinitd "${FILESDIR}"/bluetooth-init.d-r5 bluetooth
+ newconfd "${FILESDIR}"/bluetooth-conf.d bluetooth
+
+ einstalldocs
+ use doc && dodoc doc/*.txt
+ # Install .json files as examples to be used by meshctl
+ if use mesh; then
+ dodoc tools/mesh-gatt/*.json
+ local DOC_CONTENTS="Some example .json files were installed into
+ /usr/share/doc/${PF} to be used with meshctl. Feel free to
+ uncompress and copy them to ~/.config/meshctl to use them."
+ readme.gentoo_create_doc
+ fi
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+ systemd_reenable bluetooth.service
+
+ has_version net-dialup/ppp || elog "To use dial up networking you must install net-dialup/ppp"
+ use mesh && readme.gentoo_print_elog
+}
diff --git a/net-wireless/bluez/files/0001-Revert-attrib-Make-use-of-bt_att_resend.patch b/net-wireless/bluez/files/0001-Revert-attrib-Make-use-of-bt_att_resend.patch
new file mode 100644
index 000000000000..a8475b0c4273
--- /dev/null
+++ b/net-wireless/bluez/files/0001-Revert-attrib-Make-use-of-bt_att_resend.patch
@@ -0,0 +1,188 @@
+From 697866e210e4e2dce14c95f7a7243e9b9128d01f Mon Sep 17 00:00:00 2001
+From: Adam Williamson <awilliam@redhat.com>
+Date: Sun, 7 Nov 2021 15:10:53 -0800
+Subject: [PATCH] Revert "attrib: Make use of bt_att_resend"
+
+This reverts commit ac2c2e10b3adb432a572b618c6f53cabb6b3c80b. It
+causes problems with Logitech MX wireless input devices (see
+https://github.com/bluez/bluez/issues/220 and
+https://bugzilla.redhat.com/show_bug.cgi?id=2019970 ).
+---
+ attrib/gattrib.c | 95 +++++++++++++++++++++++++++++++++++++-----------
+ 1 file changed, 73 insertions(+), 22 deletions(-)
+
+diff --git a/attrib/gattrib.c b/attrib/gattrib.c
+index 270a37ebe..bc7d4f22c 100644
+--- a/attrib/gattrib.c
++++ b/attrib/gattrib.c
+@@ -41,8 +41,13 @@ struct _GAttrib {
+ struct queue *track_ids;
+ };
+
++struct id_pair {
++ unsigned int org_id;
++ unsigned int pend_id;
++};
++
+ struct attrib_callbacks {
+- unsigned int id;
++ struct id_pair *id;
+ GAttribResultFunc result_func;
+ GAttribNotifyFunc notify_func;
+ GDestroyNotify destroy_func;
+@@ -51,6 +56,32 @@ struct attrib_callbacks {
+ uint16_t notify_handle;
+ };
+
++static bool find_with_org_id(const void *data, const void *user_data)
++{
++ const struct id_pair *p = data;
++ unsigned int orig_id = PTR_TO_UINT(user_data);
++
++ return (p->org_id == orig_id);
++}
++
++static struct id_pair *store_id(GAttrib *attrib, unsigned int org_id,
++ unsigned int pend_id)
++{
++ struct id_pair *t;
++
++ t = new0(struct id_pair, 1);
++ if (!t)
++ return NULL;
++
++ t->org_id = org_id;
++ t->pend_id = pend_id;
++
++ if (queue_push_tail(attrib->track_ids, t))
++ return t;
++
++ return NULL;
++}
++
+ GAttrib *g_attrib_new(GIOChannel *io, guint16 mtu, bool ext_signed)
+ {
+ gint fd;
+@@ -119,6 +150,9 @@ static void attrib_callbacks_destroy(void *data)
+ if (cb->destroy_func)
+ cb->destroy_func(cb->user_data);
+
++ if (queue_remove(cb->parent->track_ids, cb->id))
++ free(cb->id);
++
+ free(data);
+ }
+
+@@ -148,7 +182,7 @@ void g_attrib_unref(GAttrib *attrib)
+ bt_att_unref(attrib->att);
+
+ queue_destroy(attrib->callbacks, attrib_callbacks_destroy);
+- queue_destroy(attrib->track_ids, NULL);
++ queue_destroy(attrib->track_ids, free);
+
+ free(attrib->buf);
+
+@@ -261,6 +295,7 @@ guint g_attrib_send(GAttrib *attrib, guint id, const guint8 *pdu, guint16 len,
+ struct attrib_callbacks *cb = NULL;
+ bt_att_response_func_t response_cb = NULL;
+ bt_att_destroy_func_t destroy_cb = NULL;
++ unsigned int pend_id;
+
+ if (!attrib)
+ return 0;
+@@ -282,47 +317,62 @@ guint g_attrib_send(GAttrib *attrib, guint id, const guint8 *pdu, guint16 len,
+
+ }
+
+- if (id == 0)
+- id = bt_att_send(attrib->att, pdu[0], (void *) pdu + 1,
+- len - 1, response_cb, cb, destroy_cb);
+- else {
+- int err;
+-
+- err = bt_att_resend(attrib->att, id, pdu[0], (void *) pdu + 1,
+- len - 1, response_cb, cb, destroy_cb);
+- if (err)
+- return 0;
+- }
++ pend_id = bt_att_send(attrib->att, pdu[0], (void *) pdu + 1, len - 1,
++ response_cb, cb, destroy_cb);
+
+- if (!id)
+- return id;
++ /*
++ * We store here pair as it is easier to handle it in response and in
++ * case where user request us to use specific id request - see below.
++ */
++ if (id == 0)
++ id = pend_id;
+
+ /*
+ * If user what us to use given id, lets keep track on that so we give
+ * user a possibility to cancel ongoing request.
+ */
+- if (cb) {
+- cb->id = id;
+- queue_push_tail(attrib->track_ids, UINT_TO_PTR(id));
+- }
++ if (cb)
++ cb->id = store_id(attrib, id, pend_id);
+
+ return id;
+ }
+
+ gboolean g_attrib_cancel(GAttrib *attrib, guint id)
+ {
++ struct id_pair *p;
++
+ if (!attrib)
+ return FALSE;
+
++ /*
++ * If request belongs to gattrib and is not yet done it has to be on
++ * the tracking id queue
++ *
++ * FIXME: It can happen that on the queue there is id_pair with
++ * given id which was provided by the user. In the same time it might
++ * happen that other attrib user got dynamic allocated req_id with same
++ * value as the one provided by the other user.
++ * In such case there are two clients having same request id and in
++ * this point of time we don't know which one calls cancel. For
++ * now we cancel request in which id was specified by the user.
++ */
++ p = queue_remove_if(attrib->track_ids, find_with_org_id,
++ UINT_TO_PTR(id));
++ if (!p)
++ return FALSE;
++
++ id = p->pend_id;
++ free(p);
++
+ return bt_att_cancel(attrib->att, id);
+ }
+
+ static void cancel_request(void *data, void *user_data)
+ {
+- unsigned int id = PTR_TO_UINT(data);
++ struct id_pair *p = data;
+ GAttrib *attrib = user_data;
+
+- bt_att_cancel(attrib->att, id);
++ bt_att_cancel(attrib->att, p->pend_id);
+ }
+
+ gboolean g_attrib_cancel_all(GAttrib *attrib)
+@@ -330,8 +380,9 @@ gboolean g_attrib_cancel_all(GAttrib *attrib)
+ if (!attrib)
+ return FALSE;
+
++ /* Cancel only request which belongs to gattrib */
+ queue_foreach(attrib->track_ids, cancel_request, attrib);
+- queue_remove_all(attrib->track_ids, NULL, NULL, NULL);
++ queue_remove_all(attrib->track_ids, NULL, NULL, free);
+
+ return TRUE;
+ }
+--
+2.33.1
+
diff --git a/net-wireless/bluez/files/bluez-5.62-fix-disconnecting.patch b/net-wireless/bluez/files/bluez-5.62-fix-disconnecting.patch
new file mode 100644
index 000000000000..8eff9dc006dd
--- /dev/null
+++ b/net-wireless/bluez/files/bluez-5.62-fix-disconnecting.patch
@@ -0,0 +1,54 @@
+From ebf2d7935690c00c7fd12768177e2023fc63c9fe Mon Sep 17 00:00:00 2001
+From: Javier de San Pedro <dev.git@javispedro.com>
+Date: Sat, 27 Nov 2021 23:21:36 +0100
+Subject: gatt-client: Fix disconnecting due to GattCharacteristic1.MTU
+
+After the MTU dbus property patches in 5.62 we are seeing bluetoothd
+terminate frequently with "Disconnected from D-Bus. Exiting." msgs.
+Apparently this is because bluetoothd sent an invalid reply to a D-Bus
+Property Get (for GattCharacteristic1's MTU).
+Multiple issues in bluez Github.com project reported similar behavior;
+at least #235 (see Fixes:), #219, and likely #238.
+
+When the Characteristic1 object is still cached/alive, but the
+underlying att connection is not (e.g. someone just called Disconnect),
+the property getter (characteristic_get_mtu) right now returns false.
+However, gdbus seems to ignore the return value and sends the empty reply
+message anyway (rather than a dbus error?), and this seems to cause
+the dbus connection to be terminated (due to the ill-formed reply?).
+bluetoothd then aborts.
+
+This patch makes the property value BT_ATT_DEFAULT_LE_MTU if the
+underlying att object does not exist, rather than returning an invalid
+message. This is consistent with the existing PropertyChanged signal
+behavior (we will emit a PropertyChange only if a larger MTU is
+exchanged), and fixes the issue on my machines.
+An alternative could be to change gdbus behavior, but I'm not sure if we
+are allowed to return an error here anyway without causing problems in
+other dbus libraries/wrappers.
+
+Fixes: aaa0c4996ae9 ("gatt: Add implementation of GattCharacteristic1.MTU")
+Fixes: https://github.com/bluez/bluez/issues/235
+---
+ src/gatt-client.c | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/src/gatt-client.c b/src/gatt-client.c
+index de18bea97..6ee984db9 100644
+--- a/src/gatt-client.c
++++ b/src/gatt-client.c
+@@ -883,10 +883,7 @@ static gboolean characteristic_get_mtu(const GDBusPropertyTable *property,
+ uint16_t mtu;
+
+ att = bt_gatt_client_get_att(gatt);
+- if (!att)
+- return FALSE;
+-
+- mtu = bt_att_get_mtu(att);
++ mtu = att ? bt_att_get_mtu(att) : BT_ATT_DEFAULT_LE_MTU;
+
+ dbus_message_iter_append_basic(iter, DBUS_TYPE_UINT16, &mtu);
+
+--
+cgit 1.2.3-1.el7
+