summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-29 22:25:05 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:43:08 -0400
commit72ae9bb6e2042f333f606e81cc57271dd19be540 (patch)
treeed3b87967c97cd05443686f137158adfe8000ccf /net-wireless/gr-iqbal
parentnet-wireless/gnuradio: bump (diff)
downloadgentoo-72ae9bb6e2042f333f606e81cc57271dd19be540.tar.gz
gentoo-72ae9bb6e2042f333f606e81cc57271dd19be540.tar.bz2
gentoo-72ae9bb6e2042f333f606e81cc57271dd19be540.zip
net-wireless/gr-iqbal: bumps
prep for gr3.8 upgrade Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/gr-iqbal')
-rw-r--r--net-wireless/gr-iqbal/Manifest3
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.37.3.ebuild (renamed from net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild)12
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild29
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-9999.ebuild14
4 files changed, 42 insertions, 16 deletions
diff --git a/net-wireless/gr-iqbal/Manifest b/net-wireless/gr-iqbal/Manifest
index 15cb0b0a1fa8..223d546adbe4 100644
--- a/net-wireless/gr-iqbal/Manifest
+++ b/net-wireless/gr-iqbal/Manifest
@@ -1 +1,2 @@
-DIST gr-iqbal-0.37.2.tar.xz 71340 BLAKE2B 1605c520a7ff0088a24ea79e181b36261cdf849438aa3ef4a499228a372297017d3bbc4c96279f9b1bceb7b690aa7b6081b6e970a337e03c766dab5149fff199 SHA512 00037a535219ebe3b5244d4a09355cc74bf17aa6a935bff135e9d7c7c7f6bc1c8b7a29edc02132dbacda2c41efa3613c09e6fdc222472e58d88c4c076736842e
+DIST gr-iqbal-0.37.3.tar.gz 105924 BLAKE2B 25eddc718e2b6d5c679a0d6f199d9d49ff69b535502bf9449d7561ae8c172014a5058cee7ef692a36ec518408747d63d01a23c963f45a5d4b5f58175c49f5bbc SHA512 04ac24e2cc8ebf458088e4d8b005818d3f2496fdc801779dc276c21ee751520039078d5157022a886494f8d62b586d69c703e83fb0539e775ce95e3ca34cf374
+DIST gr-iqbal-0.38.1.tar.gz 106392 BLAKE2B 009f36dcf34127e80d8afa91196906a2b2dc8696dd16f9e7d6d9011d9baf2e4c2dfac78eb1acabcbe52dd88ce08b15f8da407b141585f2c60fd63549218576e0 SHA512 b2f74bba560478b746ad1b11d70202fa2d396462f4806918379543fc69a915346745b34f9ffb2914091ec677295f6f378a5b22641c26aa37c5e23092623b5cee
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.37.3.ebuild
index 1ed8501d81d5..c1920c8ed5ed 100644
--- a/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.37.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils python-single-r1
@@ -11,11 +11,9 @@ HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://git.osmocom.org/gr-iqbal"
- KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
else
- SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
fi
@@ -23,9 +21,9 @@ LICENSE="GPL-3"
SLOT="0/${PV}"
IUSE=""
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="=net-wireless/gnuradio-3.7*:0=[${PYTHON_SINGLE_USEDEP}]
net-libs/libosmo-dsp:=
dev-libs/boost:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
new file mode 100644
index 000000000000..718058c00505
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8})
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
+else
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
index 1ed8501d81d5..718058c00505 100644
--- a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
+++ b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8})
inherit cmake-utils python-single-r1
@@ -11,11 +11,9 @@ HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://git.osmocom.org/gr-iqbal"
- KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
else
- SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
fi
@@ -23,9 +21,9 @@ LICENSE="GPL-3"
SLOT="0/${PV}"
IUSE=""
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
net-libs/libosmo-dsp:=
dev-libs/boost:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"