summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-12-19 15:03:41 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-12-19 15:03:41 +0100
commit86421caa7739259ece1e817e40edb33f98df6e77 (patch)
tree0d29683055d93c97f97ec9ec51221f6b27d9ec5a /net-wireless/gr-osmosdr
parenteclass/readme.gentoo-r1.eclass: Add support for older EAPIs as discussed with... (diff)
downloadgentoo-86421caa7739259ece1e817e40edb33f98df6e77.tar.gz
gentoo-86421caa7739259ece1e817e40edb33f98df6e77.tar.bz2
gentoo-86421caa7739259ece1e817e40edb33f98df6e77.zip
net-wireless/gr-osmosdr: fix building with USE="-python"
python_fix_shebang now dies when the directory doesn't exist Package-Manager: portage-2.2.24
Diffstat (limited to 'net-wireless/gr-osmosdr')
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-0.1.4_p20150730.ebuild4
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild6
2 files changed, 7 insertions, 3 deletions
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-0.1.4_p20150730.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-0.1.4_p20150730.ebuild
index dd7b0061a0ed..cb99ab8a7728 100644
--- a/net-wireless/gr-osmosdr/gr-osmosdr-0.1.4_p20150730.ebuild
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-0.1.4_p20150730.ebuild
@@ -66,5 +66,7 @@ src_configure() {
src_install() {
cmake-utils_src_install
- python_fix_shebang "${ED}"/usr/bin
+ if use python; then
+ python_fix_shebang "${ED}"/usr/bin
+ fi
}
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
index fb14eb8dca95..346b5ccc104b 100644
--- a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -66,5 +66,7 @@ src_configure() {
src_install() {
cmake-utils_src_install
- python_fix_shebang "${ED}"/usr/bin
+ if use python; then
+ python_fix_shebang "${ED}"/usr/bin
+ fi
}