summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-31 21:56:15 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:45:45 -0400
commite838b9f5a7c4c6c6c4253e7d6829629a8bffda7c (patch)
tree4c7a1908b00b4110c6e2f6d5c3e1762f07ca4eb7 /net-wireless/gr-paint
parentnet-wireless/gr-iio: bump for gr3.8 (diff)
downloadgentoo-e838b9f5a7c4c6c6c4253e7d6829629a8bffda7c.tar.gz
gentoo-e838b9f5a7c4c6c6c4253e7d6829629a8bffda7c.tar.bz2
gentoo-e838b9f5a7c4c6c6c4253e7d6829629a8bffda7c.zip
net-wireless/gr-paint: add snapshot
prep for gr-3.8 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/gr-paint')
-rw-r--r--net-wireless/gr-paint/Manifest1
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild50
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild7
3 files changed, 56 insertions, 2 deletions
diff --git a/net-wireless/gr-paint/Manifest b/net-wireless/gr-paint/Manifest
new file mode 100644
index 000000000000..97268d251644
--- /dev/null
+++ b/net-wireless/gr-paint/Manifest
@@ -0,0 +1 @@
+DIST gr-paint-0.0_p20200418.tar.gz 2129751 BLAKE2B 8767ff1ec791352dc701d0f7f68bbbd4088073379b4116ff2dbf2120b5e6e9b1a87ba0b0554a8489dc9b93cdb2ea5e3a8596b09482512fd1b10ea25d5b5c0fe9 SHA512 5f52e2baa090ed80d8a5b75846821b47163dcc055b94201fb59788bd85769a4e3f8c18654de45e68cb4088681b2db8b2327b5d14f176872bfe8bb2e01d7b6bfb
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild
new file mode 100644
index 000000000000..d8339979c4e2
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-0.0_p20200418.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+else
+ COMMIT="e36b2c638061d14f1b3c3bf3e889a8c99c273930"
+ SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64"
+fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ =net-wireless/gnuradio-3.7*:=[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/imagemagick
+"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cppunit
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
index 7f891f888a4e..d8339979c4e2 100644
--- a/net-wireless/gr-paint/gr-paint-9999.ebuild
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -9,7 +9,10 @@ if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
else
- KEYWORDS=""
+ COMMIT="e36b2c638061d14f1b3c3bf3e889a8c99c273930"
+ SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64"
fi
inherit cmake-utils python-single-r1
@@ -26,7 +29,7 @@ DEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
- net-wireless/gnuradio:=[${PYTHON_SINGLE_USEDEP}]
+ =net-wireless/gnuradio-3.7*:=[${PYTHON_SINGLE_USEDEP}]
"
RDEPEND="${DEPEND}
media-gfx/imagemagick