summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-12 10:46:30 +0000
committerSam James <sam@gentoo.org>2021-06-12 10:54:03 +0000
commit86cc0139a30af31444b0bb1cd43520c381162c68 (patch)
tree0aec34262d2eae8af0b01bcb74a308f4a6f16bf8 /net-wireless/hostapd
parentapp-text/poppler: Synced live ebuild (diff)
downloadgentoo-86cc0139a30af31444b0bb1cd43520c381162c68.tar.gz
gentoo-86cc0139a30af31444b0bb1cd43520c381162c68.tar.bz2
gentoo-86cc0139a30af31444b0bb1cd43520c381162c68.zip
net-wireless/hostapd: ebuild tidying
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-wireless/hostapd')
-rw-r--r--net-wireless/hostapd/hostapd-2.9-r3.ebuild39
-rw-r--r--net-wireless/hostapd/hostapd-2.9-r4.ebuild43
-rw-r--r--net-wireless/hostapd/hostapd-9999.ebuild27
-rw-r--r--net-wireless/hostapd/metadata.xml2
4 files changed, 50 insertions, 61 deletions
diff --git a/net-wireless/hostapd/hostapd-2.9-r3.ebuild b/net-wireless/hostapd/hostapd-2.9-r3.ebuild
index 7a63076e50a7..174b3dd6157a 100644
--- a/net-wireless/hostapd/hostapd-2.9-r3.ebuild
+++ b/net-wireless/hostapd/hostapd-2.9-r3.ebuild
@@ -28,30 +28,29 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="internal-tls ipv6 logwatch netlink sqlite +suiteb +wps +crda"
+IUSE="internal-tls ipv6 netlink sqlite +suiteb +wps +crda"
DEPEND="
- internal-tls? ( dev-libs/libtommath )
- !internal-tls? ( dev-libs/openssl:0=[-bindist] )
-
+ internal-tls? ( dev-libs/libtommath )
+ !internal-tls? ( dev-libs/openssl:0=[-bindist] )
kernel_linux? (
dev-libs/libnl:3
crda? ( net-wireless/crda )
)
netlink? ( net-libs/libnfnetlink )
sqlite? ( >=dev-db/sqlite-3 )"
-
RDEPEND="${DEPEND}"
pkg_pretend() {
if use internal-tls; then
- ewarn "internal-tls implementation is experimental and provides fewer features"
+ ewarn "internal-tls implementation is experimental and provides fewer features"
fi
}
src_unpack() {
# Override default one because we need the SRC_URI ones even in case of 9999 ebuilds
default
+
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
fi
@@ -63,12 +62,12 @@ src_prepare() {
pushd ../ >/dev/null || die
default
- # CVE-2019-16275 bug #696032
- eapply "${FILESDIR}/hostapd-2.9-AP-Silently-ignore-management-frame-from-unexpected.patch"
- # CVE-2020-12695 bug #727542
- eapply "${FILESDIR}/${P}-0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch"
- eapply "${FILESDIR}/${P}-0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch"
- eapply "${FILESDIR}/${P}-0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch"
+ # CVE-2019-16275 (bug #696032)
+ eapply "${FILESDIR}"/${P}-AP-Silently-ignore-management-frame-from-unexpected.patch
+ # CVE-2020-12695 (bug #727542)
+ eapply "${FILESDIR}"/${P}-0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch
+ eapply "${FILESDIR}"/${P}-0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch
+ eapply "${FILESDIR}"/${P}-0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch
popd >/dev/null || die
@@ -77,7 +76,7 @@ src_prepare() {
}
src_configure() {
- local CONFIG="${S}/.config"
+ local CONFIG="${S}"/.config
restore_config "${CONFIG}"
if [[ -f "${CONFIG}" ]]; then
@@ -233,20 +232,18 @@ src_install() {
docinto examples
dodoc wired.conf
- if use logwatch; then
- insinto /etc/log.d/conf/services/
- doins logwatch/${PN}.conf
+ insinto /etc/log.d/conf/services/
+ doins logwatch/${PN}.conf
- exeinto /etc/log.d/scripts/services/
- doexe logwatch/${PN}
- fi
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/${PN}
save_config .config
}
pkg_postinst() {
einfo
- einfo "If you are running openRC you need to follow this instructions:"
+ einfo "If you are running OpenRC you need to follow this instructions:"
einfo "In order to use ${PN} you need to set up your wireless card"
einfo "for master mode in /etc/conf.d/net and then start"
einfo "/etc/init.d/${PN}."
@@ -267,7 +264,7 @@ pkg_postinst() {
if use wps; then
einfo "You have enabled Wi-Fi Protected Setup support, please"
- einfo "read the README-WPS file in /usr/share/doc/${P}"
+ einfo "read the README-WPS file in /usr/share/doc/${PF}"
einfo "for info on how to use WPS"
fi
}
diff --git a/net-wireless/hostapd/hostapd-2.9-r4.ebuild b/net-wireless/hostapd/hostapd-2.9-r4.ebuild
index 8a63e598f559..4130241a64ce 100644
--- a/net-wireless/hostapd/hostapd-2.9-r4.ebuild
+++ b/net-wireless/hostapd/hostapd-2.9-r4.ebuild
@@ -28,30 +28,29 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="internal-tls ipv6 logwatch netlink sqlite +suiteb +wps +crda"
+IUSE="internal-tls ipv6 netlink sqlite +suiteb +wps +crda"
DEPEND="
- internal-tls? ( dev-libs/libtommath )
- !internal-tls? ( dev-libs/openssl:0=[-bindist] )
-
+ internal-tls? ( dev-libs/libtommath )
+ !internal-tls? ( dev-libs/openssl:0=[-bindist] )
kernel_linux? (
dev-libs/libnl:3
crda? ( net-wireless/crda )
)
netlink? ( net-libs/libnfnetlink )
sqlite? ( >=dev-db/sqlite-3 )"
-
RDEPEND="${DEPEND}"
pkg_pretend() {
if use internal-tls; then
- ewarn "internal-tls implementation is experimental and provides fewer features"
+ ewarn "internal-tls implementation is experimental and provides fewer features"
fi
}
src_unpack() {
# Override default one because we need the SRC_URI ones even in case of 9999 ebuilds
default
+
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
fi
@@ -63,14 +62,14 @@ src_prepare() {
pushd ../ >/dev/null || die
default
- # CVE-2019-16275 bug #696032
- eapply "${FILESDIR}/hostapd-2.9-AP-Silently-ignore-management-frame-from-unexpected.patch"
- # CVE-2020-12695 bug #727542
- eapply "${FILESDIR}/${P}-0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch"
- eapply "${FILESDIR}/${P}-0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch"
- eapply "${FILESDIR}/${P}-0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch"
- # CVE-2021-30004 bug #780135
- eapply "${FILESDIR}/${P}-ASN-1-Validate-DigestAlgorithmIdentifier-parameters.patch"
+ # CVE-2019-16275 (bug #696032)
+ eapply "${FILESDIR}"/${P}-AP-Silently-ignore-management-frame-from-unexpected.patch
+ # CVE-2020-12695 (bug #727542)
+ eapply "${FILESDIR}"/${P}-0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch
+ eapply "${FILESDIR}"/${P}-0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch
+ eapply "${FILESDIR}"/${P}-0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch
+ # CVE-2021-30004 (bug #780135)
+ eapply "${FILESDIR}"/${P}-ASN-1-Validate-DigestAlgorithmIdentifier-parameters.patch
popd >/dev/null || die
@@ -79,7 +78,7 @@ src_prepare() {
}
src_configure() {
- local CONFIG="${S}/.config"
+ local CONFIG="${S}"/.config
restore_config "${CONFIG}"
if [[ -f "${CONFIG}" ]]; then
@@ -236,20 +235,18 @@ src_install() {
docinto examples
dodoc wired.conf
- if use logwatch; then
- insinto /etc/log.d/conf/services/
- doins logwatch/${PN}.conf
+ insinto /etc/log.d/conf/services/
+ doins logwatch/${PN}.conf
- exeinto /etc/log.d/scripts/services/
- doexe logwatch/${PN}
- fi
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/${PN}
save_config .config
}
pkg_postinst() {
einfo
- einfo "If you are running openRC you need to follow this instructions:"
+ einfo "If you are running OpenRC you need to follow this instructions:"
einfo "In order to use ${PN} you need to set up your wireless card"
einfo "for master mode in /etc/conf.d/net and then start"
einfo "/etc/init.d/${PN}."
@@ -270,7 +267,7 @@ pkg_postinst() {
if use wps; then
einfo "You have enabled Wi-Fi Protected Setup support, please"
- einfo "read the README-WPS file in /usr/share/doc/${P}"
+ einfo "read the README-WPS file in /usr/share/doc/${PF}"
einfo "for info on how to use WPS"
fi
}
diff --git a/net-wireless/hostapd/hostapd-9999.ebuild b/net-wireless/hostapd/hostapd-9999.ebuild
index c9cb0fa9f955..6149f90b94e0 100644
--- a/net-wireless/hostapd/hostapd-9999.ebuild
+++ b/net-wireless/hostapd/hostapd-9999.ebuild
@@ -28,30 +28,29 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="internal-tls ipv6 logwatch netlink sqlite +suiteb +wps +crda"
+IUSE="internal-tls ipv6 netlink sqlite +suiteb +wps +crda"
DEPEND="
- internal-tls? ( dev-libs/libtommath )
- !internal-tls? ( dev-libs/openssl:0=[-bindist] )
-
+ internal-tls? ( dev-libs/libtommath )
+ !internal-tls? ( dev-libs/openssl:0=[-bindist] )
kernel_linux? (
dev-libs/libnl:3
crda? ( net-wireless/crda )
)
netlink? ( net-libs/libnfnetlink )
sqlite? ( >=dev-db/sqlite-3 )"
-
RDEPEND="${DEPEND}"
pkg_pretend() {
if use internal-tls; then
- ewarn "internal-tls implementation is experimental and provides fewer features"
+ ewarn "internal-tls implementation is experimental and provides fewer features"
fi
}
src_unpack() {
# Override default one because we need the SRC_URI ones even in case of 9999 ebuilds
default
+
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
fi
@@ -69,7 +68,7 @@ src_prepare() {
}
src_configure() {
- local CONFIG="${S}/.config"
+ local CONFIG="${S}"/.config
restore_config "${CONFIG}"
if [[ -f "${CONFIG}" ]]; then
@@ -226,20 +225,18 @@ src_install() {
docinto examples
dodoc wired.conf
- if use logwatch; then
- insinto /etc/log.d/conf/services/
- doins logwatch/${PN}.conf
+ insinto /etc/log.d/conf/services/
+ doins logwatch/${PN}.conf
- exeinto /etc/log.d/scripts/services/
- doexe logwatch/${PN}
- fi
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/${PN}
save_config .config
}
pkg_postinst() {
einfo
- einfo "If you are running openRC you need to follow this instructions:"
+ einfo "If you are running OpenRC you need to follow this instructions:"
einfo "In order to use ${PN} you need to set up your wireless card"
einfo "for master mode in /etc/conf.d/net and then start"
einfo "/etc/init.d/${PN}."
@@ -260,7 +257,7 @@ pkg_postinst() {
if use wps; then
einfo "You have enabled Wi-Fi Protected Setup support, please"
- einfo "read the README-WPS file in /usr/share/doc/${P}"
+ einfo "read the README-WPS file in /usr/share/doc/${PF}"
einfo "for info on how to use WPS"
fi
}
diff --git a/net-wireless/hostapd/metadata.xml b/net-wireless/hostapd/metadata.xml
index d518c0ca0889..563ee67435f0 100644
--- a/net-wireless/hostapd/metadata.xml
+++ b/net-wireless/hostapd/metadata.xml
@@ -9,8 +9,6 @@
<use>
<flag name="crda">Add CRDA support</flag>
<flag name="internal-tls">Use internal TLSv1 implementation instead of depending on OpenSSL or GnuTLS</flag>
- <flag name="logwatch">Install support files for
- <pkg>sys-apps/logwatch</pkg></flag>
<flag name="netlink">Adding support for using netlink to create VLANs</flag>
<flag name="suiteb">Adding support for NSA Suite B Cryptography</flag>
<flag name="wps">Add support for Wi-Fi Protected Setup</flag>