summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-02-11 22:48:32 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-02-11 23:39:32 +0000
commitfe2801fc9c4ee250553eab9d9808098f39981f03 (patch)
tree62e1be660234e19c9ceb1e20179b2aa8473218b1 /net-wireless/hostapd
parentnet-wireless/hostapd: add new revision 2.9-r2 (diff)
downloadgentoo-fe2801fc9c4ee250553eab9d9808098f39981f03.tar.gz
gentoo-fe2801fc9c4ee250553eab9d9808098f39981f03.tar.bz2
gentoo-fe2801fc9c4ee250553eab9d9808098f39981f03.zip
net-wireless/hostapd: enable new auth methods
Suggested-by: Rick Farina <zerochaos@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-wireless/hostapd')
-rw-r--r--net-wireless/hostapd/hostapd-2.9-r2.ebuild5
-rw-r--r--net-wireless/hostapd/hostapd-9999.ebuild7
2 files changed, 11 insertions, 1 deletions
diff --git a/net-wireless/hostapd/hostapd-2.9-r2.ebuild b/net-wireless/hostapd/hostapd-2.9-r2.ebuild
index 1c053ce40c24..365c114a0165 100644
--- a/net-wireless/hostapd/hostapd-2.9-r2.ebuild
+++ b/net-wireless/hostapd/hostapd-2.9-r2.ebuild
@@ -92,6 +92,11 @@ src_configure() {
echo "CONFIG_EAP=y" >> ${CONFIG}
echo "CONFIG_ERP=y" >> ${CONFIG}
echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+ echo "CONFIG_SAE=y" >> ${CONFIG}
+ echo "CONFIG_OWE=y" >> ${CONFIG}
+ echo "CONFIG_DPP=y" >> ${CONFIG}
+ echo "CONFIG_SUITEB=y" >> ${CONFIG}
+ echo "CONFIG_SUITEB192=y" >> ${CONFIG}
if use internal-tls && ! use libressl; then
echo "CONFIG_TLS=internal" >> ${CONFIG}
diff --git a/net-wireless/hostapd/hostapd-9999.ebuild b/net-wireless/hostapd/hostapd-9999.ebuild
index 382256f224b1..6ab779890926 100644
--- a/net-wireless/hostapd/hostapd-9999.ebuild
+++ b/net-wireless/hostapd/hostapd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -90,6 +90,11 @@ src_configure() {
echo "CONFIG_EAP=y" >> ${CONFIG}
echo "CONFIG_ERP=y" >> ${CONFIG}
echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+ echo "CONFIG_SAE=y" >> ${CONFIG}
+ echo "CONFIG_OWE=y" >> ${CONFIG}
+ echo "CONFIG_DPP=y" >> ${CONFIG}
+ echo "CONFIG_SUITEB=y" >> ${CONFIG}
+ echo "CONFIG_SUITEB192=y" >> ${CONFIG}
if use internal-tls && ! use libressl; then
echo "CONFIG_TLS=internal" >> ${CONFIG}