summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/madwimax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/madwimax')
-rw-r--r--net-wireless/madwimax/Manifest1
-rw-r--r--net-wireless/madwimax/madwimax-0.1.1-r1.ebuild42
-rw-r--r--net-wireless/madwimax/metadata.xml10
3 files changed, 53 insertions, 0 deletions
diff --git a/net-wireless/madwimax/Manifest b/net-wireless/madwimax/Manifest
new file mode 100644
index 000000000000..b4d2bb6ec5ef
--- /dev/null
+++ b/net-wireless/madwimax/Manifest
@@ -0,0 +1 @@
+DIST madwimax-0.1.1.tar.gz 145526 SHA256 17ac297934654663586df837dcff2bd6d3bbabddd76efdffa26713b07e08ad5f SHA512 ec3bb91d0608855018bb5b18a87c6bff7ac7f60d3afed24dec05747573c7363001e89adf07b79bb43db3023e7171d3e2f3b9c5ad22359c1a0be24d9034389e59 WHIRLPOOL 102b586bbbd54a6840af34b547ea4052302573306a09f453f6ffdf3fe686bd118d55776a590ba2188259a85cd01c15e034207eea4f94a108804b8801c85d6d60
diff --git a/net-wireless/madwimax/madwimax-0.1.1-r1.ebuild b/net-wireless/madwimax/madwimax-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..e24882caf98a
--- /dev/null
+++ b/net-wireless/madwimax/madwimax-0.1.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools linux-info udev
+
+DESCRIPTION="A reverse-engineered Linux driver for mobile WiMAX devices based on Samsung CMC-730 chip"
+HOMEPAGE="http://code.google.com/p/madwimax/"
+SRC_URI="http://madwimax.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/asciidoc
+ app-text/docbook2X
+ )"
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ sed -i -e "s:\(for name in docbook2\)x-man:\1man\.pl:" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf="--without-man-pages"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" udevrulesdir="$(get_udevdir)"/rules.d install
+ mv "${ED}/$(get_udevdir)"/rules.d/{z60_,60-}madwimax.rules || die
+ dodoc README
+}
diff --git a/net-wireless/madwimax/metadata.xml b/net-wireless/madwimax/metadata.xml
new file mode 100644
index 000000000000..8baa280a7e36
--- /dev/null
+++ b/net-wireless/madwimax/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">madwimax</remote-id>
+ </upstream>
+</pkgmetadata>