summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-23 14:45:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-23 14:47:30 +0200
commit49d8805990194db614108d3519d7397c4f1c9c63 (patch)
tree99b98340c5afbe376f68e839a39c404f724990c5 /net-wireless/rfkill/rfkill-0.5-r2.ebuild
parentsys-kernel/linux-firmware: Remove old (diff)
downloadgentoo-49d8805990194db614108d3519d7397c4f1c9c63.tar.gz
gentoo-49d8805990194db614108d3519d7397c4f1c9c63.tar.bz2
gentoo-49d8805990194db614108d3519d7397c4f1c9c63.zip
net-wireless/rfkill: Revbumps to fix QA moaning.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'net-wireless/rfkill/rfkill-0.5-r2.ebuild')
-rw-r--r--net-wireless/rfkill/rfkill-0.5-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-wireless/rfkill/rfkill-0.5-r2.ebuild b/net-wireless/rfkill/rfkill-0.5-r2.ebuild
new file mode 100644
index 000000000000..ab6b3fa74faf
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-0.5-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="!>=sys-apps/util-linux-2.31_rc1"
+DEPEND=""
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getLD) V=1 || die "Failed to compile"
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}" || die "Failed to install"
+}