summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-02-17 14:13:29 -0500
committerRick Farina <zerochaos@gentoo.org>2021-02-17 14:13:42 -0500
commitbbff0173fbaa4ebc2daaf6001e9af3ee3e16b973 (patch)
tree43e297e03f7f0236288febc6e54de544715be398 /net-wireless/rfkill
parentdev-ml/ocamlbuild: rm old version (diff)
downloadgentoo-bbff0173fbaa4ebc2daaf6001e9af3ee3e16b973.tar.gz
gentoo-bbff0173fbaa4ebc2daaf6001e9af3ee3e16b973.tar.bz2
gentoo-bbff0173fbaa4ebc2daaf6001e9af3ee3e16b973.zip
net-wireless/rfkill: bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/rfkill')
-rw-r--r--net-wireless/rfkill/Manifest1
-rw-r--r--net-wireless/rfkill/rfkill-1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-wireless/rfkill/Manifest b/net-wireless/rfkill/Manifest
index a0d4839dc50e..7047a19da2e3 100644
--- a/net-wireless/rfkill/Manifest
+++ b/net-wireless/rfkill/Manifest
@@ -1 +1,2 @@
DIST rfkill-0.5.tar.xz 7776 BLAKE2B 7f8d2e4d6b9433236de7c2e57035d39ece8b9a0c99c572aa8b0365dad35087f5594b21dcea3e6ea47e73c8471f172ef2d16193ce2ceb1fcc0490b61ddf11b765 SHA512 6ad4d28e7bf7ec69ec6a600cd774b7b3c60e85849ae3fca0f5509ed6a283ed5656d37cfd770df45ff1ceca59edd814807d116b30e199fca303baf496441419d7
+DIST rfkill-1.0.tar.xz 7228 BLAKE2B 045bcb83f5d6b89945846d5d80b1c45e8c18227ad73f4f05cdd73ffbb8e8076b8b14ce60a8f419c39db3c6543856ad47e1308f81e1621332faa64e80abc78342 SHA512 55055f47574f9589ee3739675f784c1ea286bef0ffb32f33a7ee9e319bd7ac61df6e22c6ecd1deada8ad451a8ee1f5284e4cbf5628a6d4fdedbd8ca8c7da5276
diff --git a/net-wireless/rfkill/rfkill-1.0.ebuild b/net-wireless/rfkill/rfkill-1.0.ebuild
new file mode 100644
index 000000000000..2dcc85799b0b
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="!>=sys-apps/util-linux-2.31_rc1"
+DEPEND=""
+
+src_prepare() {
+ sed -i 's#rfkill.8.gz#rfkill.8#' Makefile
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getLD) V=1
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}"
+}