summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-09-23 11:44:39 -0400
committerRick Farina <zerochaos@gentoo.org>2020-09-23 11:44:50 -0400
commit5e3f0ae35672f77db4e81bc1de2b4ac559c99b31 (patch)
treee65526a1de217e46630248bdfe3630b8c2c29eb6 /net-wireless/soapyuhd/soapyuhd-0.4.1.ebuild
parentapp-backup/btrbk: 0.30.0 version bump (diff)
downloadgentoo-5e3f0ae35672f77db4e81bc1de2b4ac559c99b31.tar.gz
gentoo-5e3f0ae35672f77db4e81bc1de2b4ac559c99b31.tar.bz2
gentoo-5e3f0ae35672f77db4e81bc1de2b4ac559c99b31.zip
net-wireless/soapyuhd: bump
properly support uhd 4.0.0.0 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/soapyuhd/soapyuhd-0.4.1.ebuild')
-rw-r--r--net-wireless/soapyuhd/soapyuhd-0.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-wireless/soapyuhd/soapyuhd-0.4.1.ebuild b/net-wireless/soapyuhd/soapyuhd-0.4.1.ebuild
new file mode 100644
index 000000000000..d86411cd4706
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices "
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"