summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-27 09:54:11 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-27 09:55:30 +0200
commit0d69c92bbae1266d7dd6130ef924861d0a73fe9f (patch)
tree520cbe9f5c8905c496ef2c9d3fcfa7f5928b3855 /net-wireless/spectools/spectools-9999.ebuild
parentmedia-sound/yoshimi: remove old (diff)
downloadgentoo-0d69c92bbae1266d7dd6130ef924861d0a73fe9f.tar.gz
gentoo-0d69c92bbae1266d7dd6130ef924861d0a73fe9f.tar.bz2
gentoo-0d69c92bbae1266d7dd6130ef924861d0a73fe9f.zip
net-wireless/spectools: Add fix for ncurses[tinfo]
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=490976 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-wireless/spectools/spectools-9999.ebuild')
-rw-r--r--net-wireless/spectools/spectools-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/net-wireless/spectools/spectools-9999.ebuild b/net-wireless/spectools/spectools-9999.ebuild
index e5c5de4b3fc6..2b88fdce4a16 100644
--- a/net-wireless/spectools/spectools-9999.ebuild
+++ b/net-wireless/spectools/spectools-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit udev toolchain-funcs
+
+inherit autotools eutils toolchain-funcs udev
MY_PN=${PN}
MY_PV=${PV/\./-}
@@ -27,14 +28,21 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="debug +ncurses +gtk"
-RDEPEND="virtual/libusb:0
- ncurses? ( sys-libs/ncurses )
+RDEPEND="
+ virtual/libusb:0
+ ncurses? ( sys-libs/ncurses:0= )
gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
# Upstream has still not migrated to the libusb-1 line.
# Maemo: Add hildon and bbus
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.08.1_p20150618-tinfo.patch
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
# Please note that upstream removed the --with-gtk-version option
# and GTK is now automagical. GTK1 support was also removed.
src_compile() {