summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-04-17 16:45:18 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-04-17 16:47:25 -0400
commit594c9d181163140840f8a4e5be69e3f8aa36474c (patch)
tree45c48d234c2dea963a2530c94b0b73bf5f782d8a /net-wireless/uhd/uhd-3.9.6.ebuild
parentapp-text/expander: [QA] Create relative rather than absolute symlinks. (diff)
downloadgentoo-594c9d181163140840f8a4e5be69e3f8aa36474c.tar.gz
gentoo-594c9d181163140840f8a4e5be69e3f8aa36474c.tar.bz2
gentoo-594c9d181163140840f8a4e5be69e3f8aa36474c.zip
net-wireless/uhd: bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-wireless/uhd/uhd-3.9.6.ebuild')
-rw-r--r--net-wireless/uhd/uhd-3.9.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-wireless/uhd/uhd-3.9.6.ebuild b/net-wireless/uhd/uhd-3.9.6.ebuild
new file mode 100644
index 000000000000..ab4d780cf5fc
--- /dev/null
+++ b/net-wireless/uhd/uhd-3.9.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit versionator python-single-r1 gnome2-utils cmake-utils multilib
+
+DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
+HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki"
+
+image_version=uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).00$(get_version_component_range 3)-release
+SRC_URI="https://github.com/EttusResearch/uhd/archive/release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3).tar.gz -> EttusResearch-UHD-$(get_version_component_range 1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
+ http://files.ettus.com/binaries/images/${image_version}.zip"
+#https://github.com/EttusResearch/UHD-Mirror/tags
+#http://files.ettus.com/binaries/images/
+KEYWORDS="~amd64 ~arm ~x86"
+S="${WORKDIR}"/uhd-release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host
+
+LICENSE="GPL-3"
+SLOT="0/1"
+IUSE=""
+RDEPEND="virtual/libusb:1
+ dev-lang/orc
+ dev-libs/boost:=
+ sys-libs/ncurses:0
+ "
+DEPEND="${RDEPEND}
+ dev-python/cheetah
+ app-arch/unzip"
+
+src_prepare() {
+ gnome2_environment_reset #534582
+
+ #this may not be needed in 3.4.3 and above, please verify
+ sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
+ insinto /lib/udev/rules.d/
+ doins "${S}"/utils/uhd-usrp.rules
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/"${image_version}"/share/uhd/images
+}