summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/uhd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/uhd')
-rw-r--r--net-wireless/uhd/Manifest2
-rw-r--r--net-wireless/uhd/metadata.xml18
-rw-r--r--net-wireless/uhd/uhd-3.8.2.ebuild46
3 files changed, 66 insertions, 0 deletions
diff --git a/net-wireless/uhd/Manifest b/net-wireless/uhd/Manifest
new file mode 100644
index 000000000000..9745beb957bf
--- /dev/null
+++ b/net-wireless/uhd/Manifest
@@ -0,0 +1,2 @@
+DIST EttusResearch-UHD-3.8.2.tar.gz 2170233 SHA256 04fc1e42010560a5c74c714be2729a252b06bf46b982321a3e47ca5ed72a3bce SHA512 7a2939f883bd5445fc8f16e1e09d3fc3dc2b41481dfb4bdefd4a8e4f2c6c0d1c703f2a47e373b295d11419740b5c62d959557ed3fd880bf75977c9716316a844 WHIRLPOOL ff883bd01768d68b7bc20b97d92e38e7f8ee79571a2cc62917f435482fdd415af7166b3032d71b842cabf12a42c3d3da09ea962f68393b7dc723acce49db65d3
+DIST uhd-images_003.008.002-release.zip 24803095 SHA256 5e3df6bff5040276208d25848ad085e0ecbbd9f8c528be04f19f91d3b169a1ee SHA512 a2a970928f7f4e9bbf983f19c71bcf9b1b26a6f7bd66f1a171e6fc7d329a7107bff0e6425734299a88b639663951e27ec4a49efcb7731cb2f3e94c2cd4557e36 WHIRLPOOL 404bfe4f87e26e0f39b467abebd7735fef42833a117561b8a73917e36d59b20dc9d62fe89bfd19e9daa3d3e7069ec4b1e0a92808f835f8f5f17e8cccd153495a
diff --git a/net-wireless/uhd/metadata.xml b/net-wireless/uhd/metadata.xml
new file mode 100644
index 000000000000..25faa41d0ed4
--- /dev/null
+++ b/net-wireless/uhd/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>radio</herd>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">EttusResearch/uhd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/uhd/uhd-3.8.2.ebuild b/net-wireless/uhd/uhd-3.8.2.ebuild
new file mode 100644
index 000000000000..750ae0af048b
--- /dev/null
+++ b/net-wireless/uhd/uhd-3.8.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit versionator python-single-r1 gnome2-utils cmake-utils multilib
+
+DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
+HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki"
+
+image_version=uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).00$(get_version_component_range 3)-release
+SRC_URI="https://github.com/EttusResearch/uhd/archive/release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3).tar.gz -> EttusResearch-UHD-$(get_version_component_range 1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
+ http://files.ettus.com/binaries/images/${image_version}.zip"
+#https://github.com/EttusResearch/UHD-Mirror/tags
+#http://files.ettus.com/binaries/images/
+KEYWORDS="~amd64 ~arm ~x86"
+S="${WORKDIR}"/uhd-release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host
+
+LICENSE="GPL-3"
+SLOT="0/1"
+IUSE=""
+RDEPEND="virtual/libusb:1
+ dev-lang/orc
+ dev-libs/boost:=
+ sys-libs/ncurses
+ "
+DEPEND="${RDEPEND}
+ dev-python/cheetah
+ app-arch/unzip"
+
+src_prepare() {
+ gnome2_environment_reset #534582
+
+ #this may not be needed in 3.4.3 and above, please verify
+ sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
+ insinto /lib/udev/rules.d/
+ doins "${S}"/utils/uhd-usrp.rules
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/"${image_version}"/share/uhd/images
+}