summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/yatebts/yatebts-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/yatebts/yatebts-9999.ebuild')
-rw-r--r--net-wireless/yatebts/yatebts-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-wireless/yatebts/yatebts-9999.ebuild b/net-wireless/yatebts/yatebts-9999.ebuild
new file mode 100644
index 000000000000..b55fcf0ac308
--- /dev/null
+++ b/net-wireless/yatebts/yatebts-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="The Yate GSM base station"
+HOMEPAGE="http://www.yatebts.com/"
+ESVN_REPO_URI="http://voip.null.ro/svn/yatebts/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="rad1 usrp1 uhd +bladerf cpu_flags_x86_sse3 cpu_flags_x86_sse4_1"
+
+RDEPEND="
+ =net-voip/yate-${PV}:=[gsm]
+ bladerf? ( net-wireless/bladerf:= )
+ uhd? ( net-wireless/uhd )
+ virtual/libusb:1"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://yate.null.ro/tarballs/${PN}4/yate-bts-${PV}-1.tar.gz"
+ S="${WORKDIR}/yate-bts"
+fi
+
+src_prepare() {
+ #we need more patches or configure flags because things install in really wrong places per FHS
+ epatch "${FILESDIR}"/${PN}-sgsnggsn-inetutils-hostname-fix.diff
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable rad1) \
+ $(use_enable usrp1) \
+ $(use_enable uhd) \
+ $(use_enable bladerf) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41)
+
+}