summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-17 16:06:10 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-17 16:06:51 +0100
commit006674e4b3910de7f0a448627c146821e8cb0ed8 (patch)
treebcfee94e9f645c7e7aa9a105dd6dbcafbf47376e /net-wireless
parentnet-analyzer/fragroute: Old (diff)
downloadgentoo-006674e4b3910de7f0a448627c146821e8cb0ed8.tar.gz
gentoo-006674e4b3910de7f0a448627c146821e8cb0ed8.tar.bz2
gentoo-006674e4b3910de7f0a448627c146821e8cb0ed8.zip
net-wireless/horst: Version 5.1
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Fixes: https://bugs.gentoo.org/show_bug.cgi?id=661914 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/horst/Manifest1
-rw-r--r--net-wireless/horst/files/horst-5.1-CC.patch14
-rw-r--r--net-wireless/horst/files/horst-5.1-pcap_bufsize.patch32
-rw-r--r--net-wireless/horst/files/horst-5.1-tinfo.patch11
-rw-r--r--net-wireless/horst/files/horst-9999-tinfo.patch11
-rw-r--r--net-wireless/horst/horst-5.1.ebuild44
-rw-r--r--net-wireless/horst/horst-9999.ebuild38
7 files changed, 136 insertions, 15 deletions
diff --git a/net-wireless/horst/Manifest b/net-wireless/horst/Manifest
index c19dc8b815c0..d4ac613a275d 100644
--- a/net-wireless/horst/Manifest
+++ b/net-wireless/horst/Manifest
@@ -1,2 +1,3 @@
DIST horst-4.2.tar.gz 97976 BLAKE2B 9f59e2dd6f67b50d0d6c67ff269f327e073edbfa87db5d3d63621116123cdcda3d85759e47bcd26344f750f87b0516589aff140542f2ef36cd12dddd048be60f SHA512 a6fa50d6eb0d2c2ae83dfccf59359f8cd74334dbc2362f01f1a3787ebb3d34bcdb76c34899cb048e4a4abc7353d72e8dd846b567ba228f9930e3f418b3656c0a
DIST horst-5.0.tar.gz 115572 BLAKE2B a7702fe05a706f3f9cfd0545850451e1035840503c1fdf9377594d883095e41acaf89dca4ef9433f3a0109491932612e657dce8054a9f28c2bd725d230588bb1 SHA512 d2df54fade3d62b91482fb16e34f9b03567285880eceb5baea3f76b46caf1763909f3999b2924e210eb0ab0d9fd9f6444f31d2b06ea1a3b73a9f54e257cfd989
+DIST horst-5.1.tar.gz 117392 BLAKE2B 4e21a1cb4d508c8ed6e63fe975a30299452c706aec1a83125acabc547ab8718bbae66d546d973bc10af1f0b6c885a20193c584312c30f5ecaef9d86156c0b12b SHA512 d2889a8c42c31bea72d4e0efd7141ca56c96953b37d2476793ef52d019720059eb57e48b72fa5d720e0c5518a9b0b8dee1a105828d581655c0fbf4dfb29698c4
diff --git a/net-wireless/horst/files/horst-5.1-CC.patch b/net-wireless/horst/files/horst-5.1-CC.patch
new file mode 100644
index 000000000000..f9c2e5120ac8
--- /dev/null
+++ b/net-wireless/horst/files/horst-5.1-CC.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -99,9 +99,9 @@
+ all: $(NAME)
+
+ .objdeps.mk: $(OBJS:%.o=%.c)
+- gcc -MM -I. $^ >$@
++ $(CC) -MM -I. $^ >$@
+ ifeq ($(OSX),1)
+- gcc -MM -I. ifctrl-osx.m >>$@
++ $(CC) -MM -I. ifctrl-osx.m >>$@
+ endif
+
+ -include .objdeps.mk
diff --git a/net-wireless/horst/files/horst-5.1-pcap_bufsize.patch b/net-wireless/horst/files/horst-5.1-pcap_bufsize.patch
new file mode 100644
index 000000000000..35f3f59dd98a
--- /dev/null
+++ b/net-wireless/horst/files/horst-5.1-pcap_bufsize.patch
@@ -0,0 +1,32 @@
+--- a/capture-pcap.c
++++ b/capture-pcap.c
+@@ -32,16 +32,16 @@
+ #define PCAP_TIMEOUT 200
+
+ static unsigned char* pcap_buffer;
+-static size_t pcap_bufsize;
++static size_t horst_pcap_bufsize;
+ static pcap_t *pcap_fp = NULL;
+
+ static void handler(u_char *user, const struct pcap_pkthdr *h, const u_char *bytes)
+ {
+ *((int *)user) = h->len;
+- if (pcap_bufsize < h->len) {
++ if (horst_pcap_bufsize < h->len) {
+ printlog("ERROR: Buffer(%d) too small for %d bytes",
+- (int)pcap_bufsize, h->len);
+- *((int *)user) = pcap_bufsize;
++ (int)horst_pcap_bufsize, h->len);
++ *((int *)user) = horst_pcap_bufsize;
+ }
+ memmove(pcap_buffer, bytes, *((int *)user));
+ }
+@@ -98,7 +98,7 @@
+ {
+ int ret = 0;
+ pcap_buffer = buffer;
+- pcap_bufsize = bufsize;
++ horst_pcap_bufsize = bufsize;
+ if (0 == pcap_dispatch(pcap_fp, 1, handler, (u_char *)&ret))
+ return -1;
+ return ret;
diff --git a/net-wireless/horst/files/horst-5.1-tinfo.patch b/net-wireless/horst/files/horst-5.1-tinfo.patch
new file mode 100644
index 000000000000..059158e58cfc
--- /dev/null
+++ b/net-wireless/horst/files/horst-5.1-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -54,7 +54,7 @@
+ radiotap/radiotap.o \
+ util.o \
+ wlan_util.o
+-LIBS=-lncurses -lm
++LIBS=$(shell $(PKG_CONFIG) --libs ncurses ) -lm
+ CFLAGS+=-std=gnu99 -Wall -Wextra -g -I. -DVERSION=\"$(VERSION)\"
+
+ ifeq ($(OSX),1)
diff --git a/net-wireless/horst/files/horst-9999-tinfo.patch b/net-wireless/horst/files/horst-9999-tinfo.patch
new file mode 100644
index 000000000000..eb623d67b133
--- /dev/null
+++ b/net-wireless/horst/files/horst-9999-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -41,7 +41,7 @@
+ SRC += network.c
+ SRC += protocol_parser.c
+
+-LIBS = -lncurses -lm -luwifi
++LIBS = $(shell $(PKG_CONFIG) --libs ncurses ) -lm -luwifi
+ LDFLAGS += -Wl,-rpath,/usr/local/lib
+
+ INCLUDES = -I.
diff --git a/net-wireless/horst/horst-5.1.ebuild b/net-wireless/horst/horst-5.1.ebuild
new file mode 100644
index 000000000000..1e0f7e8997dd
--- /dev/null
+++ b/net-wireless/horst/horst-5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Small 802.11 wireless LAN analyzer"
+HOMEPAGE="http://br1.einfach.org/tech/horst/"
+SRC_URI="https://github.com/br101/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +pcap test"
+
+RDEPEND="
+ sys-libs/ncurses:0
+ pcap? ( net-libs/libpcap )
+"
+TDEPEND="
+ test? ( sys-devel/sparse )
+"
+DEPEND="
+ ${RDEPEND}
+ ${TDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT=test #just semantic tests, no functional tests
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.1-CC.patch
+ "${FILESDIR}"/${PN}-5.1-pcap_bufsize.patch
+ "${FILESDIR}"/${PN}-5.1-tinfo.patch
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake PCAP=$(usex pcap 1 0) DEBUG=$(usex debug 1 0)
+}
+
+src_install() {
+ dosbin ${PN}{,.sh}
+ dodoc README.md
+ doman ${PN}.8
+}
diff --git a/net-wireless/horst/horst-9999.ebuild b/net-wireless/horst/horst-9999.ebuild
index 7f4bb0baf2b2..3e8968e69d14 100644
--- a/net-wireless/horst/horst-9999.ebuild
+++ b/net-wireless/horst/horst-9999.ebuild
@@ -1,36 +1,44 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit toolchain-funcs git-r3
+EAPI=6
+inherit git-r3 toolchain-funcs
DESCRIPTION="Small 802.11 wireless LAN analyzer"
-HOMEPAGE="https://github.com/br101/horst"
-EGIT_REPO_URI="https://github.com/br101/${PN}"
+HOMEPAGE="http://br1.einfach.org/tech/horst/"
+EGIT_REPO_URI="https://github.com/br101/${PN}/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="debug +pcap test"
-RDEPEND="sys-libs/ncurses:0
- pcap? ( net-libs/libpcap )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/sparse )"
-
-#just semantic tests, no functional tests
-RESTRICT=test
+RDEPEND="
+ sys-libs/ncurses:0
+ pcap? ( net-libs/libpcap )
+"
+TDEPEND="
+ test? ( sys-devel/sparse )
+"
+DEPEND="
+ ${RDEPEND}
+ ${TDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT=test #just semantic tests, no functional tests
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
+)
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
emake PCAP=$(usex pcap 1 0) DEBUG=$(usex debug 1 0)
}
src_install() {
dosbin ${PN}{,.sh}
dodoc README.md
- doman ${PN}.8 ${PN}.conf.5
+ doman ${PN}.8
insinto /etc
doins ${PN}.conf
}