summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina (Zero_Chaos) <zerochaos@gentoo.org>2022-02-15 17:33:40 -0500
committerRick Farina <zerochaos@gentoo.org>2022-02-24 11:04:27 -0500
commit2fc1a014d1e2979f4318492b621fa273eba230d2 (patch)
tree1cd5094c6bb02ebbe747e8d118aa5bc41a1e6cda /net-wireless
parentnet-wireless/uhd: reorder *DEPEND (diff)
downloadgentoo-2fc1a014d1e2979f4318492b621fa273eba230d2.tar.gz
gentoo-2fc1a014d1e2979f4318492b621fa273eba230d2.tar.bz2
gentoo-2fc1a014d1e2979f4318492b621fa273eba230d2.zip
net-wireless/uhd: better tinfo workaround
Reported upstream https://gitlab.kitware.com/cmake/cmake/-/issues/23236 Signed-off-by: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch42
-rw-r--r--net-wireless/uhd/uhd-4.1.0.4.ebuild3
2 files changed, 2 insertions, 43 deletions
diff --git a/net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch b/net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch
deleted file mode 100644
index 484aa1f9c2f5..000000000000
--- a/net-wireless/uhd/files/uhd-4.0.0.0-tinfo.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Naur host/CMakeLists.txt uhd-4.0.0.0-patched/host/CMakeLists.txt
---- host/CMakeLists.txt 2020-09-13 15:14:04.000000000 -0400
-+++ host/CMakeLists.txt 2020-09-16 10:11:52.266933094 -0400
-@@ -506,6 +506,9 @@
- if(ENABLE_USB)
- list(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
- endif(ENABLE_USB)
-+
-+LIST(APPEND UHD_LINK_LIST_STATIC "tinfo")
-+
- set(UHD_RFNOC_FOUND "TRUE")
-
- configure_file(
-diff -Naur host/examples/CMakeLists.txt uhd-4.0.0.0-patched/host/examples/CMakeLists.txt
---- host/examples/CMakeLists.txt 2020-09-13 15:14:04.000000000 -0400
-+++ host/examples/CMakeLists.txt 2020-09-16 10:12:49.082935381 -0400
-@@ -55,11 +55,11 @@
- if(CURSES_FOUND)
- include_directories(${CURSES_INCLUDE_DIR})
- add_executable(rx_ascii_art_dft rx_ascii_art_dft.cpp)
-- target_link_libraries(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
-+ target_link_libraries(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
- UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
-
- add_executable(twinrx_freq_hopping twinrx_freq_hopping.cpp)
-- target_link_libraries(twinrx_freq_hopping uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
-+ target_link_libraries(twinrx_freq_hopping uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
- UHD_INSTALL(TARGETS twinrx_freq_hopping RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
- endif(CURSES_FOUND)
-
-diff -Naur host/utils/latency/CMakeLists.txt uhd-4.0.0.0-patched/host/utils/latency/CMakeLists.txt
---- host/utils/latency/CMakeLists.txt 2020-09-13 15:14:04.000000000 -0400
-+++ host/utils/latency/CMakeLists.txt 2020-09-16 10:13:55.994938074 -0400
-@@ -25,7 +25,7 @@
- get_filename_component(name ${source} NAME_WE)
- add_executable(${name} ${source} ${latency_lib_path})
- LIBUHD_APPEND_SOURCES(${name})
-- target_link_libraries(${name} uhd ${Boost_LIBRARIES} ${CURSES_LIBRARIES})
-+ target_link_libraries(${name} uhd ${Boost_LIBRARIES} tinfo ${CURSES_LIBRARIES})
- UHD_INSTALL(TARGETS ${name} RUNTIME DESTINATION ${latency_comp_dest} COMPONENT ${latency_comp_name})
- endforeach(source)
-
diff --git a/net-wireless/uhd/uhd-4.1.0.4.ebuild b/net-wireless/uhd/uhd-4.1.0.4.ebuild
index 4bcb7e47ea2c..f0add2574dad 100644
--- a/net-wireless/uhd/uhd-4.1.0.4.ebuild
+++ b/net-wireless/uhd/uhd-4.1.0.4.ebuild
@@ -49,7 +49,6 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}/${PN}-4.0.0.0-tinfo.patch"
"${FILESDIR}/${PN}-4.1.0.4-hidden-visibility-tests.patch"
)
@@ -67,7 +66,9 @@ src_prepare() {
}
src_configure() {
+ #https://gitlab.kitware.com/cmake/cmake/-/issues/23236
local mycmakeargs=(
+ -DCURSES_NEED_NCURSES=ON
-DENABLE_LIBUHD=ON
-DENABLE_C_API=ON
-DENABLE_MAN_PAGES=ON