summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina (Zero_Chaos) <zerochaos@gentoo.org>2022-02-14 12:24:19 -0500
committerRick Farina <zerochaos@gentoo.org>2022-02-24 11:04:25 -0500
commit37b450a21884e166125aa38e6a72bb1e7a1b7906 (patch)
tree2f8f2b5e9b64f5f15b5a81f6a0af025faa69a76d /net-wireless
parentsci-biology/seqan: add version 3.1.0 (diff)
downloadgentoo-37b450a21884e166125aa38e6a72bb1e7a1b7906.tar.gz
gentoo-37b450a21884e166125aa38e6a72bb1e7a1b7906.tar.bz2
gentoo-37b450a21884e166125aa38e6a72bb1e7a1b7906.zip
net-wireless/uhd: fix ebuild deprecation
Bump eapi 7 -> 8 Migrate eclass cmake-utils -> cmake Signed-off-by: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/uhd/uhd-3.15.0.0-r100.ebuild11
-rw-r--r--net-wireless/uhd/uhd-4.1.0.4.ebuild13
2 files changed, 11 insertions, 13 deletions
diff --git a/net-wireless/uhd/uhd-3.15.0.0-r100.ebuild b/net-wireless/uhd/uhd-3.15.0.0-r100.ebuild
index 439b2f78fc50..598f6ea06237 100644
--- a/net-wireless/uhd/uhd-3.15.0.0-r100.ebuild
+++ b/net-wireless/uhd/uhd-3.15.0.0-r100.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-#not sure why, but eapi 7 fails
+EAPI=8
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit eapi7-ver python-single-r1 gnome2-utils cmake-utils
+inherit python-single-r1 gnome2-utils cmake
DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
HOMEPAGE="https://kb.ettus.com"
@@ -61,7 +60,7 @@ src_unpack() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
gnome2_environment_reset #534582
@@ -97,10 +96,10 @@ src_configure() {
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPKG_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_optimize
use utils && python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
if [ "${PV}" != "9999" ]; then
diff --git a/net-wireless/uhd/uhd-4.1.0.4.ebuild b/net-wireless/uhd/uhd-4.1.0.4.ebuild
index 3b262ab66ff5..8fbc0ab1a94a 100644
--- a/net-wireless/uhd/uhd-4.1.0.4.ebuild
+++ b/net-wireless/uhd/uhd-4.1.0.4.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-#not sure why, but eapi 7 fails
+EAPI=8
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit eapi7-ver python-single-r1 gnome2-utils cmake-utils
+inherit python-single-r1 gnome2-utils cmake
DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
HOMEPAGE="https://kb.ettus.com"
@@ -61,7 +60,7 @@ src_unpack() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
gnome2_environment_reset #534582
@@ -92,10 +91,10 @@ src_configure() {
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPKG_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_optimize
use utils && python_fix_shebang "${ED}"/usr/$(get_libdir)/${PN}/utils/
if [ "${PV}" != "9999" ]; then
@@ -143,5 +142,5 @@ src_install() {
src_test() {
#we can disable the python tests
#ctest -E 'py*'
- PYTHON_PATH=python/ cmake-utils_src_test
+ PYTHON_PATH=python/ cmake_src_test
}