summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2022-03-16 21:55:40 -0400
committerRick Farina <zerochaos@gentoo.org>2022-03-16 22:15:46 -0400
commit5784e26cc42f4cdf3db96a5545316fe82c84d373 (patch)
treea5d851e750313da43a69a67fd4fc37f2f9f093d2 /net-wireless
parentnet-libs/gnutls: Stabilize 3.7.3-r1 arm, #834462 (diff)
downloadgentoo-5784e26cc42f4cdf3db96a5545316fe82c84d373.tar.gz
gentoo-5784e26cc42f4cdf3db96a5545316fe82c84d373.tar.bz2
gentoo-5784e26cc42f4cdf3db96a5545316fe82c84d373.zip
net-wireless/wpa_supplicant: fix wep regression
Introduce a use flag for wep. Previous bump accidently left wep hard disabled. That's a very sane default, but we need a way to turn it back on for anyone who needs it. Fixes: 744939bdfc1a0a6296c709d4382d3676abdb2b66 Additionally add a use flag for TKIP which was introduced in 2.10. While 2.10 leaves TKIP enabled by default, it's been deprecated since 2009 and support has been removed from many other operating systems such as Windows. Disabled is a better default. Enable DPP2, support was added in 2.10 and there is no downside Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml2
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild (renamed from net-wireless/wpa_supplicant/wpa_supplicant-2.10.ebuild)16
2 files changed, 17 insertions, 1 deletions
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
index 749b235bf0e5..e6c399334732 100644
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ b/net-wireless/wpa_supplicant/metadata.xml
@@ -21,7 +21,9 @@
<flag name="ps3">Add support for ps3 hypervisor driven gelic wifi</flag>
<flag name="privsep">Enable wpa_priv privledge separation binary</flag>
<flag name="tdls">Add support for Tunneled Direct Link Setup (802.11z)</flag>
+ <flag name="tkip">Add support for WPA TKIP (deprecated 2009)</flag>
<flag name="uncommon-eap-types">Add support for GPSK, SAKE, GPSK_SHA256, IKEV2 and EKE</flag>
+ <flag name="wep">Add support for Wired Equivalent Privacy (deprecated 2004)</flag>
<flag name="wps">Add support for Wi-Fi Protected Setup</flag>
<flag name="wimax">Add support for Wimax EAP-PEER authentication algorithm</flag>
<flag name="smartcard">Add support for smartcards</flag>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.10.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild
index 8b641fcc5aa7..38b59c995133 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.10.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild
@@ -19,7 +19,7 @@ else
fi
SLOT="0"
-IUSE="ap +crda broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps"
+IUSE="ap +crda broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls tkip uncommon-eap-types wep wimax wps"
# CONFIG_PRIVSEP=y does not have sufficient support for the new driver
# interface functions used for MACsec, so this combination cannot be used
@@ -271,9 +271,23 @@ src_configure() {
Kconfig_style_config OWE
Kconfig_style_config SAE
Kconfig_style_config DPP
+ Kconfig_style_config DPP2
Kconfig_style_config SUITEB192
Kconfig_style_config SUITEB
+ if use wep ; then
+ Kconfig_style_config WEP
+ else
+ Kconfig_style_config WEP n
+ fi
+
+ # Watch out, reversed logic
+ if use tkip ; then
+ Kconfig_style_config NO_TKIP n
+ else
+ Kconfig_style_config NO_TKIP
+ fi
+
if use smartcard ; then
Kconfig_style_config SMARTCARD
else