summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-11-14 15:41:49 +0100
committerGuilherme Amadio <amadio@gentoo.org>2018-11-15 14:37:33 +0100
commitd7cd91a14608932fb2afe06635f9da5c0be8d225 (patch)
tree626553b98f9613a8f21fd4aed815e8591fe2daed /profiles/features
parentdev-db/percona-xtrabackup: amd64 stable wrt bug #670970 (diff)
downloadgentoo-d7cd91a14608932fb2afe06635f9da5c0be8d225.tar.gz
gentoo-d7cd91a14608932fb2afe06635f9da5c0be8d225.tar.bz2
gentoo-d7cd91a14608932fb2afe06635f9da5c0be8d225.zip
profiles: prefixify dynamic linker used by sys-devel/clang
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'profiles/features')
-rw-r--r--profiles/features/prefix/standalone/profile.bashrc3
1 files changed, 3 insertions, 0 deletions
diff --git a/profiles/features/prefix/standalone/profile.bashrc b/profiles/features/prefix/standalone/profile.bashrc
index d167e7a9155f..20a3aff74cf5 100644
--- a/profiles/features/prefix/standalone/profile.bashrc
+++ b/profiles/features/prefix/standalone/profile.bashrc
@@ -26,6 +26,9 @@ elif [[ ${CATEGORY}/${PN} == sys-devel/clang && ${EBUILD_PHASE} == configure ]];
sed -i -e "s@DEFAULT_SYSROOT \"\"@DEFAULT_SYSROOT \"${EPREFIX}\"@" "${S}"/CMakeLists.txt
eend $?
pushd "${S}/lib/Driver/ToolChains" >/dev/null
+ ebegin "Use dynamic linker from ${EPREFIX}"
+ sed -i -e "/LibDir.*Loader/s@return \"\/\"@return \"${EPREFIX%/}/\"@" Linux.cpp
+ eend $?
ebegin "Remove --sysroot call on ld for native toolchain"
sed -i -e "$(grep -n -B1 sysroot= Gnu.cpp | sed -ne '{1s/-.*//;1p}'),+1 d" Gnu.cpp
eend $?