summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:11:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:12:09 +0200
commit2a9e25adaa568563c875886468ee6c9e405ba1e1 (patch)
tree318205d889103d141ae3d8e4dc910d2678bad124 /ros-meta/qt_gui_core/qt_gui_core-9999.ebuild
parentdev-ros/rqt_gui_cpp: Initial import. Ebuild by me. (diff)
downloadgentoo-2a9e25adaa568563c875886468ee6c9e405ba1e1.tar.gz
gentoo-2a9e25adaa568563c875886468ee6c9e405ba1e1.tar.bz2
gentoo-2a9e25adaa568563c875886468ee6c9e405ba1e1.zip
ros-meta/qt_gui_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/qt_gui_core/qt_gui_core-9999.ebuild')
-rw-r--r--ros-meta/qt_gui_core/qt_gui_core-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/ros-meta/qt_gui_core/qt_gui_core-9999.ebuild b/ros-meta/qt_gui_core/qt_gui_core-9999.ebuild
new file mode 100644
index 000000000000..34851c9c874d
--- /dev/null
+++ b/ros-meta/qt_gui_core/qt_gui_core-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Integration of the ROS package system and ROS-specific plugins for a Qt-based GUI"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_dotgraph
+ dev-ros/qt_gui
+ dev-ros/qt_gui_app
+ dev-ros/qt_gui_cpp
+ dev-ros/qt_gui_py_common
+"
+DEPEND="${RDEPEND}"