summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:14:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 14:14:06 +0200
commit984c386726f90ae67d81efb2eee12f8b4fa72941 (patch)
tree888672d40759da0f4b774aa80beaa6c8d385c626 /ros-meta/ros/ros-9999.ebuild
parentdev-ros/rosunit: Initial import. Ebuild by me. (diff)
downloadgentoo-984c386726f90ae67d81efb2eee12f8b4fa72941.tar.gz
gentoo-984c386726f90ae67d81efb2eee12f8b4fa72941.tar.bz2
gentoo-984c386726f90ae67d81efb2eee12f8b4fa72941.zip
ros-meta/ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/ros/ros-9999.ebuild')
-rw-r--r--ros-meta/ros/ros-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/ros-meta/ros/ros-9999.ebuild b/ros-meta/ros/ros-9999.ebuild
new file mode 100644
index 000000000000..24a2fb22eb9a
--- /dev/null
+++ b/ros-meta/ros/ros-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=ros
+
+inherit ros-catkin
+
+DESCRIPTION="ROS packaging system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbash
+ dev-ros/rosboost_cfg
+ dev-ros/rosclean
+ dev-ros/roscreate
+ dev-ros/rosmake
+ dev-ros/rosunit
+
+ dev-ros/mk
+ dev-ros/rosbuild
+ dev-ros/roslang
+ dev-ros/roslib
+"
+DEPEND="${RDEPEND}"