summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:17:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 18:17:39 +0200
commitaa988942ac52cd6889c70fb55d1ab544192042e4 (patch)
tree6e522052a81bee05cefd4cb020b86d5e439d8f23 /ros-meta/ros_base/ros_base-9999.ebuild
parentros-meta/common_tutorials: Initial import. Ebuild by me. (diff)
downloadgentoo-aa988942ac52cd6889c70fb55d1ab544192042e4.tar.gz
gentoo-aa988942ac52cd6889c70fb55d1ab544192042e4.tar.bz2
gentoo-aa988942ac52cd6889c70fb55d1ab544192042e4.zip
ros-meta/ros_base: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/ros_base/ros_base-9999.ebuild')
-rw-r--r--ros-meta/ros_base/ros_base-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/ros-meta/ros_base/ros_base-9999.ebuild b/ros-meta/ros_base/ros_base-9999.ebuild
new file mode 100644
index 000000000000..889d446ae525
--- /dev/null
+++ b/ros-meta/ros_base/ros_base-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_core and includes other basic non-robot tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ ros-meta/bond_core
+ dev-ros/class_loader
+ dev-ros/dynamic_reconfigure
+ ros-meta/common_tutorials
+ ros-meta/nodelet_core
+ dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"