summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:06:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:55 +0200
commit012e24bc9b90e70648dbc1ea8c1c561060d94301 (patch)
tree19d25da78962bc9c6e9dd066f8dda6062a8736ee /ros-meta/ros_comm
parentdev-ros/test_rosservice: Bump to 1.14.2. (diff)
downloadgentoo-012e24bc9b90e70648dbc1ea8c1c561060d94301.tar.gz
gentoo-012e24bc9b90e70648dbc1ea8c1c561060d94301.tar.bz2
gentoo-012e24bc9b90e70648dbc1ea8c1c561060d94301.zip
ros-meta/ros_comm: Bump to 1.14.2.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'ros-meta/ros_comm')
-rw-r--r--ros-meta/ros_comm/Manifest1
-rw-r--r--ros-meta/ros_comm/ros_comm-1.14.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/ros-meta/ros_comm/Manifest b/ros-meta/ros_comm/Manifest
index a678ef37f71e..ae04e98fe2fa 100644
--- a/ros-meta/ros_comm/Manifest
+++ b/ros-meta/ros_comm/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
+DIST ros_comm-1.14.2.tar.gz 1044745 BLAKE2B 1a5d47a4c6682c7a629d9d84be121a5eafcfc16621dec9a9ab9b57c2c7f9070f0007e15492ee44d86e1879351fae20bb9a759093424dd22ae7d44ae0f28e00e1 SHA512 8cece09572dc6b94a42eb49537cbcddbb954f70df01dc7ac9bd8aba17f53207b86afd8ccff81d929eca33bb9642ad7c530835d3f43471de497611940edae4777
diff --git a/ros-meta/ros_comm/ros_comm-1.14.2.ebuild b/ros-meta/ros_comm/ros_comm-1.14.2.ebuild
new file mode 100644
index 000000000000..b3bda6139bb7
--- /dev/null
+++ b/ros-meta/ros_comm/ros_comm-1.14.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS communications-related packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+# utilities subdir
+RDEPEND="
+ dev-ros/roslz4
+ dev-ros/xmlrpcpp
+ dev-ros/roswtf
+ dev-ros/message_filters
+"
+# tools subdir
+RDEPEND="${RDEPEND}
+ dev-ros/rosbag
+ dev-ros/rosbag_storage
+ dev-ros/rosgraph
+ dev-ros/roslaunch
+ dev-ros/rosmaster
+ dev-ros/rosmsg
+ dev-ros/rosnode
+ dev-ros/rosout
+ dev-ros/rosparam
+ dev-ros/rosservice
+ dev-ros/rostest
+ dev-ros/rostopic
+ dev-ros/topic_tools
+"
+# clients subdir
+RDEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rospy
+"
+# test subdir
+RDEPEND="${RDEPEND}
+ dev-ros/test_rosbag
+ dev-ros/test_rosbag_storage
+ dev-ros/test_roscpp
+ dev-ros/test_rosgraph
+ dev-ros/test_roslaunch
+ dev-ros/test_roslib_comm
+ dev-ros/test_rosmaster
+ dev-ros/test_rosparam
+ dev-ros/test_rospy
+ dev-ros/test_rosservice
+"
+DEPEND="${RDEPEND}"