summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:48:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:48:14 +0200
commita8609934ca9bb6e31ce0439201cc2192e0d09124 (patch)
tree4e6582fe3ca9d12746ba0ab2febc77bdcaf1fd6c /ros-meta/ros_tutorials
parentdev-ros/rospy_tutorials: Initial import. Ebuild by me. (diff)
downloadgentoo-a8609934ca9bb6e31ce0439201cc2192e0d09124.tar.gz
gentoo-a8609934ca9bb6e31ce0439201cc2192e0d09124.tar.bz2
gentoo-a8609934ca9bb6e31ce0439201cc2192e0d09124.zip
ros-meta/ros_tutorials: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/ros_tutorials')
-rw-r--r--ros-meta/ros_tutorials/Manifest1
-rw-r--r--ros-meta/ros_tutorials/metadata.xml5
-rw-r--r--ros-meta/ros_tutorials/ros_tutorials-0.6.1.ebuild22
-rw-r--r--ros-meta/ros_tutorials/ros_tutorials-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/ros-meta/ros_tutorials/Manifest b/ros-meta/ros_tutorials/Manifest
new file mode 100644
index 000000000000..b0543368940a
--- /dev/null
+++ b/ros-meta/ros_tutorials/Manifest
@@ -0,0 +1 @@
+DIST ros_tutorials-0.6.1.tar.gz 126792 SHA256 0227557d49343c8dc2c17f5fba6a44ca8fe46cb0d9f34315bf4c2f8c3d9969f5 SHA512 f09e5451030c0a76a9473020535e79ac06e748f4208109cf83e61526d13472c3390402814a3d145cb793c5418af703cd9959ca57143798d1706185c13d3418c5 WHIRLPOOL 861fec5410f5e1f6930b537f757abf120ee5b10b843a39010e0dc04f170c627c793dbf462fa1ac0a2c3f150780915d01ade459f973453a053ee53e2ccae7d795
diff --git a/ros-meta/ros_tutorials/metadata.xml b/ros-meta/ros_tutorials/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/ros-meta/ros_tutorials/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/ros_tutorials/ros_tutorials-0.6.1.ebuild b/ros-meta/ros_tutorials/ros_tutorials-0.6.1.ebuild
new file mode 100644
index 000000000000..1aec096a39e5
--- /dev/null
+++ b/ros-meta/ros_tutorials/ros_tutorials-0.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates various features of ROS, as well as support packages which help demonstrate them"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp_tutorials
+ dev-ros/rospy_tutorials
+ dev-ros/turtlesim
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/ros_tutorials/ros_tutorials-9999.ebuild b/ros-meta/ros_tutorials/ros_tutorials-9999.ebuild
new file mode 100644
index 000000000000..1aec096a39e5
--- /dev/null
+++ b/ros-meta/ros_tutorials/ros_tutorials-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates various features of ROS, as well as support packages which help demonstrate them"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp_tutorials
+ dev-ros/rospy_tutorials
+ dev-ros/turtlesim
+"
+DEPEND="${RDEPEND}"