summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-04-04 21:40:55 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-04-05 22:11:06 +0000
commit4634017093489bee4687f9dd544a34b97e17da2e (patch)
treea83d8797da6321a7e7749f99961330c7bf7805cb /sci-astronomy/casacore
parentdev-python/argcomplete: Version bump to 1.1.1 (diff)
downloadgentoo-4634017093489bee4687f9dd544a34b97e17da2e.tar.gz
gentoo-4634017093489bee4687f9dd544a34b97e17da2e.tar.bz2
gentoo-4634017093489bee4687f9dd544a34b97e17da2e.zip
sci-astronomy/casacore: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-astronomy/casacore')
-rw-r--r--sci-astronomy/casacore/Manifest1
-rw-r--r--sci-astronomy/casacore/casacore-2.1.0.ebuild84
-rw-r--r--sci-astronomy/casacore/files/casacore-disable-tpath-test.patch49
-rw-r--r--sci-astronomy/casacore/metadata.xml1
4 files changed, 134 insertions, 1 deletions
diff --git a/sci-astronomy/casacore/Manifest b/sci-astronomy/casacore/Manifest
index bed219b55b96..0584fd74d323 100644
--- a/sci-astronomy/casacore/Manifest
+++ b/sci-astronomy/casacore/Manifest
@@ -1 +1,2 @@
DIST casacore-2.0.3.tar.gz 7250964 SHA256 44746633113e16f8daabb38c404d2b316b1acfd9304a4df91cb1849d2786d726 SHA512 f434e52cfd2903730c18857126c11eb4fbfe5f7a0555d82f423562d6f41c682262c7bf4775954b16ed60d872a067fc5495ac9aaa17deb9555381436b1a26c741 WHIRLPOOL 8836a27f07f231d676879c69504a32dbd893092a9378ac259698ffe07ee050cedb24dd298b38e4ef86b1c6ea4fac42e9941cd6e9317cf1d404da897c34b6866f
+DIST casacore-2.1.0.tar.gz 10173155 SHA256 9c0017e741c1c4b14bc09582867910f750cd76ff2673e0ecd554aa5b2db7acb4 SHA512 ab52bed9ebc5aef79c7b46c963c90fe9db2e7bac82249f99ed0def2496065ae337cdd9359fb9a6c0182fc3faa702f476116bf0edffc54585a3353a43ce6ddd9f WHIRLPOOL cda1fba87a02d5564a3f56c93eaad2c674bc7f8795d4bd56152549174405cd761ef1df5a00d27ebd0d2bf37fe663b17bbd961508607d1a39e1c494795f6fa755
diff --git a/sci-astronomy/casacore/casacore-2.1.0.ebuild b/sci-astronomy/casacore/casacore-2.1.0.ebuild
new file mode 100644
index 000000000000..68298834ebff
--- /dev/null
+++ b/sci-astronomy/casacore/casacore-2.1.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# python3 is experimental and only one python is supported
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils eutils toolchain-funcs fortran-2 python-single-r1
+
+DESCRIPTION="Core libraries for the Common Astronomy Software Applications"
+HOMEPAGE="https://github.com/casacore/casacore"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="c++11 +data doc fftw hdf5 openmp python threads test"
+
+RDEPEND="
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sys-libs/readline:0=
+ virtual/blas
+ virtual/lapack
+ data? ( sci-astronomy/casa-data )
+ fftw? ( sci-libs/fftw:3.0= )
+ hdf5? ( sci-libs/hdf5:0= )
+ python? ( dev-libs/boost:0=[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( sci-astronomy/casa-data sci-astronomy/sofa_c )"
+
+PATCHES=( "${FILESDIR}/${PN}-disable-tpath-test.patch" )
+
+pkg_pretend() {
+ if [[ $(tc-getCC)$ == *gcc* ]] && [[ ${MERGE_TYPE} != binary ]]; then
+ use c++11 && [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) && \
+ die "You are using gcc but gcc-4.7 or higher is required for C++11"
+ use openmp && ! tc-has-openmp && \
+ die "You are using gcc but without OpenMP capabilities that you requested"
+ fi
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ fortran-2_pkg_setup
+}
+
+src_configure() {
+ has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
+ local mycmakeargs=(
+ -DENABLE_SHARED=ON
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DDATA_DIR="${EPREFIX}/usr/share/casa/data"
+ -DBUILD_PYTHON="$(usex python)"
+ -DBUILD_TESTING="$(usex test)"
+ -DCXX11="$(usex c++11)"
+ -DUSE_FFTW3="$(usex fftw)"
+ -DUSE_HDF5="$(usex hdf5)"
+ -DUSE_OPENMP="$(usex openmp)"
+ -DUSE_THREADS="$(usex threads)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen doxygen.cfg || die
+ fi
+}
+
+src_install(){
+ cmake-utils_src_install
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/html
+ fi
+}
diff --git a/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch b/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch
new file mode 100644
index 000000000000..e92e1e7ac4f8
--- /dev/null
+++ b/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch
@@ -0,0 +1,49 @@
+From: Benda Xu <heroxbd@gentoo.org>
+Date: Wed, 29 Oct 2014 16:40:47 +0900
+Subject: disable tPath test
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Forwarded: no need
+Description: sbuild gets HOME variable leaked into the build environment
+ Debian uses sbuild as official build farm. Until the cause is pinned down,
+ this test is disabled.
+
+ 98/425 Test #101: tPath ...............................***Failed 0.64 sec
+1,16d0
+< expanded: /home/heroxbd
+< expected: /«PKGBUILDDIR»
+< absolute: /home/heroxbd
+< expected: /«PKGBUILDDIR»
+< expanded: /home/heroxbd/test/test2
+< expected: /«PKGBUILDDIR»/test/test2
+< absolute: /home/heroxbd/test/test2
+< expected: /«PKGBUILDDIR»/test/test2
+< expanded: /home/heroxbd/test
+< expected: /«PKGBUILDDIR»/test
+< absolute: /home/heroxbd/test
+< expected: /«PKGBUILDDIR»/test
+< expanded: /home/heroxbd/test
+< expected: /«PKGBUILDDIR»/test
+< absolute: /home/heroxbd/test
+< expected: /«PKGBUILDDIR»/test
+33a18
+> OK
+FAIL (output not verified): ./tPath
+---
+ casa/OS/test/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/casa/OS/test/CMakeLists.txt b/casa/OS/test/CMakeLists.txt
+index 4a31f7a..10d5b80 100644
+--- a/casa/OS/test/CMakeLists.txt
++++ b/casa/OS/test/CMakeLists.txt
+@@ -12,7 +12,6 @@ tMemory
+ tMemoryTrace
+ tModcompConversion
+ tMutex
+-tPath
+ tPrecTimer
+ tTime
+ tTimer
diff --git a/sci-astronomy/casacore/metadata.xml b/sci-astronomy/casacore/metadata.xml
index 048e5b3ca55f..67227b679918 100644
--- a/sci-astronomy/casacore/metadata.xml
+++ b/sci-astronomy/casacore/metadata.xml
@@ -11,7 +11,6 @@
which were the code of the discontinued AIPS++ package.
</longdescription>
<upstream>
- <remote-id type="google-code">casacore</remote-id>
<remote-id type="github">casacore/casacore</remote-id>
</upstream>
<use>