summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/galaxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/galaxy')
-rw-r--r--sci-astronomy/galaxy/Manifest1
-rw-r--r--sci-astronomy/galaxy/galaxy-2.2.ebuild44
-rw-r--r--sci-astronomy/galaxy/metadata.xml10
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-astronomy/galaxy/Manifest b/sci-astronomy/galaxy/Manifest
new file mode 100644
index 000000000000..9629c281427d
--- /dev/null
+++ b/sci-astronomy/galaxy/Manifest
@@ -0,0 +1 @@
+DIST galaxy-2.2.tar.gz 146675 SHA256 88d7bcfe7c25ad260f2f7b5abce2e3bb69c9e3e0661772a9016b2356160f1c00 SHA512 b3843f4ef7bdd60d761db019ded8af99b4c520ecc1c852a210bc6282751474254d9b9172e738015c7b01df57502655749051baac11448797fb9b71ecd4edd8d6 WHIRLPOOL 4d2bf2df59a89eb4cb459f2e90dbdc9992796c22d539fde9c0c918473eafdccb80ee4cad77c8da7c79b9d9c372431332cf0562ae5326ac718072d7c0f1128b53
diff --git a/sci-astronomy/galaxy/galaxy-2.2.ebuild b/sci-astronomy/galaxy/galaxy-2.2.ebuild
new file mode 100644
index 000000000000..aeb097140831
--- /dev/null
+++ b/sci-astronomy/galaxy/galaxy-2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fdo-mime toolchain-funcs flag-o-matic
+
+# probably change every release
+PID="1/3/0/3/13035936"
+
+DESCRIPTION="Stellar simulation program"
+HOMEPAGE="http://www.kornelix.com/galaxy.html"
+SRC_URI="http://www.kornelix.com/uploads/${PID}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="x11-libs/gtk+:3"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+pkg_setup() {
+ tc-export CXX
+ append-cxxflags -pthread
+ append-ldflags -pthread
+ export PREFIX="${EPREFIX}/usr"
+}
+
+src_prepare() {
+ sed -e '/DOCDIR/ s/PROGRAM)/&-\$(VERSION)/g' \
+ -e '/xdg-desktop-menu/d' \
+ -i Makefile || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-astronomy/galaxy/metadata.xml b/sci-astronomy/galaxy/metadata.xml
new file mode 100644
index 000000000000..94a0b6211442
--- /dev/null
+++ b/sci-astronomy/galaxy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ Stellar simulation program. Watch a few stars move around each-other,
+ accelerated by their mutual attractions, or watch thousands of random
+ stars evolve into a spiral galaxy.
+</longdescription>
+</pkgmetadata>