summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 03:14:05 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 07:01:27 +0000
commit6a9a725664ad99e22b74846d102e4ac52167ec46 (patch)
tree31d30e2da04a66052808d6e01f7ebf00873acf03 /sci-astronomy/pal/pal-0.9.7.ebuild
parentsci-astronomy/astrometry: version bump (diff)
downloadgentoo-6a9a725664ad99e22b74846d102e4ac52167ec46.tar.gz
gentoo-6a9a725664ad99e22b74846d102e4ac52167ec46.tar.bz2
gentoo-6a9a725664ad99e22b74846d102e4ac52167ec46.zip
sci-astronomy/pal: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-astronomy/pal/pal-0.9.7.ebuild')
-rw-r--r--sci-astronomy/pal/pal-0.9.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-astronomy/pal/pal-0.9.7.ebuild b/sci-astronomy/pal/pal-0.9.7.ebuild
new file mode 100644
index 000000000000..bd8451b6d4d4
--- /dev/null
+++ b/sci-astronomy/pal/pal-0.9.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Positional Astronomy Library"
+HOMEPAGE="http://github.com/Starlink/pal"
+SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+RDEPEND="sci-astronomy/erfa:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --without-starlink \
+ --without-stardocs \
+ --with-erfa \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ # remove cruft from non-fhs complient
+ rm -r "${ED}"usr/share/pal || die
+ rm -r "${ED}"usr/{docs,manifests,news} || die
+ use static-libs || prune_libtool_files --all
+}