summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-07 21:00:43 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-07 21:02:24 +0000
commit732d5c38a89687a8c064fb5e5033b911254412c4 (patch)
treefcf9ed551a93cbd4f46a4249df86e9af7fdb3c07 /sci-astronomy/psfex/psfex-3.17.1.ebuild
parentsci-astronomy/scamp: initial import (diff)
downloadgentoo-732d5c38a89687a8c064fb5e5033b911254412c4.tar.gz
gentoo-732d5c38a89687a8c064fb5e5033b911254412c4.tar.bz2
gentoo-732d5c38a89687a8c064fb5e5033b911254412c4.zip
sci-astronomy/psfex: initial import
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/psfex/psfex-3.17.1.ebuild')
-rw-r--r--sci-astronomy/psfex/psfex-3.17.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sci-astronomy/psfex/psfex-3.17.1.ebuild b/sci-astronomy/psfex/psfex-3.17.1.ebuild
new file mode 100644
index 000000000000..d288e5b4196e
--- /dev/null
+++ b/sci-astronomy/psfex/psfex-3.17.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
+HOMEPAGE="http://www.astromatic.net/software/psfex"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc threads plplot"
+
+RDEPEND="
+ sci-libs/atlas:0[lapack,threads=]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-have-mmap.patch"
+ "${FILESDIR}/${P}-plplot510.patch"
+ "${FILESDIR}/${P}-sigbus.patch"
+)
+
+src_prepare() {
+ default
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] &&
+ myclapack=ptclapack
+ fi
+ # fix the configure and not the acx_atlas.m4. the eautoreconf will
+ # produce a configure giving a wrong install Makefile target (to fix)
+ sed -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s/-llapack/-l${myclapack}/g" \
+ -e "s/\(lapack_lib=\).*/\1${myclapack}/g" \
+ -e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
+ -i acx_atlas.m4 || die
+
+ # fix for newer plplot
+ sed -e 's/plplotd/plplot/g' -i acx_plplot.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
+ $(use_enable plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*
+}