summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2018-11-09 00:32:43 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 00:00:27 +0100
commitc4f0ac180ab68aacd7b0e20e2802bacce1e72c6e (patch)
treebb9683d9c10dce3c737fdecacbe76ef1f7214933 /sci-astronomy/stellarium
parentsci-astronomy/stellarium: version 0.18.2 (diff)
downloadgentoo-c4f0ac180ab68aacd7b0e20e2802bacce1e72c6e.tar.gz
gentoo-c4f0ac180ab68aacd7b0e20e2802bacce1e72c6e.tar.bz2
gentoo-c4f0ac180ab68aacd7b0e20e2802bacce1e72c6e.zip
sci-astronomy/stellarium: enable test
Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy/stellarium')
-rw-r--r--sci-astronomy/stellarium/stellarium-0.18.2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sci-astronomy/stellarium/stellarium-0.18.2.ebuild b/sci-astronomy/stellarium/stellarium-0.18.2.ebuild
index 5e6e6cc48c88..25ffaeb162c0 100644
--- a/sci-astronomy/stellarium/stellarium-0.18.2.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.18.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils desktop flag-o-matic gnome2-utils
+inherit cmake-utils desktop flag-o-matic gnome2-utils virtualx
DESCRIPTION="3D photo-realistic skies in real time"
HOMEPAGE="http://www.stellarium.org/"
@@ -22,9 +22,7 @@ PATCHES=( "${FILESDIR}"/${P}.patch )
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps media nls stars"
-
-RESTRICT="test" # There are no tests
+IUSE="debug gps media nls stars test"
RDEPEND="
dev-qt/qtcore:5
@@ -43,8 +41,9 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-qt/qtconcurrent:5
- dev-qt/qttest:5
- nls? ( dev-qt/linguist-tools:5 )"
+ nls? ( dev-qt/linguist-tools:5 )
+ test? ( dev-qt/qttest:5 )
+"
LANGS=(
af am ar as ast az be bg bn bo br bs ca cs
@@ -82,10 +81,15 @@ src_configure() {
-DENABLE_GPS="$(usex gps)"
-DENABLE_NLS="$(usex nls)"
-DENABLE_MEDIA="$(usex media)"
+ -DENABLE_TESTING="$(usex test)"
)
cmake-utils_src_configure
}
+src_test() {
+ virtx cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install