summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/xfitsview/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/xfitsview/files')
-rw-r--r--sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch b/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
new file mode 100644
index 000000000000..6b010a3ea721
--- /dev/null
+++ b/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
@@ -0,0 +1,54 @@
+* Fix parallel build
+* Respect LDFLAGS
+* Fix build with gmake 3.82
+
+http://bugs.gentoo.org/show_bug.cgi?id=337479
+
+--- Makefile.in
++++ Makefile.in
+@@ -61,26 +61,26 @@
+ LIBDIR = lib/$(ARCH)/
+ CFLAGS = -Iinclude -Ifitssubs @MOTIF_CPPFLAGS@ @X_CFLAGS@ \
+ $(DEBUG) $(OSFLAGS) @CFLAGS@
+-LIBS = @MOTIF_LIBS@ -lfitsLib
+-LDFLAGS = @MOTIF_LDFLAGS@ @X_LIBS@ -L$(LIBDIR)
++LIBS = @MOTIF_LIBS@ @X_LIBS@ -L$(LIBDIR) -lfitsLib
++LDFLAGS = @LDFLAGS@ @MOTIF_LDFLAGS@
+
+ all: $(TARGETS)
+
+ # update source/object directory
+ srcupdate:
+- cd src; $(MAKE)
++ $(MAKE) -C src
+
+ # update fitssubs source/object directory
+ fitsupdate:
+- cd fitssubs; $(MAKE)
++ $(MAKE) -C fitssubs
+
+ # update fitssubs library directory
+-libupdate:
+- cd lib; $(MAKE) RANLIB="$(RANLIB)"
++libupdate: fitsupdate srcupdate
++ $(MAKE) RANLIB="$(RANLIB)" -C lib
+
+ # Link Obitview
+-XFITSview: lib/$(ARCH)/libfitsLib.a src/*.c XFITSview.c
+- $(CC) XFITSview.c -o XFITSview $(CFLAGS) src/*.o $(LDFLAGS) $(LIBS)
++XFITSview: XFITSview.c libupdate
++ $(CC) $(LDFLAGS) XFITSview.c -o XFITSview $(CFLAGS) src/*.o $(LIBS)
+
+ # make gzipped tar backup of directory
+ backup:
+--- fitssubs/Makefile.in
++++ fitssubs/Makefile.in
+@@ -69,7 +69,7 @@
+
+
+ # create library directory if needed
+-../lib/$(ARCH): ../lib
++$(LIBDIR): ../lib
+ mkdir ../lib/$(ARCH)
+
+ clean: