summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-16 05:29:20 +0000
committerSam James <sam@gentoo.org>2022-05-16 05:29:20 +0000
commit436c3cf55dd8a5f8522bc4fee2dd8607d0cbf244 (patch)
tree0dbbb0e4d9d05e03de4bf410f436d48cb1baf6c1 /sci-astronomy
parentsci-astronomy/siril: version bump 1.0.1 (diff)
downloadgentoo-436c3cf55dd8a5f8522bc4fee2dd8607d0cbf244.tar.gz
gentoo-436c3cf55dd8a5f8522bc4fee2dd8607d0cbf244.tar.bz2
gentoo-436c3cf55dd8a5f8522bc4fee2dd8607d0cbf244.zip
sci-astronomy/siril: fix openmp check
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/siril/siril-1.0.1.ebuild8
-rw-r--r--sci-astronomy/siril/siril-9999.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-astronomy/siril/siril-1.0.1.ebuild b/sci-astronomy/siril/siril-1.0.1.ebuild
index 822c1fba9bfd..e24c4af5709a 100644
--- a/sci-astronomy/siril/siril-1.0.1.ebuild
+++ b/sci-astronomy/siril/siril-1.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson xdg
+inherit meson toolchain-funcs xdg
DESCRIPTION="A free astronomical image processing software"
HOMEPAGE="https://www.siril.org/"
@@ -54,7 +54,11 @@ PATCHES=(
DOCS=( README.md NEWS ChangeLog LICENSE.md LICENSE_sleef.txt AUTHORS )
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {
diff --git a/sci-astronomy/siril/siril-9999.ebuild b/sci-astronomy/siril/siril-9999.ebuild
index 822c1fba9bfd..e24c4af5709a 100644
--- a/sci-astronomy/siril/siril-9999.ebuild
+++ b/sci-astronomy/siril/siril-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson xdg
+inherit meson toolchain-funcs xdg
DESCRIPTION="A free astronomical image processing software"
HOMEPAGE="https://www.siril.org/"
@@ -54,7 +54,11 @@ PATCHES=(
DOCS=( README.md NEWS ChangeLog LICENSE.md LICENSE_sleef.txt AUTHORS )
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {