summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-30 08:49:38 +0100
committerSam James <sam@gentoo.org>2022-03-21 23:40:34 +0000
commit45d83c2ed06362b5531c59474679c29260ded35a (patch)
treef4482fb215f352b32c370ddba929a5c0452e9ebf /sci-astronomy
parentapp-editors/gvim: version bump to v8.2.4586. (diff)
downloadgentoo-45d83c2ed06362b5531c59474679c29260ded35a.tar.gz
gentoo-45d83c2ed06362b5531c59474679c29260ded35a.tar.bz2
gentoo-45d83c2ed06362b5531c59474679c29260ded35a.zip
sci-astronomy/wcslib: version bump 7.7
* moved `flex` and `pkgconfig` to BDEPEND * fixed race condition during test phase Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://bugs.gentoo.org/834504 Closes: https://github.com/gentoo/gentoo/pull/24671 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/Manifest1
-rw-r--r--sci-astronomy/wcslib/files/wcslib-7.7-tofits.patch22
-rw-r--r--sci-astronomy/wcslib/wcslib-7.7.ebuild75
3 files changed, 98 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index ecd92c3235f6..49d7c3568ab2 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -1,3 +1,4 @@
DIST wcslib-7.3.1.tar.bz2 2434274 BLAKE2B 9789a8eb34fe37c96b52e20efe3c14368499058e5c46aad4853b2be5f32a31df26525ec2c38d0ce87bcb7891b91a3ec3ac537e3c662c716a7c4381f26cd715e4 SHA512 753e0e202fb4250d321c36a0df9cd45ed88697111a06e108bc3e5397ddecc60d460cda2b4d45b5311dd72b88b66d4c70ff150b03e2da46c834b024f15304779b
DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
DIST wcslib-7.4.tar.bz2 2446483 BLAKE2B e659e0f7d4aa54d599c1300f600bc8b7b56d672fa715be1e7c3ade4ff6eebaf68a2894dac73032b1f3aee5965254f359681718c93949962f4a59bdda448d5395 SHA512 3696f59bf15f3806faff2441250f8ae38bfbbc1e2e25404c9480c82629472521d89306d9340475ea4691c5e1a8417be3f058b4a01b49c9a45e0e718056a9394c
+DIST wcslib-7.7.tar.bz2 2515760 BLAKE2B f5418513168903e14488004abeb5ec2f69d773f49a5abc28598d184ba66df2232b87fb0754fc63800951ea2e794741fbde119794feca2d822287cd63d3fa658c SHA512 372eb32d28ee78be14a3e8f1fba2a51c2b1f69de3bb70bf49487653878f905b4c463a0b7fc9cb06cf4fdd0b23114d3ec26d853072e0fd06d6e14610f0dfa06d4
diff --git a/sci-astronomy/wcslib/files/wcslib-7.7-tofits.patch b/sci-astronomy/wcslib/files/wcslib-7.7-tofits.patch
new file mode 100644
index 000000000000..5c8022560220
--- /dev/null
+++ b/sci-astronomy/wcslib/files/wcslib-7.7-tofits.patch
@@ -0,0 +1,22 @@
+--- wcslib-7.7/Fortran/GNUmakefile
++++ wcslib-7.7/Fortran/GNUmakefile
+@@ -171,8 +171,8 @@
+ -@ echo ''
+ $(FC) $(FFLAGS) -c $<
+
+-%.fits : ../C/test/%.keyrec tofits
+- ./tofits < $< > $@
++%.fits : ../C/test/%.keyrec ../utils/tofits
++ ../utils/tofits < $< > $@
+
+ run_% : %
+ -@ echo ''
+@@ -361,7 +361,7 @@
+ -@ echo ''
+ $(MAKE) -C ../pgsbox lib
+
+-tofits : ../C/test/tofits.c
++../utils/tofits : ../utils/tofits.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ ../C/wcstab.fits : ;
diff --git a/sci-astronomy/wcslib/wcslib-7.7.ebuild b/sci-astronomy/wcslib/wcslib-7.7.ebuild
new file mode 100644
index 000000000000..0e2822299e62
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-7.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+inherit flag-o-matic fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/7"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs +tools"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/flex-2.6.0
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tofits.patch"
+)
+
+src_configure() {
+ # workaround until upstream fix it properly
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable fortran)
+ $(use_enable tools utils)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf "${myconf[@]}"
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_test() {
+ # -j1 to work around a race condition
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs share the same symbols as shared (i.e. compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}