summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-03-25 21:13:12 +0100
committerSam James <sam@gentoo.org>2022-05-16 05:26:06 +0000
commit479f2008aaad0c97c277c420934fff5fc8e6c2fd (patch)
treed377e4c805aa59c179735a8b5b432c7ed9a06248 /sci-astronomy
parentmedia-libs/librtprocess: new package (diff)
downloadgentoo-479f2008aaad0c97c277c420934fff5fc8e6c2fd.tar.gz
gentoo-479f2008aaad0c97c277c420934fff5fc8e6c2fd.tar.bz2
gentoo-479f2008aaad0c97c277c420934fff5fc8e6c2fd.zip
sci-astronomy/siril: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://bugs.gentoo.org/575932 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/siril/Manifest1
-rw-r--r--sci-astronomy/siril/files/siril-docfiles.patch16
-rw-r--r--sci-astronomy/siril/metadata.xml30
-rw-r--r--sci-astronomy/siril/siril-1.0.0.ebuild66
-rw-r--r--sci-astronomy/siril/siril-9999.ebuild66
5 files changed, 179 insertions, 0 deletions
diff --git a/sci-astronomy/siril/Manifest b/sci-astronomy/siril/Manifest
new file mode 100644
index 000000000000..4290e92f9877
--- /dev/null
+++ b/sci-astronomy/siril/Manifest
@@ -0,0 +1 @@
+DIST siril-1.0.0.tar.bz2 2830447 BLAKE2B 0c7b52682a71db6ec618357ce5ee5e88f144b0d00b0649a00755fe81fe49a90cfa5283aabbe0648670e39210ff2cb94cd0b6223f17f70458056b693d3d77eccf SHA512 b31fa0df0ae447130b20bc07a597d52e0e50991f1faebd990c5890001a46a704b1a3fe4915db118b53b3661a5888f031d5ab29e562bb8018060aea0a83cad5d3
diff --git a/sci-astronomy/siril/files/siril-docfiles.patch b/sci-astronomy/siril/files/siril-docfiles.patch
new file mode 100644
index 000000000000..f98e0210d7e6
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-docfiles.patch
@@ -0,0 +1,16 @@
+--- siril-1.0.0/meson.build
++++ siril-1.0.0/meson.build
+@@ -497,13 +497,6 @@
+ ]
+
+ install_man(man_files)
+-install_data(['AUTHORS', 'LICENSE.md', 'LICENSE_sleef.txt'],
+- rename : [
+- 'doc/siril/AUTHORS',
+- 'doc/siril/LICENSE.md',
+- 'doc/siril/LICENSE_sleef.txt',
+- ],
+- install_dir : siril_share)
+
+
+ ################################################################################
diff --git a/sci-astronomy/siril/metadata.xml b/sci-astronomy/siril/metadata.xml
new file mode 100644
index 000000000000..580487d37ad5
--- /dev/null
+++ b/sci-astronomy/siril/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ SIRIL is an astronomical image processing tool.
+
+ It is specially tailored for noise reduction and improving the
+ signal/noise ratio of an image from multiple captures, as required in
+ astronomy. SIRIL can align automatically or manually, stack and enhance
+ pictures from various file formats, even image sequence files (films
+ and SER files). It works well with limited system resources, like in
+ embedded platforms, but is also very fast when run on more powerful
+ computers.
+ </longdescription>
+ <use>
+ <flag name="heif">Add support for the HEIF image format</flag>
+ <flag name="wcs">Add supprt astrometry features using <pkg>sci-astronomy/wcslib</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">free-astro/siril</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-astronomy/siril/siril-1.0.0.ebuild b/sci-astronomy/siril/siril-1.0.0.ebuild
new file mode 100644
index 000000000000..822c1fba9bfd
--- /dev/null
+++ b/sci-astronomy/siril/siril-1.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A free astronomical image processing software"
+HOMEPAGE="https://www.siril.org/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/free-astro/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/free-astro/siril/-/archive/${PV/_/-}/${PN}-${PV/_/-}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="curl ffmpeg gnuplot heif jpeg openmp png raw tiff wcs"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/json-glib-1.2.6
+ >=dev-libs/libconfig-1.4[cxx]
+ >=media-gfx/exiv2-0.25
+ media-libs/librtprocess:=
+ >=media-libs/opencv-4.4.0:=
+ sci-libs/cfitsio
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.20.0:3
+ curl? ( net-misc/curl )
+ ffmpeg? ( media-video/ffmpeg:= )
+ heif? ( media-libs/libheif )
+ jpeg? ( virtual/jpeg )
+ png? ( >=media-libs/libpng-1.6.0 )
+ raw? ( media-libs/libraw )
+ tiff? ( media-libs/tiff )
+ wcs? ( >=sci-astronomy/wcslib-7.7 )
+"
+RDEPEND="
+ ${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docfiles.patch"
+)
+
+DOCS=( README.md NEWS ChangeLog LICENSE.md LICENSE_sleef.txt AUTHORS )
+
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use openmp)
+ $(usex curl -Denable-libcurl=yes -Denable-libcurl=no)
+ )
+ meson_src_configure
+}
diff --git a/sci-astronomy/siril/siril-9999.ebuild b/sci-astronomy/siril/siril-9999.ebuild
new file mode 100644
index 000000000000..822c1fba9bfd
--- /dev/null
+++ b/sci-astronomy/siril/siril-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A free astronomical image processing software"
+HOMEPAGE="https://www.siril.org/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/free-astro/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/free-astro/siril/-/archive/${PV/_/-}/${PN}-${PV/_/-}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="curl ffmpeg gnuplot heif jpeg openmp png raw tiff wcs"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/json-glib-1.2.6
+ >=dev-libs/libconfig-1.4[cxx]
+ >=media-gfx/exiv2-0.25
+ media-libs/librtprocess:=
+ >=media-libs/opencv-4.4.0:=
+ sci-libs/cfitsio
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.20.0:3
+ curl? ( net-misc/curl )
+ ffmpeg? ( media-video/ffmpeg:= )
+ heif? ( media-libs/libheif )
+ jpeg? ( virtual/jpeg )
+ png? ( >=media-libs/libpng-1.6.0 )
+ raw? ( media-libs/libraw )
+ tiff? ( media-libs/tiff )
+ wcs? ( >=sci-astronomy/wcslib-7.7 )
+"
+RDEPEND="
+ ${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docfiles.patch"
+)
+
+DOCS=( README.md NEWS ChangeLog LICENSE.md LICENSE_sleef.txt AUTHORS )
+
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use openmp)
+ $(usex curl -Denable-libcurl=yes -Denable-libcurl=no)
+ )
+ meson_src_configure
+}