summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-01 16:05:00 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-01 16:05:29 +0100
commitb6e954e30d906676f203c02b983e4367dd602209 (patch)
tree751cc2bba7f061f915bd118ed87762e0b089c952 /sci-astronomy
parentmedia-gfx/darktable: do not set CMAKE_BUILD_TYPE (diff)
downloadgentoo-b6e954e30d906676f203c02b983e4367dd602209.tar.gz
gentoo-b6e954e30d906676f203c02b983e4367dd602209.tar.bz2
gentoo-b6e954e30d906676f203c02b983e4367dd602209.zip
sci-astronomy/xephem: add version 4.1.0
This version adds ssl support Closes: https://bugs.gentoo.org/776166 Closes: https://bugs.gentoo.org/774933 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/xephem/Manifest1
-rw-r--r--sci-astronomy/xephem/files/xephem-4.1.0-respect_env_vars.patch128
-rw-r--r--sci-astronomy/xephem/xephem-4.1.0.ebuild58
3 files changed, 187 insertions, 0 deletions
diff --git a/sci-astronomy/xephem/Manifest b/sci-astronomy/xephem/Manifest
index 05ea2af9342a..09e25047eca9 100644
--- a/sci-astronomy/xephem/Manifest
+++ b/sci-astronomy/xephem/Manifest
@@ -1 +1,2 @@
DIST xephem-3.7.7.tgz 18128521 BLAKE2B a7d0ee2cf1be64f79ed0c5cea6d37e48c69875de5b3c9592554ee8be25b369e964c7a6bb05690ef28893b7af8277daf39ba85538f56852f35538180f9ad0c2ba SHA512 0a21f783a0a543f19a527afb87647ff2e988c6a426a37e01b9a3d1d76a9ee74125ce802e2dbc5e13034f11ef897e6188cb5b0bb92bc0d35db0fb8839e0c53157
+DIST xephem-4.1.0.tar.gz 17213750 BLAKE2B 921aa4b305cb80df5746db962739d16ee23f1831b59934389ecd218b874ba1fc51aab07896d1283760db1a50be6279da50ed112320fc481f90b4f2d6e25c96dc SHA512 bcad3a6b375cabf1f44e39bc99386552d97a7e7d2ee4063dae4ccd3d5842604f0efc3407447f18a5c9e7f265bab6eebe98bdb64626dcf2135b56f346818ef1b6
diff --git a/sci-astronomy/xephem/files/xephem-4.1.0-respect_env_vars.patch b/sci-astronomy/xephem/files/xephem-4.1.0-respect_env_vars.patch
new file mode 100644
index 000000000000..0f08e4380c30
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-4.1.0-respect_env_vars.patch
@@ -0,0 +1,128 @@
+diff --git a/GUI/xephem/Makefile b/GUI/xephem/Makefile
+index dd653c7..32966ee 100644
+--- a/GUI/xephem/Makefile
++++ b/GUI/xephem/Makefile
+@@ -9,9 +9,9 @@
+ # one executable, xephem.
+
+ # These -I and -L flags point to the supporting XEphem libraries
+-LIBINC = -I../../libastro -I../../libip -I../../liblilxml -I../../libjpegd -I../../libpng -I../../libz
+-LIBLNK = -L../../libastro -L../../libip -L../../liblilxml -L../../libjpegd -L../../libpng -L../../libz
+-LIBLIB = -lastro -lip -llilxml -ljpegd -lpng -lz
++LIBINC = -I../../libastro -I../libastro -I../../libip -I../libip -I../../liblilxml -I../liblilxml
++LIBLNK = -L../../libastro -L../libastro -L../../libip -L../libip -L../../liblilxml -L../liblilxml
++LIBLIB = -lastro -lip -llilxml -ljpeg -lpng -lz
+
+ # MOTIFI is the directory containing the Xm directory of include files.
+ # MOTIFL is the directory containing the libXm.a library.
+@@ -29,12 +29,9 @@ MOTIFL = /usr/lib
+ endif
+
+ # for linux and Apple OS X
+-CC = gcc
+-CLDFLAGS = -g
+-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/opt/X11/include
+-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/opt/X11/lib
+ XLIBS = -lXm -lXt -lXext -lXmu -lX11
+-LIBS = $(XLIBS) $(LIBLIB) -lm -lssl
++CFLAGS := $(LIBINC) $(CFLAGS)
++LIBS = $(LIBLNK) $(XLIBS) $(LIBLIB) -lm -lssl
+
+ # static linking on Apple using X11 libs from ports
+ # CC = gcc
+@@ -194,12 +191,9 @@ xephem.1: xephem.man
+ nroff -man $? > $@
+
+ libs:
+- cd ../../libastro; make
+- cd ../../libip; make
+- cd ../../libjpegd; make
+- cd ../../liblilxml; make
+- cd ../../libpng; make
+- cd ../../libz; make
++ $(MAKE) -C ../../libastro
++ $(MAKE) -C ../../libip
++ $(MAKE) -C ../../liblilxml
+
+ clean:
+ rm -fr *.o ../../lib*/*.[ao]
+diff --git a/libastro/Makefile b/libastro/Makefile
+index 0a8ecb6..a640c95 100644
+--- a/libastro/Makefile
++++ b/libastro/Makefile
+@@ -4,8 +4,6 @@
+ # compiler and flags
+
+ # gcc
+-CC = gcc
+-CFLAGS= -O2 -Wall
+
+ # macosx universal binary
+ # CFLAGS= -O2 -Wall -arch i386 -arch ppc
+@@ -83,11 +81,11 @@ OBJS = \
+ vsop87_data.o
+
+ libastro.a: $(HS) $(OBJS)
+- ar rv $@ $(OBJS)
+- ranlib $@
++ $(AR) rv $@ $(OBJS)
++ $(RANLIB) $@
+
+ libastro.so: $(HS) $(OBJS)
+- $(CC) -shared -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+
+ clobber:
+ rm -f *.o libastro.a
+diff --git a/libip/Makefile b/libip/Makefile
+index 5c36ac8..f093d6f 100644
+--- a/libip/Makefile
++++ b/libip/Makefile
+@@ -2,8 +2,6 @@
+ # (C) 2001 Elwood Charles Downey
+
+ # gcc
+-CC = gcc
+-CFLAGS= -I../libastro -O2 -Wall
+
+ # macosx universal binary
+ # CFLAGS= -I../libastro -O2 -Wall -arch i386 -arch ppc
+@@ -36,11 +34,11 @@ OBJS = \
+ HS = ip.h fsmatch.h
+
+ libip.a: $(HS) $(OBJS)
+- ar rv $@ $(OBJS)
+- ranlib $@
++ $(AR) rv $@ $(OBJS)
++ $(RANLIB) $@
+
+ libip.so: $(OBJS)
+- gcc -shared -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+
+ clobber:
+ rm -f *.o libip.a
+diff --git a/liblilxml/Makefile b/liblilxml/Makefile
+index 2e73761..c75651b 100644
+--- a/liblilxml/Makefile
++++ b/liblilxml/Makefile
+@@ -4,8 +4,6 @@
+ # compiler and flags
+
+ # gcc
+-CC = gcc
+-CFLAGS= -O2 -Wall
+
+ # macosx universal binary
+ # CFLAGS= -O2 -Wall -arch i386 -arch ppc
+@@ -27,8 +25,8 @@ HS = lilxml.h
+ OBJS = lilxml.o base64.o
+
+ liblilxml.a: $(HS) $(OBJS)
+- ar r $@ $(OBJS)
+- ranlib $@
++ $(AR) r $@ $(OBJS)
++ $(RANLIB) $@
+
+ liltest: liltest.o liblilxml.a
+ $(CC) $(LDFLAGS) -o liltest liltest.o liblilxml.a
diff --git a/sci-astronomy/xephem/xephem-4.1.0.ebuild b/sci-astronomy/xephem/xephem-4.1.0.ebuild
new file mode 100644
index 000000000000..93bd0f5554d6
--- /dev/null
+++ b/sci-astronomy/xephem/xephem-4.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Interactive tool for astronomical ephemeris and sky simulation"
+HOMEPAGE="https://xephem.github.io/XEphem/Site/xephem.html"
+SRC_URI="https://github.com/XEphem/XEphem/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/XEphem-${PV}"
+
+LICENSE="MIT"
+SLOT=0
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-libs/openssl:=
+ >=x11-libs/motif-2.3:0
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/groff"
+
+HTML_DOCS=( GUI/xephem/help/. )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.7.7-implicits.patch"
+ "${FILESDIR}/${P}-respect_env_vars.patch"
+)
+
+src_compile() {
+ tc-export CC AR RANLIB
+ emake -C GUI/xephem
+}
+
+src_install() {
+ insinto /usr/share/X11/app-defaults
+ newins - XEphem <<-EOF
+ XEphem.ShareDir: /usr/share/${PN}
+ EOF
+ newenvd - 99xephem <<-EOF
+ XEHELPURL=/usr/share/doc/${PF}/html/xephem.html
+ EOF
+ einstalldocs
+
+ cd GUI/xephem || die
+ dobin xephem
+ doman xephem.1
+ newicon XEphem.png ${PN}.png
+ insinto /usr/share/${PN}
+ doins -r auxil catalogs fifos fits gallery lo
+ make_desktop_entry xephem XEphem ${PN}
+}