summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-02 04:19:34 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-02 04:19:34 +0100
commitf84da63476bd6108105d349f74e6710237a8b290 (patch)
tree30df96b5dbb84e67bbe8cd8de31ea247999b91f3 /sci-biology/bamtools/bamtools-2.4.2.ebuild
parentdev-perl/Module-Starter: Bump to version 1.730.0 (diff)
downloadgentoo-f84da63476bd6108105d349f74e6710237a8b290.tar.gz
gentoo-f84da63476bd6108105d349f74e6710237a8b290.tar.bz2
gentoo-f84da63476bd6108105d349f74e6710237a8b290.zip
sci-biology/bamtools: Version bump to 2.4.2
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sci-biology/bamtools/bamtools-2.4.2.ebuild')
-rw-r--r--sci-biology/bamtools/bamtools-2.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-biology/bamtools/bamtools-2.4.2.ebuild b/sci-biology/bamtools/bamtools-2.4.2.ebuild
new file mode 100644
index 000000000000..e6daa8262028
--- /dev/null
+++ b/sci-biology/bamtools/bamtools-2.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
+HOMEPAGE="https://github.com/pezmaster31/bamtools"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pezmaster31/bamtools.git"
+else
+ SRC_URI="https://github.com/pezmaster31/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}" # no stable ABI yet
+
+RDEPEND="
+ >=dev-libs/jsoncpp-1.8.0:=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+mycmakeargs=( -DBUILD_SHARED_LIBS=ON )