summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/bamtools/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/bamtools/files')
-rw-r--r--sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch32
-rw-r--r--sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch23
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch b/sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch
new file mode 100644
index 000000000000..318396e75c36
--- /dev/null
+++ b/sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch
@@ -0,0 +1,32 @@
+ src/CMakeLists.txt | 1 -
+ src/api/CMakeLists.txt | 4 ++--
+ src/toolkit/bamtools_filter.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index e359695..2bd2185 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -6,7 +6,6 @@
+ # ==========================
+
+ add_subdirectory( api )
+-add_subdirectory( third_party )
+ add_subdirectory( toolkit )
+ add_subdirectory( utils )
+
+diff --git a/src/api/CMakeLists.txt b/src/api/CMakeLists.txt
+index 66eb35f..65f4639 100644
+--- a/src/api/CMakeLists.txt
++++ b/src/api/CMakeLists.txt
+@@ -54,8 +54,8 @@ target_link_libraries( BamTools ${APILibs} )
+ target_link_libraries( BamTools-static ${APILibs} )
+
+ # set library install destinations
+-install( TARGETS BamTools LIBRARY DESTINATION "lib/bamtools" RUNTIME DESTINATION "bin")
+-install( TARGETS BamTools-static ARCHIVE DESTINATION "lib/bamtools")
++install( TARGETS BamTools LIBRARY DESTINATION "lib${LIB_SUFFIX}" RUNTIME DESTINATION "bin")
++install( TARGETS BamTools-static ARCHIVE DESTINATION "lib${LIB_SUFFIX}")
+
+ # export API headers
+ include(../ExportHeader.cmake)
diff --git a/sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch b/sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch
new file mode 100644
index 000000000000..c07c59d2cddd
--- /dev/null
+++ b/sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch
@@ -0,0 +1,23 @@
+--- bamtools-2.3.0/src/api/CMakeLists.txt.ori 2013-08-27 18:00:43.000000000 +0200
++++ bamtools-2.3.0/src/api/CMakeLists.txt 2013-08-27 18:00:47.000000000 +0200
+@@ -54,8 +54,8 @@
+ target_link_libraries( BamTools-static ${APILibs} )
+
+ # set library install destinations
+-install( TARGETS BamTools LIBRARY DESTINATION "lib/bamtools" RUNTIME DESTINATION "bin")
+-install( TARGETS BamTools-static ARCHIVE DESTINATION "lib/bamtools")
++install( TARGETS BamTools LIBRARY DESTINATION "lib${LIB_SUFFIX}" RUNTIME DESTINATION "bin")
++install( TARGETS BamTools-static ARCHIVE DESTINATION "lib${LIB_SUFFIX}")
+
+ # export API headers
+ include(../ExportHeader.cmake)
+--- bamtools-2.3.0/src/CMakeLists.txt.ori 2013-08-27 18:03:10.000000000 +0200
++++ bamtools-2.3.0/src/CMakeLists.txt 2013-08-27 18:03:23.000000000 +0200
+@@ -6,7 +6,6 @@
+ # ==========================
+
+ add_subdirectory( api )
+-add_subdirectory( third_party )
+ add_subdirectory( toolkit )
+ add_subdirectory( utils )
+