summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-10-11 10:04:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-14 14:47:58 +0200
commit50fe91c03b9c8431a871463ee75ae68bdfc8a171 (patch)
treea24a4853e88633356002bf9d088f4e2a23b4c306 /sci-biology/bowtie/bowtie-0.12.8.ebuild
parentsci-biology/bowtie-2.2.6: Enable 'tbb' USE flag by default (diff)
downloadgentoo-50fe91c03b9c8431a871463ee75ae68bdfc8a171.tar.gz
gentoo-50fe91c03b9c8431a871463ee75ae68bdfc8a171.tar.bz2
gentoo-50fe91c03b9c8431a871463ee75ae68bdfc8a171.zip
sci-biology/bowtie: bring back stable bowtie-0.12.8
bowtie-0.12.8 is the only stable variant and removing it breaks the stable depgraph.
Diffstat (limited to 'sci-biology/bowtie/bowtie-0.12.8.ebuild')
-rw-r--r--sci-biology/bowtie/bowtie-0.12.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/bowtie/bowtie-0.12.8.ebuild b/sci-biology/bowtie/bowtie-0.12.8.ebuild
new file mode 100644
index 000000000000..c26c986ed194
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-0.12.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ultrafast memory-efficient short read aligner"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86 ~x64-macos"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+# NB: Bundles code from Maq (http://maq.sf.net) and the SeqAn library (http://www.seqan.de)
+# TODO: properly report system CFLAGS in -DCOMPILE_OPTIONS
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-47.patch
+}
+
+src_compile() {
+ unset CFLAGS
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CXX="$(tc-getCXX)" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS=""
+}
+
+src_install() {
+ dobin bowtie bowtie-*
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+ newman MANUAL bowtie.1
+ dodoc AUTHORS NEWS TUTORIAL
+}