summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-10-10 21:04:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-14 14:47:58 +0200
commitddbfba3594bda0b32f359e057555d477ffbced1e (patch)
treeea878cf553eda9db8df5ca4d710fd83d4ef22f54 /sci-biology/bowtie/bowtie-1.1.2.ebuild
parentx11-libs/gdk-pixbuf: run glibc-specific test only on glibc (diff)
downloadgentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.tar.gz
gentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.tar.bz2
gentoo-ddbfba3594bda0b32f359e057555d477ffbced1e.zip
sci-biology/bowtie: version bump, SLOT major version
sci-biology/bowtie is now SLOTed, in order to allow for a parallel installation with bowtie2. In addition, the latest bowtie now supports dev-cpp/tbb with 'tbb' USE flag.
Diffstat (limited to 'sci-biology/bowtie/bowtie-1.1.2.ebuild')
-rw-r--r--sci-biology/bowtie/bowtie-1.1.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-biology/bowtie/bowtie-1.1.2.ebuild b/sci-biology/bowtie/bowtie-1.1.2.ebuild
new file mode 100644
index 000000000000..55eec5060787
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-1.1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
+
+LICENSE="Artistic"
+SLOT="1"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+IUSE="examples tbb"
+
+DEPEND="app-arch/unzip
+ tbb? ( dev-cpp/tbb )"
+RDEPEND=""
+
+DOCS=( AUTHORS NEWS TUTORIAL doc/README )
+HTML_DOCS=( doc/{manual.html,style.css} )
+
+src_prepare() {
+ # Suppress useless -Wall pollution
+ sed -i 's/\-Wall/\-Wno-enum-compare/g' Makefile || die
+
+ # always include tinythread.cpp
+ epatch "${FILESDIR}/${P}-tbb-tinythread-missing.patch"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CFLAGS="" \
+ CXXFLAGS="" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS}" \
+ WITH_TBB="$(usex tbb 1 0)"
+}
+
+src_install() {
+ dobin ${PN} ${PN}-*
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*
+
+ newman MANUAL ${PN}.1
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r genomes indexes
+ fi
+}