summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-24 22:09:33 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-24 22:23:36 +0100
commit470054f8e4bca944eff4bed8b471a088d2927a00 (patch)
tree8a08951650076a955cca1bfb62228a12c687e658 /sci-biology/dialign-tx/dialign-tx-1.0.2-r2.ebuild
parentsys-auth/polkit: hppa stable wrt bug #632492 (diff)
downloadgentoo-470054f8e4bca944eff4bed8b471a088d2927a00.tar.gz
gentoo-470054f8e4bca944eff4bed8b471a088d2927a00.tar.bz2
gentoo-470054f8e4bca944eff4bed8b471a088d2927a00.zip
sci-biology/dialign-tx: Fix C99 inline semantics
* Also port to EAPI 6 Closes: https://bugs.gentoo.org/640188 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-biology/dialign-tx/dialign-tx-1.0.2-r2.ebuild')
-rw-r--r--sci-biology/dialign-tx/dialign-tx-1.0.2-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/dialign-tx/dialign-tx-1.0.2-r2.ebuild b/sci-biology/dialign-tx/dialign-tx-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..123977916f06
--- /dev/null
+++ b/sci-biology/dialign-tx/dialign-tx-1.0.2-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P=${PN^^}_${PV}
+
+DESCRIPTION="Greedy and progressive approaches for segment-based multiple sequence alignment"
+HOMEPAGE="http://dialign-tx.gobics.de/"
+SRC_URI="http://dialign-tx.gobics.de/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-implicits.patch
+ "${FILESDIR}"/${P}-modernize.patch
+ "${FILESDIR}"/${P}-gnu89-inline.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake -C source clean
+ emake -C source
+}
+
+src_install() {
+ dobin source/dialign-tx
+ insinto /usr/$(get_libdir)/${PN}/conf
+ doins -r conf/.
+}
+
+pkg_postinst() {
+ einfo "The configuration directory is"
+ einfo "${EROOT%/}/usr/$(get_libdir)/${PN}/conf"
+ einfo "You will need to pass this to ${PN} on every run."
+}