summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-24 22:22:37 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-24 22:23:41 +0100
commit94b001b50c3cdcf0a1b083e0916f8d381f9522ac (patch)
treee037cb0a31eba52ec6c286ee0d69a0b3ed1f509e /sci-biology/dialign2/dialign2-2.2.1.ebuild
parentsci-biology/dialign-tx: Fix C99 inline semantics (diff)
downloadgentoo-94b001b50c3cdcf0a1b083e0916f8d381f9522ac.tar.gz
gentoo-94b001b50c3cdcf0a1b083e0916f8d381f9522ac.tar.bz2
gentoo-94b001b50c3cdcf0a1b083e0916f8d381f9522ac.zip
sci-biology/dialign2: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-biology/dialign2/dialign2-2.2.1.ebuild')
-rw-r--r--sci-biology/dialign2/dialign2-2.2.1.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/sci-biology/dialign2/dialign2-2.2.1.ebuild b/sci-biology/dialign2/dialign2-2.2.1.ebuild
index 13ce733d8a79..db310e3fe8d3 100644
--- a/sci-biology/dialign2/dialign2-2.2.1.ebuild
+++ b/sci-biology/dialign2/dialign2-2.2.1.ebuild
@@ -1,34 +1,37 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Multiple sequence alignment"
HOMEPAGE="http://bibiserv.techfak.uni-bielefeld.de/dialign"
-SRC_URI="http://bibiserv.techfak.uni-bielefeld.de/applications/dialign/resources/downloads/dialign-2.2.1-src.tar.gz"
+SRC_URI="http://bibiserv.techfak.uni-bielefeld.de/applications/dialign/resources/downloads/dialign-${PV}-src.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-S="${WORKDIR}"/dialign_package
+S=${WORKDIR}/dialign_package
+PATCHES=( "${FILESDIR}"/${PN}-2.2.1-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+ append-cppflags -I. -DCONS
+}
src_compile() {
- emake -C src \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I. -DCONS -c"
+ emake -C src
}
src_install() {
dobin src/${PN}-2
insinto /usr/share/${PN}
- doins dialign2_dir/*
+ doins -r dialign2_dir/.
- cat >> "${T}"/80${PN} <<- EOF
- DIALIGN2_DIR="${EPREFIX}/usr/share/${PN}"
+ cat >> "${T}"/80${PN} <<- EOF || die
+ DIALIGN2_DIR="${EPREFIX}/usr/share/${PN}"
EOF
doenvd "${T}"/80${PN}
}