summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/lagan/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/lagan/files')
-rw-r--r--sci-biology/lagan/files/lagan-2.0-flags.patch107
-rw-r--r--sci-biology/lagan/files/lagan-2.0-gcc4.3.patch23
2 files changed, 130 insertions, 0 deletions
diff --git a/sci-biology/lagan/files/lagan-2.0-flags.patch b/sci-biology/lagan/files/lagan-2.0-flags.patch
new file mode 100644
index 000000000000..e324ef64c4c6
--- /dev/null
+++ b/sci-biology/lagan/files/lagan-2.0-flags.patch
@@ -0,0 +1,107 @@
+diff --git a/Makefile b/Makefile
+index fbbbe79..a1d449b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,5 @@
+ all:
+- (cd src; $(MAKE))
++ $(MAKE) -C src
+ clean:
+ rm -f chaos anchors order glocal utils/bin2bl mlagan utils/cstat utils/bin2mf utils/rc *~ utils/contigorder utils/getbounds utils/cextract utils/seqmerge utils/getlength utils/getoverlap utils/*~ utils/scorealign utils/scorecontigs mlagan.purify utils/getcontigpos utils/fa2xfa utils/Glue utils/dotplot utils/overlay
+ (cd src; $(MAKE) clean)
+diff --git a/src/Makefile b/src/Makefile
+index 7f6b6fd..dd6309b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -4,51 +4,51 @@ CFLAGS = -O3 # -Wall -W
+ TRGT_DIR = ..
+
+ all: ../anchors ../chaos ../order ../mlagan ../prolagan ../utils/bin2mf ../utils/bin2bl ../utils/cextract ../utils/cstat ../utils/contigorder ../utils/getbounds ../utils/getlength ../utils/getoverlap ../utils/rc ../utils/seqmerge ../utils/scorealign ../utils/scorecontigs ../utils/getcontigpos ../utils/fa2xfa ../utils/Glue ../utils/dotplot ../utils/overlay
+- (cd glocal; $(MAKE))
++ $(MAKE) -C glocal
+ clean:
+ rm -f *.o *~ utils/*~ mlagan.purify core
+ (cd glocal; $(MAKE) clean)
+ ../anchors: anchors.c skiplist.c
+- $(CC) -o $(TRGT_DIR)/anchors anchors.c skiplist.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/anchors anchors.c skiplist.c
+ ../chaos: fchaos.c thrtrie.c skiplist.c global.c translate.c mempage.c filebuffer.c
+- $(CC) -o $(TRGT_DIR)/chaos fchaos.c thrtrie.c skiplist.c global.c translate.c filebuffer.c -lm -DCHAOS__FLAG
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/chaos fchaos.c thrtrie.c skiplist.c global.c translate.c filebuffer.c -lm -DCHAOS__FLAG
+ ../order: order.c diagmatrix.c filebuffer.c
+- $(CC) -o $(TRGT_DIR)/order order.c diagmatrix.c filebuffer.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/order order.c diagmatrix.c filebuffer.c
+ ../mlagan: mlagan.c diagmatrix.c multial.c skiplist.c filebuffer.c
+- $(CC) -o $(TRGT_DIR)/mlagan mlagan.c multial.c diagmatrix.c skiplist.c filebuffer.c -lm -DMULTIAL__FLAG
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/mlagan mlagan.c multial.c diagmatrix.c skiplist.c filebuffer.c -lm -DMULTIAL__FLAG
+ ../prolagan: prolagan.c diagmatrix.c multial.c skiplist.c filebuffer.c
+- $(CC) -o $(TRGT_DIR)/prolagan prolagan.c multial.c diagmatrix.c skiplist.c filebuffer.c -lm -DMULTIAL__FLAG
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/prolagan prolagan.c multial.c diagmatrix.c skiplist.c filebuffer.c -lm -DMULTIAL__FLAG
+ ../utils/bin2mf: utils/bin2mf.c
+- $(CC) -o $(TRGT_DIR)/utils/bin2mf utils/bin2mf.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/bin2mf utils/bin2mf.c
+ ../utils/bin2bl: utils/bin2bl.c
+- $(CC) -o $(TRGT_DIR)/utils/bin2bl utils/bin2bl.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/bin2bl utils/bin2bl.c
+ ../utils/cextract: utils/cextract.c
+- $(CC) -o $(TRGT_DIR)/utils/cextract utils/cextract.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/cextract utils/cextract.c
+ ../utils/cstat: utils/cstat.c
+- $(CC) -o $(TRGT_DIR)/utils/cstat utils/cstat.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/cstat utils/cstat.c
+ ../utils/contigorder: utils/contigorder.c
+- $(CC) -o $(TRGT_DIR)/utils/contigorder utils/contigorder.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/contigorder utils/contigorder.c
+ ../utils/getbounds: utils/getbounds.c
+- $(CC) -o $(TRGT_DIR)/utils/getbounds utils/getbounds.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/getbounds utils/getbounds.c
+ ../utils/getcontigpos: utils/getcontigpos.c
+- $(CC) -o $(TRGT_DIR)/utils/getcontigpos utils/getcontigpos.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/getcontigpos utils/getcontigpos.c
+ ../utils/getlength: utils/getlength.c
+- $(CC) -o $(TRGT_DIR)/utils/getlength utils/getlength.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/getlength utils/getlength.c
+ ../utils/getoverlap: utils/getoverlap.c
+- $(CC) -o $(TRGT_DIR)/utils/getoverlap utils/getoverlap.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/getoverlap utils/getoverlap.c
+ ../utils/rc: utils/rc.c
+- $(CC) -o $(TRGT_DIR)/utils/rc utils/rc.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/rc utils/rc.c
+ ../utils/seqmerge: utils/seqmerge.c
+- $(CC) -o $(TRGT_DIR)/utils/seqmerge utils/seqmerge.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/seqmerge utils/seqmerge.c
+ ../utils/scorealign: utils/scorealign.c
+- $(CC) -o $(TRGT_DIR)/utils/scorealign utils/scorealign.c -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/scorealign utils/scorealign.c -lm
+ ../utils/scorecontigs: utils/scorecontigs.c
+- $(CC) -o $(TRGT_DIR)/utils/scorecontigs utils/scorecontigs.c -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/scorecontigs utils/scorecontigs.c -lm
+ ../utils/fa2xfa: utils/fa2xfa.c
+- $(CC) -o $(TRGT_DIR)/utils/fa2xfa utils/fa2xfa.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/fa2xfa utils/fa2xfa.c
+ ../utils/overlay: utils/overlay.c
+- $(CC) -o $(TRGT_DIR)/utils/overlay utils/overlay.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/overlay utils/overlay.c
+ ../utils/Glue: utils/Glue.cpp
+- $(CPP) -o $(TRGT_DIR)/utils/Glue utils/Glue.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/Glue utils/Glue.cpp
+ ../utils/dotplot: utils/dotplot.cpp
+- $(CPP) -o $(TRGT_DIR)/utils/dotplot utils/dotplot.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(TRGT_DIR)/utils/dotplot utils/dotplot.cpp
+diff --git a/src/glocal/Makefile b/src/glocal/Makefile
+index ce1421a..b82507f 100755
+--- a/src/glocal/Makefile
++++ b/src/glocal/Makefile
+@@ -10,10 +10,10 @@ TRGT = glocal
+ OBJECTS = glocal.o io.o rightinfluence.o leftinfluence.o score.o
+
+ .cpp.o:
+- $(CC) -Wno-deprecated $(CFLAGS) $(INCDIR) -c $*.cpp
++ $(CXX) $(CXXFLAGS) $(INCDIR) -c $*.cpp
+
+ $(TRGT): $(OBJECTS)
+- $(CLINKER) $(OPTFLAGS) $(OBJECTS) -o $(TRGT_DIR)/$(TRGT) $(MLIB)
++ $(CXX) $(LDFLAGS) $(OBJECTS) -o $(TRGT_DIR)/$(TRGT) $(MLIB)
+
+ clean :
+ rm -f *.o ./*~ *~ core
diff --git a/sci-biology/lagan/files/lagan-2.0-gcc4.3.patch b/sci-biology/lagan/files/lagan-2.0-gcc4.3.patch
new file mode 100644
index 000000000000..a4b1d6808e2f
--- /dev/null
+++ b/sci-biology/lagan/files/lagan-2.0-gcc4.3.patch
@@ -0,0 +1,23 @@
+diff -durr lagan20-orig/src/glocal/score.cpp lagan20/src/glocal/score.cpp
+--- lagan20-orig/src/glocal/score.cpp 2009-02-04 15:25:57.698333297 +0000
++++ lagan20/src/glocal/score.cpp 2009-02-04 15:27:23.894092890 +0000
+@@ -2,7 +2,7 @@
+ #include<score.h>
+ #include<leftinfluence.h>
+ #include<rightinfluence.h>
+-#include<fstream.h>
++#include<fstream>
+
+ extern vector<class Score*> scoreFunctions[1<<(UPSTRANDBITS+DOWNSTRANDBITS+RELPOSBITS)];
+
+diff -durr lagan20-orig/src/utils/Glue.cpp lagan20/src/utils/Glue.cpp
+--- lagan20-orig/src/utils/Glue.cpp 2009-02-04 15:25:57.702333182 +0000
++++ lagan20/src/utils/Glue.cpp 2009-02-04 15:27:04.190822654 +0000
+@@ -1,6 +1,7 @@
+ #include "MultiSequence.h"
+ #include "SafeVector.h"
+ #include "Output.h"
++#include <string.h>
+ #include <math.h>
+ #include <assert.h>
+ #include <fstream>