summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/mummer/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/mummer/files')
-rw-r--r--sci-biology/mummer/files/3.22-ldflags.patch16
-rw-r--r--sci-biology/mummer/files/3.22-prll.patch56
-rw-r--r--sci-biology/mummer/files/mummer-3.20-gcc43.patch12
3 files changed, 84 insertions, 0 deletions
diff --git a/sci-biology/mummer/files/3.22-ldflags.patch b/sci-biology/mummer/files/3.22-ldflags.patch
new file mode 100644
index 000000000000..d3c4a60a1adb
--- /dev/null
+++ b/sci-biology/mummer/files/3.22-ldflags.patch
@@ -0,0 +1,16 @@
+diff --git a/src/tigr/Makefile b/src/tigr/Makefile
+index cf6b9ca..5b28d1e 100644
+--- a/src/tigr/Makefile
++++ b/src/tigr/Makefile
+@@ -9,9 +9,9 @@ AUX_BIN_DIR := $(CURDIR)
+ endif
+
+ OBJ_RULE = $(CXX) $(CXXFLAGS) $< -c -o $@
+-BIN_RULE = $(CXX) $(CXXFLAGS) $^ -o $(BIN_DIR)/$@; \
++BIN_RULE = $(CXX) $(LDFLAGS) $(CXXFLAGS) $^ -o $(BIN_DIR)/$@; \
+ chmod 755 $(BIN_DIR)/$@
+-AUX_BIN_RULE = $(CXX) $(CXXFLAGS) $^ -o $(AUX_BIN_DIR)/$@; \
++AUX_BIN_RULE = $(CXX) $(LDFLAGS) $(CXXFLAGS) $^ -o $(AUX_BIN_DIR)/$@; \
+ chmod 755 $(AUX_BIN_DIR)/$@
+ VPATH := $(AUX_BIN_DIR):$(BIN_DIR)
+
diff --git a/sci-biology/mummer/files/3.22-prll.patch b/sci-biology/mummer/files/3.22-prll.patch
new file mode 100644
index 000000000000..3b24ee40214a
--- /dev/null
+++ b/sci-biology/mummer/files/3.22-prll.patch
@@ -0,0 +1,56 @@
+diff --git a/Makefile b/Makefile
+index 4db4977..bbd00ed 100644
+--- a/Makefile
++++ b/Makefile
+@@ -114,15 +114,15 @@ install: all
+
+
+ kurtz:
+- cd $(KURTZ_SRC_DIR); $(MAKE) mummer
++ $(MAKE) -C $(KURTZ_SRC_DIR) mummer
+
+
+ scripts:
+- cd $(SCRIPT_DIR); $(MAKE) all
++ $(MAKE) -C $(SCRIPT_DIR) all
+
+
+ tigr:
+- cd $(TIGR_SRC_DIR); $(MAKE) all
++ $(MAKE) -C $(TIGR_SRC_DIR) all
+
+
+ uninstall: clean
+diff --git a/src/kurtz/Makefile b/src/kurtz/Makefile
+index 85dfc16..5bff793 100644
+--- a/src/kurtz/Makefile
++++ b/src/kurtz/Makefile
+@@ -1,7 +1,7 @@
+ all:
+- cd libbasedir; $(MAKE) all
+- cd streesrc; $(MAKE) all
+- cd mm3src; $(MAKE) all
++ $(MAKE) -C libbasedir all
++ $(MAKE) -C streesrc all
++ $(MAKE) -C mm3src all
+
+ clean:
+ rm -f *~
+@@ -10,11 +10,11 @@ clean:
+ cd mm3src; $(MAKE) clean
+
+ mummer:
+- cd libbasedir; $(MAKE) libbase.a
+- cd streesrc; $(MAKE) libstree.a
+- cd mm3src; $(MAKE) mummer
++ $(MAKE) -C libbasedir libbase.a
++ $(MAKE) -C streesrc libstree.a
++ $(MAKE) -C mm3src mummer
+
+ splintall:
+- cd libbasedir; ${MAKE} splintall
+- cd streesrc; ${MAKE} splintall
+- cd mm3src; ${MAKE} splintall
++ $(MAKE) -C libbasedir splintall
++ $(MAKE) -C streesrc splintall
++ $(MAKE) -C mm3src splintall
diff --git a/sci-biology/mummer/files/mummer-3.20-gcc43.patch b/sci-biology/mummer/files/mummer-3.20-gcc43.patch
new file mode 100644
index 000000000000..4d3edb41e46a
--- /dev/null
+++ b/sci-biology/mummer/files/mummer-3.20-gcc43.patch
@@ -0,0 +1,12 @@
+--- src/tigr/show-diff.cc.orig 2008-06-16 17:55:34.000000000 +0000
++++ src/tigr/show-diff.cc 2008-06-16 17:56:25.000000000 +0000
+@@ -14,6 +14,8 @@
+ #include <cstdlib>
+ #include <cassert>
+ #include <climits>
++#include <algorithm>
++
+ using namespace std;
+
+
+