summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/picard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/picard')
-rw-r--r--sci-biology/picard/Manifest1
-rw-r--r--sci-biology/picard/files/1.103-gentoo.patch131
-rw-r--r--sci-biology/picard/metadata.xml9
-rw-r--r--sci-biology/picard/picard-1.103.ebuild70
4 files changed, 211 insertions, 0 deletions
diff --git a/sci-biology/picard/Manifest b/sci-biology/picard/Manifest
new file mode 100644
index 000000000000..814765877966
--- /dev/null
+++ b/sci-biology/picard/Manifest
@@ -0,0 +1 @@
+DIST picard-1.103.tar.bz2 15037887 SHA256 777af2a0aadd97a2b909160774e6e0ad99cef6de7763096f10660ccbe2baca63 SHA512 f8db38a8fee278868cd2ea11f78275a5defadf36e053703133f0f90836df8e3a3ca08635fd7c02967ed99b52bc5baffa600a34b58a94288d3eede7f5c3dd79ca WHIRLPOOL de5a0341473174bfc7a1f1b8d1b3b6122b212a1d964dda534912347595a3da9fe2a86692959df7375896292e3f3657a9c27c2f1694fca60d48ff23192b93b098
diff --git a/sci-biology/picard/files/1.103-gentoo.patch b/sci-biology/picard/files/1.103-gentoo.patch
new file mode 100644
index 000000000000..00e89b95056a
--- /dev/null
+++ b/sci-biology/picard/files/1.103-gentoo.patch
@@ -0,0 +1,131 @@
+diff --git a/build.xml b/build.xml
+index fca2271..11f4fbd 100755
+--- a/build.xml
++++ b/build.xml
+@@ -52,9 +52,6 @@
+ <property name="testng.verbosity" value="2"/>
+ <property name="test.debug.port" value="5005" /> <!-- override on the command line if desired -->
+
+- <property environment="env"/>
+- <property name="java6.home" value="${env.JAVA6_HOME}"/>
+-
+ <condition property="isUnix">
+ <os family="unix"/>
+ </condition>
+@@ -78,9 +75,6 @@
+ <pathelement location="${classes}"/>
+ </path>
+
+- <path id="java6.lib.ref">
+- <fileset dir="${java6.home}/lib" includes="*.jar"/>
+- </path>
+ </target>
+
+ <!-- CLEAN -->
+@@ -94,10 +88,6 @@
+ </target>
+
+ <!-- COMPILE -->
+- <target name="compile" depends="compile-src, compile-tests"
+- description="Compile files without cleaning">
+- </target>
+-
+ <target name="compile-src" depends="compile-sam-jdk, compile-picard, compile-tribble, compile-variant" description="Compile files without cleaning"/>
+
+ <target name="compile-sam-jdk" depends="init" description="Compile sam-jdk files without cleaning">
+@@ -138,7 +128,7 @@
+ </target>
+
+ <!-- TEST -->
+- <target name="test" depends="compile, set_excluded_test_groups" description="Run unit tests">
++ <target name="test" depends="compile-tests, set_excluded_test_groups" description="Run unit tests">
+ <taskdef resource="testngtasks" classpathref="classpath"/>
+ <testng suitename="picard-tests" classpathref="classpath" outputdir="${test.output}"
+ failureproperty="tests.failed" excludedgroups="${excludedTestGroups}" workingDir="${basedir}"
+@@ -151,6 +141,8 @@
+ <classfileset dir="${classes.test}">
+ <include name="**/Test*.class"/>
+ <include name="**/*Test.class"/>
++ <exclude name="**/ValidateSamFileTest.class" />
++ <exclude name="**/VCFWriterUnitTest.class" />
+ </classfileset>
+ <jvmarg value="-Xmx2G"/>
+ </testng>
+@@ -165,7 +157,7 @@
+ </target>
+
+ <target name="single-test"
+- depends="compile, compile-tests"
++ depends="compile-tests"
+ description="Compile and run a single test.">
+ <taskdef resource="testngtasks" classpathref="classpath"/>
+ <fail unless="name" message="Please provide input test: -Dname=..." />
+@@ -200,13 +192,12 @@
+ </jar>
+ </target>
+
+- <target name="picard-jar" depends="compile"
++ <target name="picard-jar" depends="compile-src"
+ description="Builds picard-${picard-version}.jar for inclusion in other projects">
+ <mkdir dir="${dist}"/>
+ <jar destfile="${dist}/picard-${picard-version}.jar" compress="no">
+ <fileset dir="${classes}" includes ="net/sf/picard/**/*.*"/>
+ <fileset dir="${src.scripts}" includes="**/*.R"/>
+- <zipfileset src="${lib}/apache-ant-1.8.2-bzip2.jar"/>
+ <manifest>
+ <attribute name="Implementation-Version" value="${picard-version}(${repository.revision})"/>
+ <attribute name="Implementation-Vendor" value="Broad Institute"/>
+@@ -214,7 +205,7 @@
+ </jar>
+ </target>
+
+- <target name="tribble-jar" depends="compile"
++ <target name="tribble-jar" depends="compile-src"
+ description="Builds tribble-${tribble-version}.jar for inclusion in other projects">
+ <mkdir dir="${dist}"/>
+ <jar destfile="${dist}/tribble-${tribble-version}.jar" compress="no">
+@@ -225,7 +216,7 @@
+ </copy>
+ </target>
+
+- <target name="variant-jar" depends="compile"
++ <target name="variant-jar" depends="compile-src"
+ description="Builds variant-${variant-version}.jar for inclusion in other projects">
+ <mkdir dir="${dist}"/>
+ <jar destfile="${dist}/variant-${variant-version}.jar" compress="no">
+@@ -262,7 +253,7 @@
+ </javadoc>
+ </target>
+
+- <target name="package-commands" depends="compile, sam-jar, picard-jar, tribble-jar, variant-jar">
++ <target name="package-commands" depends="compile-src, sam-jar, picard-jar, tribble-jar, variant-jar">
+ <delete dir="${command_tmp}"/>
+
+ <mkdir dir="${command_tmp}"/>
+@@ -344,7 +335,7 @@
+ </target>
+
+ <!-- ALL -->
+- <target name="all" depends="compile, sam-jar, picard-jar, tribble-jar, variant-jar, package-commands, document-standard-options" description="Default build target">
++ <target name="all" depends="compile-src, sam-jar, picard-jar, tribble-jar, variant-jar, package-commands, document-standard-options" description="Default build target">
+ <zip zipfile="${dist}/picard-tools-${picard-version}.zip">
+ <zipfileset dir="${dist}" includes="*.jar" prefix="picard-tools-${picard-version}"/>
+ <zipfileset dir="${lib}" includes="snappy*.jar"/>
+@@ -468,8 +459,6 @@
+ target="${javac.target}">
+ <classpath refid="@{compile.classpath}"/>
+ <compilerarg line="@{compiler.args}" />
+- <!-- ensure that Java 6 bootclasspath is used -->
+- <compilerarg value="-Xbootclasspath/p:${toString:java6.lib.ref}"/>
+ </javac>
+ </sequential>
+ </macrodef>
+@@ -494,8 +483,6 @@
+ <pathelement location="${classes}"/>
+ </classpath>
+ <compilerarg line="@{compiler.args}"/>
+- <!-- ensure that Java 6 bootclasspath is used -->
+- <compilerarg value="-Xbootclasspath/p:${toString:java6.lib.ref}"/>
+ </javac>
+ </sequential>
+ </macrodef>
diff --git a/sci-biology/picard/metadata.xml b/sci-biology/picard/metadata.xml
new file mode 100644
index 000000000000..265affea91d0
--- /dev/null
+++ b/sci-biology/picard/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/picard/picard-1.103.ebuild b/sci-biology/picard/picard-1.103.ebuild
new file mode 100644
index 000000000000..16e71f41f2b0
--- /dev/null
+++ b/sci-biology/picard/picard-1.103.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+WANT_ANT_TASKS="ant-apache-bcel dev-java/testng:0 ant-junit4"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java-based command-line utilities that manipulate SAM files"
+HOMEPAGE="http://picard.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/snappy:1.0
+ dev-java/cofoja:0
+ dev-java/commons-jexl:2
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.6
+ dev-java/ant-apache-bcel:0
+ test? (
+ dev-java/testng:0
+ dev-lang/R
+ )
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+EANT_BUILD_TARGET="all"
+EANT_TEST_TARGET="test"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="snappy-1.0,cofoja,commons-jexl-2,ant-core"
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},testng"
+
+java_prepare() {
+ mkdir "${S}"/lib || die
+
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+
+ mv "${S}"/src/java/net/sf/samtools/SAMTestUtil.java "${S}"/src/tests/java/net/sf/samtools || die
+}
+
+src_install() {
+ cd dist || die
+
+ for i in *-${PV}.jar; do
+ java-pkg_newjar $i ${i/-${PV}/}
+ rm $i || die
+ done
+
+ java-pkg_dojar *.jar
+ for i in *.jar; do
+ java-pkg_dolauncher ${i/.jar/} --jar $i;
+ done
+
+ use source && java-pkg_dosrc "${S}"/src/java/*
+ use doc && java-pkg_dojavadoc "${S}"/javadoc
+}
+
+src_test() {
+ java-pkg-2_src_test
+}