summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/qrna/qrna-2.0.3c-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/qrna/qrna-2.0.3c-r1.ebuild')
-rw-r--r--sci-biology/qrna/qrna-2.0.3c-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-biology/qrna/qrna-2.0.3c-r1.ebuild b/sci-biology/qrna/qrna-2.0.3c-r1.ebuild
new file mode 100644
index 000000000000..f8834630acee
--- /dev/null
+++ b/sci-biology/qrna/qrna-2.0.3c-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Prototype ncRNA genefinder"
+HOMEPAGE="http://selab.janelia.org/software.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ sci-biology/hmmer"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed \
+ -e "s:^CC.*:CC = $(tc-getCC):" \
+ -e "/^AR/s:ar:$(tc-getAR):g" \
+ -e "/^RANLIB/s:ranlib:$(tc-getRANLIB):g" \
+ -e "/CFLAGS/s:=.*$:= ${CFLAGS}:" \
+ -i {src,squid,squid02}/Makefile || die
+ rm -v squid*/*.a
+}
+
+src_compile() {
+ local dir
+ for dir in squid squid02 src; do
+ emake -C ${dir}
+ done
+}
+
+src_install () {
+ dobin src/{cfgbuild,eqrna,eqrna_sample,rnamat_main} scripts/*
+
+ newdoc 00README README
+ insinto /usr/share/doc/${PF}
+ doins documentation/*
+
+ insinto /usr/share/${PN}/data
+ doins lib/*
+ insinto /usr/share/${PN}/demos
+ doins Demos/*
+
+ # Sets the path to the QRNA data files.
+ doenvd "${FILESDIR}"/26qrna
+}