summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/recon/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/recon/files')
-rw-r--r--sci-biology/recon/files/1.06-buffer-overflow.patch13
-rw-r--r--sci-biology/recon/files/recon-1.06-respect.patch24
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/recon/files/1.06-buffer-overflow.patch b/sci-biology/recon/files/1.06-buffer-overflow.patch
new file mode 100644
index 000000000000..29d220c7310d
--- /dev/null
+++ b/sci-biology/recon/files/1.06-buffer-overflow.patch
@@ -0,0 +1,13 @@
+diff --git a/src/eledef.c b/src/eledef.c
+index 964890b..a001ec4 100644
+--- a/src/eledef.c
++++ b/src/eledef.c
+@@ -385,7 +385,7 @@ void ele_def(int method, FILE *frags, float cutoff, EPROT_t **all_epp, int *ecp,
+
+ void img_charge(IPROT_t **shadow, int ct, FILE *input) {
+ int i=0, pos=0;
+- char line[100];
++ char line[256];
+ int scan_flag;
+ MSP_t msp;
+
diff --git a/sci-biology/recon/files/recon-1.06-respect.patch b/sci-biology/recon/files/recon-1.06-respect.patch
new file mode 100644
index 000000000000..a02038d84784
--- /dev/null
+++ b/sci-biology/recon/files/recon-1.06-respect.patch
@@ -0,0 +1,24 @@
+ src/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 36ef59b..e45a0f2 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -13,14 +13,14 @@ MANDIR = $(HOME)/man
+ #SRCDIR = .
+
+ ## your compiler
+-CC = gcc
++CC ?= gcc
+ #CC = cc # for SGI Origin200 compiler#
+
+ ## any special compiler flags you want
+ # -pedantic clashes with -DMEMDEBUG??
+ #
+ #CFLAGS = -g -Wall -pedantic
+-CFLAGS = -O
++CFLAGS ?= -O
+ #CFLAGS = -g
+ #CFLAGS = -TARG:exc_max -64 -Ofast=ip27 #specific SGI Origin200 compiler#
+