summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-10-28 21:24:37 +0100
committerDavid Seifert <soap@gentoo.org>2018-10-28 21:24:37 +0100
commit18d496c1b4022e892aae9fcf3350b302b34357ed (patch)
tree44e751b790c150f7d3840939cdce8952b402800e /sci-biology/samtools
parentsci-libs/htslib: Version bump to 1.9 (diff)
downloadgentoo-18d496c1b4022e892aae9fcf3350b302b34357ed.tar.gz
gentoo-18d496c1b4022e892aae9fcf3350b302b34357ed.tar.bz2
gentoo-18d496c1b4022e892aae9fcf3350b302b34357ed.zip
sci-biology/samtools: Version bump to 1.9
Bug: https://bugs.gentoo.org/647714 Signed-off-by: David Seifert <soap@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sci-biology/samtools')
-rw-r--r--sci-biology/samtools/Manifest1
-rw-r--r--sci-biology/samtools/samtools-1.9.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index 8269a052050d..7ce21379a95d 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1,2 +1,3 @@
DIST samtools-0.1.20.tar.gz 566387 BLAKE2B a62d74c408877754af50f5e5fea0e2289ec1e0c9f25013ed0d039bfe8ef61108600d917f8c9d356e98aca632795b4eb0f01ea1b54526a652577fb74a38a433c2 SHA512 15bd8cf401d14c1ab4faa591b6054f5ea9731c4e966f37f71d33d9081a270cfeb91e8a3d80c631e0725b49da81387f824c206e8c21553ad554d0cfc5c238a6e5
DIST samtools-1.5.tar.bz2 4190142 BLAKE2B 1d3478f9adf76925a3721e145795ce4a4caf580244f5ba5bc1ddd14d1b13c723c6fddc24cdadf0a23ca5dcd7007a9985f54e7532cb15d5d9433b1164f5a22023 SHA512 ff3e39ba867ecbd88f3363b038508c1557e349ea4223483f8f4ecb17ff8864fb53cd193bc2059a147e30f07395bbf53c8518d0f70219e454375c8bffe56e3059
+DIST samtools-1.9.tar.bz2 4440405 BLAKE2B 409265fed9ff3fcd09096c968224499750da69324eeded754e367430c0f53f9246ccc9a31e166f13ea7bc767fefab499bcfda4d008d5ac82971984c67b533aff SHA512 6c8207754615ae8dad84b278f93e7d57eb40b818efb80f6aff6aba22fde5772247724e86596e765791e3175ffbb683393dd3ddfe7681c73eef4eb4f2342bf68f
diff --git a/sci-biology/samtools/samtools-1.9.ebuild b/sci-biology/samtools/samtools-1.9.ebuild
new file mode 100644
index 000000000000..bdcd115aafee
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1 toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-${PV}*
+ sys-libs/ncurses:0=
+ sys-libs/zlib:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/varfilter.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+
+ eautoreconf
+}
+
+src_test() {
+ local -x LD_LIBRARY_PATH="${S}"
+ default
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}