summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/trnascan-se
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/trnascan-se')
-rw-r--r--sci-biology/trnascan-se/Manifest2
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.23-glibc-2.10.patch292
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.23-ldflags.patch26
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch26
-rw-r--r--sci-biology/trnascan-se/metadata.xml12
-rw-r--r--sci-biology/trnascan-se/trnascan-se-1.23-r2.ebuild45
-rw-r--r--sci-biology/trnascan-se/trnascan-se-1.31.ebuild54
7 files changed, 457 insertions, 0 deletions
diff --git a/sci-biology/trnascan-se/Manifest b/sci-biology/trnascan-se/Manifest
new file mode 100644
index 000000000000..b82cf548c773
--- /dev/null
+++ b/sci-biology/trnascan-se/Manifest
@@ -0,0 +1,2 @@
+DIST trnascan-se-1.23.tar.bz2 482202 SHA256 a1d18a0b9decf4a93fa6cf02fb5867367729449fc8e47e3749c91678fc1f344a SHA512 4977febcecf8344fb77aad2eeb278637aebdb1d995fd26823e459b3767d4f40b20f57d343092cc2cb8024b0ccc385879f4b6406c69022f848aa1df0acf1a68d8 WHIRLPOOL 978328857eaef5666fcf38c22afabfb796984b5fa52a02a7167b653164ba0bc32fcb52d35159eef83732046245c598426739cd4ed63bf259ea85130dda17dd70
+DIST trnascan-se-1.31.tar.gz 740960 SHA256 862924d869453d1c111ba02f47d4cd86c7d6896ff5ec9e975f1858682282f316 SHA512 ba55bc8dfa7e5aee9c9a86c135a55b767cda083b74668bd9af4aaaeb693f9c3a17dc8bade5793de12b775564f09fbb861b0ab4f25bf83ccb0954fecd01bb328d WHIRLPOOL aef8b9f8d44799bac134a36af45374cdaba4b30c041e71e3095252aa8272fe9bd0aa76091211ac270ad609f67f388d577a83ec2ed2433997963fd5708c5b6665
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.23-glibc-2.10.patch b/sci-biology/trnascan-se/files/trnascan-se-1.23-glibc-2.10.patch
new file mode 100644
index 000000000000..e21da6e58db0
--- /dev/null
+++ b/sci-biology/trnascan-se/files/trnascan-se-1.23-glibc-2.10.patch
@@ -0,0 +1,292 @@
+diff -ur trnascan-se-1.23.orig/sqio.c trnascan-se-1.23/sqio.c
+--- trnascan-se-1.23.orig/sqio.c 2002-04-12 23:12:04.000000000 +0300
++++ trnascan-se-1.23/sqio.c 2009-08-05 21:45:53.000000000 +0300
+@@ -235,7 +235,7 @@
+ }
+
+ static void
+-getline(struct ReadSeqVars *V)
++get_line(struct ReadSeqVars *V)
+ {
+ readline(V->f, V->sbuffer);
+ }
+@@ -306,7 +306,7 @@
+ V->seqlen = 0;
+ if (addfirst) addseq(V->sbuffer, V);
+ do {
+- getline(V);
++ get_line(V);
+ done = feof(V->f);
+ done |= (*endTest)(V->sbuffer, &addend);
+ if (addend || !done)
+@@ -332,7 +332,7 @@
+ char *sptr;
+ /* load first line of entry */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ENTRY", 5) != 0)
+- getline(V);
++ get_line(V);
+ if (feof(V->f)) return;
+
+ if ((sptr = strtok(V->sbuffer + 15, "\n\t ")) != NULL)
+@@ -341,7 +341,7 @@
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_ID);
+ }
+ do {
+- getline(V);
++ get_line(V);
+ if (!feof(V->f) && strncmp(V->sbuffer, "TITLE", 5) == 0)
+ SetSeqinfoString(V->sqinfo, V->sbuffer+15, SQINFO_DESC);
+ else if (!feof(V->f) && strncmp(V->sbuffer, "ACCESSION", 9) == 0)
+@@ -350,7 +350,7 @@
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_ACC);
+ }
+ } while (! feof(V->f) && (strncmp(V->sbuffer,"SEQUENCE", 8) != 0));
+- getline(V); /* skip next line, coords */
++ get_line(V); /* skip next line, coords */
+
+ readLoop(0, endPIR, V);
+
+@@ -364,7 +364,7 @@
+ /* get next line
+ */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ENTRY", 5) != 0)
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -382,7 +382,7 @@
+ char *nm;
+ /* position past ';' comments */
+ do {
+- getline(V);
++ get_line(V);
+ } while (! (feof(V->f) || ((*V->sbuffer != 0) && (*V->sbuffer != ';')) ));
+
+ if (!feof(V->f))
+@@ -394,7 +394,7 @@
+ }
+
+ while (!(feof(V->f) || ((*V->sbuffer != '\0') && (*V->sbuffer == ';'))))
+- getline(V);
++ get_line(V);
+ }
+
+ static int
+@@ -416,7 +416,7 @@
+ if ((nm = strtok(V->sbuffer+16, ",\n\t ")) != NULL)
+ SetSeqinfoString(V->sqinfo, nm, SQINFO_NAME);
+ }
+- getline(V);
++ get_line(V);
+ }
+
+ if (! feof(V->f))
+@@ -425,7 +425,7 @@
+ /* load next line
+ */
+ while ((!feof(V->f)) && (*V->sbuffer != ';'))
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -443,7 +443,7 @@
+ int in_definition;
+
+ while (strncmp(V->sbuffer, "LOCUS", 5) != 0)
+- getline(V);
++ get_line(V);
+
+ if ((sptr = strtok(V->sbuffer+12, "\n\t ")) != NULL)
+ {
+@@ -454,7 +454,7 @@
+ in_definition = FALSE;
+ while (! feof(V->f))
+ {
+- getline(V);
++ get_line(V);
+ if (! feof(V->f) && strstr(V->sbuffer, "DEFINITION") == V->sbuffer)
+ {
+ if ((sptr = strtok(V->sbuffer+12, "\n")) != NULL)
+@@ -487,11 +487,11 @@
+
+
+ while (!(feof(V->f) || ((*V->sbuffer!=0) && (strstr(V->sbuffer,"LOCUS") == V->sbuffer))))
+- getline(V);
++ get_line(V);
+ /* SRE: V->s now holds "//", so sequential
+ reads are wedged: fixed Tue Jul 13 1993 */
+ while (!feof(V->f) && strstr(V->sbuffer, "LOCUS ") != V->sbuffer)
+- getline(V);
++ get_line(V);
+ }
+
+ static int
+@@ -521,12 +521,12 @@
+ if ((sptr = strtok(V->sbuffer+4, "\n\t ")) != NULL)
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_NAME);
+
+- getline(V); /*skip title-junk line*/
++ get_line(V); /*skip title-junk line*/
+
+ readLoop(0, endNBRF, V);
+
+ while (!(feof(V->f) || (*V->sbuffer != 0 && *V->sbuffer == '>')))
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -559,7 +559,7 @@
+ } else Die("bogus GCGdata format? %s", V->sbuffer);
+
+ /* second line contains free text description */
+- getline(V);
++ get_line(V);
+ SetSeqinfoString(V->sqinfo, V->sbuffer, SQINFO_DESC);
+
+ if (binary) {
+@@ -579,7 +579,7 @@
+ else readLoop(0, endGCGdata, V);
+
+ while (!(feof(V->f) || ((*V->sbuffer != 0) && (*V->sbuffer == '>'))))
+- getline(V);
++ get_line(V);
+ }
+
+ static int
+@@ -625,7 +625,7 @@
+ readLoop(0, endPearson, V);
+
+ while (!(feof(V->f) || ((*V->sbuffer != 0) && (*V->sbuffer == '>'))))
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -652,7 +652,7 @@
+
+ /* make sure we have first line */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ID ", 4) != 0)
+- getline(V);
++ get_line(V);
+
+ if ((sptr = strtok(V->sbuffer+5, "\n\t ")) != NULL)
+ {
+@@ -661,7 +661,7 @@
+ }
+
+ do {
+- getline(V);
++ get_line(V);
+ if (!feof(V->f) && strstr(V->sbuffer, "AC ") == V->sbuffer)
+ {
+ if ((sptr = strtok(V->sbuffer+5, "; \t\n")) != NULL)
+@@ -685,7 +685,7 @@
+
+ /* load next record's ID line */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ID ", 4) != 0)
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -701,7 +701,7 @@
+ {
+ char *sptr;
+
+- getline(V); /*s == "seqLen seqid string..."*/
++ get_line(V); /*s == "seqLen seqid string..."*/
+
+ if ((sptr = strtok(V->sbuffer+6, " \t\n")) != NULL)
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_NAME);
+@@ -712,7 +712,7 @@
+ readLoop(0, endZuker, V);
+
+ while (!(feof(V->f) | ((*V->sbuffer != '\0') & (*V->sbuffer == '('))))
+- getline(V);
++ get_line(V);
+ }
+
+ static void
+@@ -734,7 +734,7 @@
+
+ do {
+ done = feof(V->f);
+- getline(V);
++ get_line(V);
+ if (! done) addseq(V->sbuffer, V);
+ } while (!done);
+ }
+@@ -746,7 +746,7 @@
+ char *sptr;
+ int dostruc = FALSE;
+
+- while (strncmp(V->sbuffer, "NAM ", 4) != 0) getline(V);
++ while (strncmp(V->sbuffer, "NAM ", 4) != 0) get_line(V);
+
+ if ((sptr = strtok(V->sbuffer+4, "\n\t ")) != NULL)
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_NAME);
+@@ -754,7 +754,7 @@
+ /*CONSTCOND*/
+ while (1)
+ {
+- getline(V);
++ get_line(V);
+ if (feof(V->f)) {squid_errno = SQERR_FORMAT; return; }
+
+ if (strncmp(V->sbuffer, "SRC ", 4) == 0)
+@@ -786,14 +786,14 @@
+ while (1)
+ {
+ /* sequence line */
+- getline(V);
++ get_line(V);
+ if (feof(V->f) || strncmp(V->sbuffer, "++", 2) == 0)
+ break;
+ addseq(V->sbuffer, V);
+ /* structure line */
+ if (dostruc)
+ {
+- getline(V);
++ get_line(V);
+ if (feof(V->f)) { squid_errno = SQERR_FORMAT; return; }
+ addstruc(V->sbuffer, V);
+ }
+@@ -801,7 +801,7 @@
+
+
+ while (!feof(V->f) && strncmp(V->sbuffer, "NAM ", 4) != 0)
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -848,7 +848,7 @@
+
+ /* Load the first line.
+ */
+- getline(dbfp);
++ get_line(dbfp);
+
+ return dbfp;
+ }
+@@ -862,7 +862,7 @@
+ SeqfilePosition(SQFILE *sqfp, long offset)
+ {
+ fseek(sqfp->f, offset, SEEK_SET);
+- getline(sqfp);
++ get_line(sqfp);
+ }
+
+
+@@ -954,7 +954,7 @@
+ do { /* skip leading comments on GCG file */
+ gotuw = (strstr(V->sbuffer,"..") != NULL);
+ if (gotuw) readUWGCG(V);
+- getline(V);
++ get_line(V);
+ } while (! feof(V->f));
+ break;
+
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.23-ldflags.patch b/sci-biology/trnascan-se/files/trnascan-se-1.23-ldflags.patch
new file mode 100644
index 000000000000..783e4340823d
--- /dev/null
+++ b/sci-biology/trnascan-se/files/trnascan-se-1.23-ldflags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index 53e5c5b..a2d3feb 100644
+--- a/Makefile
++++ b/Makefile
+@@ -109,17 +109,17 @@ MPOBJ = mpviterbi.o mp-dbviterbi.o
+ all: $(PROGS) tRNAscanSE setpaths
+
+ covels-SE: $(OBJ) scan_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(RFLAGS) $(LDFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
+
+ coves-SE: $(OBJ) score_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(RFLAGS) $(LDFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
+
+ eufindtRNA: $(SQUIDOBJ) pavesi.o eufind_main.o
+- $(CC) $(CFLAGS) -o eufindtRNA eufind_main.o \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o eufindtRNA eufind_main.o \
+ pavesi.o $(SQUIDOBJ) $(LIBS)
+
+ trnascan-1.4: trnascan.o
+- $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4 trnascan.c
++ $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" $(LDFLAGS) -o trnascan-1.4 trnascan.c
+
+ tRNAscanSE:
+ $(PERLDIR)/$(PERLBIN) checkversion.pl
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch b/sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch
new file mode 100644
index 000000000000..f28b1e8f6bb0
--- /dev/null
+++ b/sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index 53e5c5b..a2d3feb 100644
+--- a/Makefile
++++ b/Makefile
+@@ -109,17 +109,17 @@ MPOBJ = mpviterbi.o mp-dbviterbi.o
+ all: $(PROGS) tRNAscan-SE setpaths
+
+ covels-SE: $(OBJ) scan_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(RFLAGS) $(LDFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
+
+ coves-SE: $(OBJ) score_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(RFLAGS) $(LDFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
+
+ eufindtRNA: $(SQUIDOBJ) pavesi.o eufind_main.o
+- $(CC) $(CFLAGS) -o eufindtRNA eufind_main.o \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o eufindtRNA eufind_main.o \
+ pavesi.o $(SQUIDOBJ) $(LIBS)
+
+ trnascan-1.4: trnascan.o
+- $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4 trnascan.c
++ $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" $(LDFLAGS) -o trnascan-1.4 trnascan.c
+
+ tRNAscan-SE:
+ $(PERLDIR)/$(PERLBIN) checkversion.pl
diff --git a/sci-biology/trnascan-se/metadata.xml b/sci-biology/trnascan-se/metadata.xml
new file mode 100644
index 000000000000..55de1683677f
--- /dev/null
+++ b/sci-biology/trnascan-se/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ tRNAscan-SE detects ~99% of eukaryotic nuclear or prokaryotic tRNA
+ genes, with a false positive rate of less than one per 15 gigabases,
+ and with a search speed of about 30 kb/second. It was implemented for
+ large-scale human genome sequence analysis, but is applicable to
+ other DNAs as well.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/trnascan-se/trnascan-se-1.23-r2.ebuild b/sci-biology/trnascan-se/trnascan-se-1.23-r2.ebuild
new file mode 100644
index 000000000000..aa8abf707262
--- /dev/null
+++ b/sci-biology/trnascan-se/trnascan-se-1.23-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="tRNA detection in large-scale genome sequences"
+HOMEPAGE="http://lowelab.ucsc.edu/tRNAscan-SE/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ sed -e "s%BINDIR = \$(HOME)/bin%BINDIR = ${EPREFIX}/usr/bin%" \
+ -e "s%LIBDIR = \$(HOME)/lib/tRNAscan-SE%LIBDIR = ${EPRFIX}/usr/$(get_libdir)/${PN}%" \
+ -e "s%MANDIR = \$(HOME)/man%MANDIR = ${EPREFIX}/usr/share/man%" \
+ -e "s%CC = gcc%CC = $(tc-getCC)%" \
+ -e "s%CFLAGS = -O%CFLAGS = ${CFLAGS}%" \
+ -i Makefile || die
+}
+
+src_install() {
+ mv tRNAscan-SE.man tRNAscan-SE.man.1 || die
+ dobin covels-SE coves-SE eufindtRNA tRNAscan-SE trnascan-1.4 || die
+ doman tRNAscan-SE.man.1 || die
+ dodoc MANUAL README Release.history || die
+ insinto /usr/$(get_libdir)/${PN}/
+ doins *.cm gcode.* Dsignal TPCsignal || die
+ insinto /usr/share/doc/${PF}
+ doins Manual.ps || die
+}
+
+src_test() {
+ make PATH="${S}:${PATH}" testrun || die
+}
diff --git a/sci-biology/trnascan-se/trnascan-se-1.31.ebuild b/sci-biology/trnascan-se/trnascan-se-1.31.ebuild
new file mode 100644
index 000000000000..aa9b3a03fd8f
--- /dev/null
+++ b/sci-biology/trnascan-se/trnascan-se-1.31.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+
+inherit eutils perl-module toolchain-funcs
+
+DESCRIPTION="tRNA detection in large-scale genome sequences"
+HOMEPAGE="http://lowelab.ucsc.edu/tRNAscan-SE/"
+SRC_URI="http://lowelab.ucsc.edu/software/tRNAscan-SE.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/tRNAscan-SE-1.3.1/
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed \
+ -e "s:BINDIR = \$(HOME)/bin:BINDIR = ${EPREFIX}/usr/bin:" \
+ -e "s:LIBDIR = \$(HOME)/lib/tRNAscan-SE:LIBDIR = ${EPRFIX}/usr/share/${PN}:" \
+ -e "s:MANDIR = \$(HOME)/man:MANDIR = ${EPREFIX}/usr/share/man:" \
+ -e "s:CC = gcc:CC = $(tc-getCC):" \
+ -e "s:CFLAGS = -O:CFLAGS = ${CFLAGS}:" \
+ -i Makefile || die
+
+ perl_set_version
+}
+
+src_test() {
+ emake PATH="${S}:${PATH}" testrun
+}
+
+src_install() {
+ dobin covels-SE coves-SE eufindtRNA tRNAscan-SE trnascan-1.4
+
+ newman tRNAscan-SE.man tRNAscan-SE.man.1
+
+ dodoc MANUAL README Release.history
+
+ insinto /usr/share/${PN}/
+ doins *.cm gcode.* Dsignal TPCsignal
+
+ dodoc Manual.ps
+
+ insinto ${VENDOR_LIB}
+ doins -r tRNAscanSE
+}