summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-25 11:24:17 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-25 11:39:01 +0200
commitbdf7251db30941f3912dd646d37fb125fbabf018 (patch)
treeb3e9888c3084c07f8dae49138903d10a53f4f546 /sci-biology/vcftools
parentapp-arch/snappy: x86 stable wrt bug #595026 (diff)
downloadgentoo-bdf7251db30941f3912dd646d37fb125fbabf018.tar.gz
gentoo-bdf7251db30941f3912dd646d37fb125fbabf018.tar.bz2
gentoo-bdf7251db30941f3912dd646d37fb125fbabf018.zip
sci-biology/vcftools: Version bump to 0.1.14
Gentoo-bug: 594924 * EAPI=6 * Properly RDEPEND on dev-lang/perl Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2407 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/vcftools')
-rw-r--r--sci-biology/vcftools/Manifest1
-rw-r--r--sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch50
-rw-r--r--sci-biology/vcftools/vcftools-0.1.14.ebuild39
3 files changed, 90 insertions, 0 deletions
diff --git a/sci-biology/vcftools/Manifest b/sci-biology/vcftools/Manifest
index acbb2140b6da..9a014b164251 100644
--- a/sci-biology/vcftools/Manifest
+++ b/sci-biology/vcftools/Manifest
@@ -1 +1,2 @@
+DIST vcftools-0.1.14.tar.gz 342369 SHA256 76d799dd9afcb12f1ed42a07bc2886cd1a989858a4d047f24d91dcf40f608582 SHA512 863a16b3b20d392deba7f04310af95f1ab21be537273692aa104e22d737af2eb1bc54a768af954f06188e0500e4f7a032d1189886eb3a439b108cb8189b14eb7 WHIRLPOOL 6de2e33a9882cb5567e2e22605a14851a7b1b458ec4152c87986ef8f49882e9af17e860f24ff40201905ca7d4a54bcfd4f8e8178509aca0bf65172d1c385d2c8
DIST vcftools_0.1.12b.tar.gz 631374 SHA256 9d2324512e9f1237d5cece74ba63965eb43643e9eada8685afe8217760a20a91 SHA512 803790c8ddbfec1b006a5ce5c6d1c2e0f468978eb96d5ee61d38b863df5752f8b89e0c936803d690491e2d1a898d237ec8772c01b7e9d1a138c610f3a1decbfd WHIRLPOOL 3198f10cd97021f1878b4e2ab1cda3c0038061d301a99a36b1482c8d7bcc5e706f01d0bf3a46634d48dd2e741700032870da2a1dfe7a65022e318d4dde4c8863
diff --git a/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch b/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch
new file mode 100644
index 000000000000..126a709385db
--- /dev/null
+++ b/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch
@@ -0,0 +1,50 @@
+* Add prefix in Makefiles, not the configure script
+* Use AC_SEARCH_LIBS instead of AC_CHECK_LIB,
+ as it is more flexible and helps us with LAPACK
+* Use correct ZLIB_CFLAGS instead of non-existent ZLIB_CPPFLAGS
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,7 +34,7 @@
+ [--with-pmdir=DIR],
+ [install Perl modules in DIR]),
+ [PMDIR=${withval}],
+- [PMDIR='${prefix}'/"$pmdir_relative_path"])
++ [PMDIR="$pmdir_relative_path"])
+
+ AC_SUBST([PMDIR])
+
+@@ -73,9 +73,9 @@
+ [pca=${enableval}],
+ [pca=no])
+
+-if test "x${pca}" = "xyes" ; then
+- AC_CHECK_LIB(lapack, dgeev_)
+-fi
++AS_IF([test "x${pca}" = "xyes"],[
++ AC_SEARCH_LIBS([dgeev_], [lapack])
++])
+
+ # Generate output.
+ AC_CONFIG_FILES([Makefile
+--- a/src/cpp/Makefile.am
++++ b/src/cpp/Makefile.am
+@@ -1,6 +1,6 @@
+ bin_PROGRAMS = vcftools
+
+-vcftools_CPPFLAGS = $(ZLIB_CPPFLAGS)
++vcftools_CPPFLAGS = $(ZLIB_CFLAGS)
+ vcftools_LDADD = $(ZLIB_LIBS)
+
+ vcftools_SOURCES = \
+--- a/src/perl/Makefile.am
++++ b/src/perl/Makefile.am
+@@ -24,7 +24,7 @@
+ vcf-tstv \
+ vcf-validator
+
+-pmdir = $(PMDIR)
++pmdir = $(exec_prefix)/$(PMDIR)
+
+ dist_pm_DATA = \
+ FaSlice.pm \
diff --git a/sci-biology/vcftools/vcftools-0.1.14.ebuild b/sci-biology/vcftools/vcftools-0.1.14.ebuild
new file mode 100644
index 000000000000..92814353f041
--- /dev/null
+++ b/sci-biology/vcftools/vcftools-0.1.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic perl-functions toolchain-funcs
+
+DESCRIPTION="Tools for working with VCF (Variant Call Format) files"
+HOMEPAGE="http://vcftools.sourceforge.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="lapack"
+
+RDEPEND="dev-lang/perl:=
+ lapack? ( virtual/lapack )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.14-buildsystem.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ perl_set_version
+
+ append-flags $($(tc-getPKG_CONFIG) --cflags lapack)
+ append-libs $($(tc-getPKG_CONFIG) --libs lapack)
+
+ econf \
+ $(use_enable lapack pca) \
+ --with-pmdir="${VENDOR_LIB#${EPREFIX}/usr}"
+}