summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-04 00:33:38 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-04 01:03:13 +0200
commit49f9e4a0c388e395c0cbf781ea7e3a9db8cc761b (patch)
tree6d75205dd2c935fbeff24d23fd1fb4c901484583 /sci-biology/yass
parentwww-misc/urlwatch: Clean up old. (diff)
downloadgentoo-49f9e4a0c388e395c0cbf781ea7e3a9db8cc761b.tar.gz
gentoo-49f9e4a0c388e395c0cbf781ea7e3a9db8cc761b.tar.bz2
gentoo-49f9e4a0c388e395c0cbf781ea7e3a9db8cc761b.zip
sci-biology/yass: Port to EAPI=6
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-biology/yass')
-rw-r--r--sci-biology/yass/yass-1.14-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/yass/yass-1.14-r2.ebuild b/sci-biology/yass/yass-1.14-r2.ebuild
new file mode 100644
index 000000000000..ff95e7410d5a
--- /dev/null
+++ b/sci-biology/yass/yass-1.14-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Genomic similarity search with multiple transition constrained spaced seeds"
+HOMEPAGE="http://bioinfo.lifl.fr/yass/"
+SRC_URI="http://bioinfo.lifl.fr/yass/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dmalloc lowmem threads"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dmalloc? ( dev-libs/dmalloc )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PV}-as-needed.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ $(use_enable lowmem lowmemory) \
+ $(use_with dmalloc)
+}